AUDESP

Gerador de Arquivos AUDESP

Tribunal de Contas do Estado de São Paulo

Através desse módulo é possível gerar os arquivos XML da AUDESP, ou liberar os dados para que o SCPI gere os arquivos.

Para o SCPI gerar os arquivos XML:

O SCPI gera arquivos para AUDESP desde 2008, portanto os contadores usuários do sistema já conhecem o método e já possuem o coletor AUDESP instalado em seus computadores. Nesse cenário o SIP disponibiliza suas funções de geração de arquivos AUDESP para o SCPI de modo que basta o usuário do RH liberar os dados para que esta operação seja realizada pela contabilidade, sendo desnecessário o tráfego de arquivos pela rede, o que aumenta a possibilidade de falhas, diminuindo, portanto o custo operacional da entidade.

Liberar dados para o SCPI:

Acesse o módulo "Regionais" através do módulo principal confome imagem abaixo.

Antes de gerar o arquivo é necessário preencher o número do município e o número da entidade no cadastro da empresa presente dentro do módulo SIP-AUDESP. Para isso acesse o botão "Cadastro" no menu ao lado, conforme imagem abaixo.

Além do cadastro da empresa é necessário alterar o cadastro de cargos conforme imagem abaixo.

Para gerar os arquivos acesse o botão "Gerar XML" conforme imagem abaixo.

Na tela que será aberta o usuário deve visualizar os relatórios disponíveis e caso todos estejam com dados a contento o usuário deve clicar no botão "Liberar Dados para Geração dos Arquivos pelo SCPI". Em seguida o usuário do SCPI poderá gerar os arquivos do SIP, pois a responsabilidade de checar os dados já foi exercida pelo departamento de recursos humanos.


SIPCON

SIPCON - Assistente de Configurações

Este módulo é destinado a configurações do terminal com o servidor. A configuração indicada neste assistente é armazenada no arquivo sipcon.ini, portanto este módulo é apenas um editor do arquivo.

Neste tópico a explicação sobre configuração em rede é mais abrangente já que por padrão o SIP é instalado como ambiente local e nenhuma configuração é necessária.

1. O primeiro parâmetro solicitado pelo assistente é de sistema operacional do servidor, essa informação influencia no caminho do banco de dados para conexão, pois o Firebird solicita o caminho dentro do servidor, já que trata-se de um serviço e não de compartilhamento. Mais detalhes sobre o caminho do banco de dados serão abordados no passo 4.

2. O segundo parâmetro pode ser ignorado no momento pois o SIP ainda não suporta outro banco de dados a não ser o Firebird.

3. Neste passo informe como é o ambiente em que o SIP está instalado. Existem duas opções.

· Rede

o ambiente de rede consiste em o SIP ter seu servidor de banco de dados e de aplicação instalados em um computador central chamado de servidor. Isso é necessário quando mais de um computador acessa o SIP.

· Local

o ambiente local é aquele em que o banco de dados e os módulos estão no mesmo computador. Mesmo instalado em apenas um computador o SIP ainda pode ser utilizado como muilti-usuário. Observe que se o computador estiver num ambiente de rede hipotético em que existe apenas um computador para cada departamento e o SIP é instalado apenas em um computador, o ambiente deve ser configurado como local.

4. A conexão com o banco de dados é feita com base nos parâmetros informados nesse passo. Deve-se observar o valor do parâmetro anterior, se o ambiente for rede então o campo nome do servidor deverá ser preenchido com o nome ou IP do computador-servidor, já se o ambiente for local então o nome deverá ser obrigatóriamente localhost.

Especial atenção deve ser dada ao caminho do banco de dados pois ele deve ser informado na estação como se fosse no servidor, portanto na hipótese em que o computador-servidor possui dois HDs ou duas partições e o SIP.FDB estiver instalado sob o de rótulo "D:" então o caminho na estação deverá ser "D:\Fiorilli\SIP_7\SIP_DADOS\SIP.FDB", mesmo que na estação os módulos estejam instalados em "C:\Fiorilli\SIP_7".

Outra hipótese que deve ser considerada é a de servidores baseados em Unix, neles o caminho dos arquivos é dado por barras normais e não existe letra rotulando HDs ou partições, mesmo assim numa estação Windows o SIPCON deverá ter seu caminho de banco de dados configurado com barras normais. Por exemplo, o SIP.FDB é alojado em "/home/Fiorilli/SIP_7/SIP_DADOS/SIP.FDB", esse caminho é o que deverá ser informado no SIPCON da estação Windows.

Observe também que nenhum compartilhamento deve ser criado para a pasta que armazena o SIP.FDB pois o Firebird é um serviço residente apenas no servidor e que opera, por padrão, na porta 3050, portanto a estação se comunica com o banco de dados Firebird através de porta e não através de compartilhamento, que se for feito comprometerá a segurança do arquivo de dados.

Na estação nenhum Firebird deverá ser instalado.

Já que o Firebird é um serviço e opera na porta 3050 o Firewall das estações e do servidor deve fornecer livre passagem por essa porta, que pode ser alterada se necessário.

Para alterar a porta que o Firebird opera basta editar o arquivo firebird.conf que está na pasta de instalação do Firebird. Procure pela linha "#RemoteServicePort = 3050" remova o símbolo sharp do começo da linha e altere o número da porta que está no fim da linha. Em seguida é necessário reiniciar o serviço do Firebird.

5. O quinto passo é a configuração de conexão com o SIP-Servidor. Para maiores informações sobre como configurá-lo acesse o tópico SIP-Servidor Instalação deste manual.

6. Com esta opção configurada todos os computadores que possuem o SIP instalado detectarão as novas versões baixadas na pasta indicada e se atualizarão automaticamente. Portanto esta opção será solicitada pelo assistente do SIPCON somente se ele foi configurado para ambiente de rede.

Neste caso um compartilhamento deve ser criado para a pasta SIP_ARQ e referenciado no SIPCON das estações nesse passo. Observe que a pasta SIP_ARQ está fóra da pasta SIP_DADOS garantindo a segurança do arquivo SIP.FDB.

Não importa em qual hipótese o SIP está instalado no servidor, se sob o rótulo "D:" ou se em Unix, neste campo o caminho do compartilhamento é que deverá ser informado. Por exemplo, "\\Servidor\SIP_ARQ".

Outras funções do SIPCON

Versão DLL: Existe um botão chamado "Versão DLL", é através dele que o suporte técnico verificará se a dll de comunicação com o Firebird é a correta.

Ping: O botão "Ping" serve para verificar se existe comunicação entre a estação e o servidor, independentemente de o Firebird estar instalado. Para estações com Windows Vista o SIPCON deve ser iniciado com elevação de privilégios.

Sobre: É através desse botão que o suporte técnico pode verificar a versão do SIPCON que está sendo utilizada.


SIPDEF

Após o download do módulo SIPDEF7.exe o SIPDownload irá abrir o assistente abaixo:

Caso a atualização esteja sendo feita a partir de uma estação de trabalho altere o diretório da tela acima para o caminho de rede correto, por exemplo: \\servidor\SIP_DADOS. Porém é recomendável que a atualização seja feita no servidor.

Atenção: recomenda-se que a pasta compartilhada que contém o banco de dados tenha no máximo três usuários com permissão de rede para acessá-la, pois não é necessário que todos os usuários tenham permissão de rede a referida pasta evitando assim problemas com segurança.

Siga os passos restantes do assistente para concluir a instalação da atualização do banco de dados.

Feche o SIP de todas as estações de trabalho que o utilizam.

Abra o SIP 7 em qualquer estação que ele verificará e atualizará os módulos e o banco de dados.

Atualização do Banco de Dados (SIPDEF)

A tela acima demonstra a conclusão do processo de atualização do banco de dados, clique em OK para que o SIP 7 continue a carregar.

Em alguns casos podem ocorrer erros durante a atualização.

Entre em contato com a Fiorilli, se possível já com um backup do sistema no nosso FTP .


Novidades

Nesta tela são listadas todas as novidades do SIP, isto é feito online, ou seja, nenhum arquivo local é lido, nem mesmo o banco de dados, estas informações estão disponíveis na internet e são acessadas com exclusividade pelo módulo SIP.


Site Oficial

Acesso www.fiorilli.com.br

Opção disponível no menu Atualização

Através dessa opção o usuário terá acesso ao site oficial da Fiorilli S/C Ltda. - Software em seu navegador padrão.


Atualizar SIP Download

Opção disponível no menu Atualização

O SIP Download é o módulo que realiza download de todos os outros módulos do SIP, menos dele mesmo. Para atualizar o atualizador, ou seja, para atualizar o SIP Download o usuário pode acessar esta opção.

Caso o módulo principal esteja indisponível o usuário pode acessar, através do Windows Explorer, o módulo DownloadSIPDOW.exe, ele iniciará a atualização do SIP Download imediatamente.

Porém todo esse trabalho é necessário apenas se algum problema estiver ocorrendo, pois o próprio SIP Download verifica a necessidade de sua atualização e chama o outro módulo para atualizá-lo mediante confirmação do usuário.


Instalação

Instalando o SIP 7

A seguir cada uma das opções serão explicadas e exemplificadas.

· Instalação Completa (Servidor) com Firebird

Utilize essa opção quando estiver instalando o SIP num microcomputador que será o servidor dedicado e que não tenha o firebird instalado.

Servidor dedicado é um microcomputador com windows server ou linux que autentica por domínio e que principalmente não é utilizado para trabalhos de nenhum departamento.

Apenas o módulo de backup e os arquivos de dados do SIP serão instalados.

· Instalação Completa (Servidor) sem Firebird

Utilize essa opção conforme item 1 porém o servidor já possua o firebird instalado, por exemplo, quando já existe uma instalação do SCPI devidamente configurada.

Esta opção também considera que o microcomputador é um servidor dedicado.

Apenas o módulo de backup e os arquivos de dados do SIP serão instalados.

· Instalação Completa (Estação)

Utilize essa opção quando tiver utilizado uma das duas opções de instalação anterior, mas que o microcomputador atual seja um terminal ou estação de trabalho.

Esta opção considera que nenhum banco de dados nem o firebird serão instalados, pois já se encontram no servidor dedicado. Apenas os módulos e atalhos serão instalados.

· Instalação Completa (Local) com Firebird

Utilize essa opção quando o departamento possui apenas um microcomputador.

Utilize essa opção quando não existe um servidor dedicado, mas o departamento possui mais de um computador e um deles será o servidor -> nesse computador utilize essa opção.

Atenção o Firebird será instalado.

Todos os arquivos de dados e todos os módulos e atalhos serão instalados.

· Instalação Completa (Local) sem Firebird

Utilize essa opção conforme subitens a e b do item 4

Atenção o Firebird não será instalado, ou seja, utilize num microcomputador que já possua o firebird como por exemplo um que já tenha o SCPI instalado.

Todos os arquivos de dados e todos os módulos e atalhos serão instalados.

· Apenas Firebird 1.5

Utilize essa opção para instalar ou reinstalar apenas o firebird.

Nenhum módulo ou atalho será instalado.

Nenhum arquivo de dados será instalado.

· Apenas Banco de dados do CBO

Utilize essa opção para substituir o arquivo de dados que contém o CBO – Código Brasileiro de Ocupações.

Isso pode ser necessário caso o arquivo seja corrompido ou apagado

Não existe nenhum módulo do SIP que possibilite manutenção nesse arquivo, ele é somente para consulta.

· Apenas Banco de dados do CEP

Utilize essa opção para substituir ou instalar o arquivo de dados que contém o CEP brasileiro.

Isso pode ser necessário caso o arquivo seja corrompido, apagado ou nunca tenha sido instalado pois ele é opcional.

Não existe nenhum módulo do SIP, ainda, que possibilite manutenção nesse arquivo, ele é somente para consulta.

· Apenas Banco de dados do SIP

Utilize essa opção para substituir ou instalar o arquivo principal de dados (base vazia).

Todos os módulos do SIP têm por finalidade incluir, alterar, excluir ou consultar dados desse arquivo.

· Apenas aplicativos/módulos

Utilize essa opção para substituir ou instalar os módulos e/ou os atalhos do SIP

Nenhum arquivo de dados será instalado.

O Firebird não será instalado.


Filtro

Filtro de Pesquisa

Instruções para utilização do Filtro de Pesquisa.

Para que serve:

Filtro é uma condição de restrição aos dados, isso significa que ele deve ser utilizado quando o usuário deseja obter um subgrupo do conjunto de dados disponíveis para telas de cadastro ou relatório. Uma condição de restrição aos dados é imposta campo a campo. Portanto se existirem mil trabalhadores cadastrados e o usuário deseja listar apenas os ativos, ele deverá utilizar o Filtro de Pesquisa para impor essa condição de restrição através do campo Situação.

Como funciona:

O Filtro de Pesquisa é separado em campos disponíveis e campos escolhidos, uma vez indicada a condição para o campo disponível ele deverá ser transportado para a lista de campos escolhidos, para isso basta pressionar o botão Adicionar. Em contrapartida o botão Excluir devolve um campo escolhido à lista de campos disponíveis. O botão Limpar, por sua vez, devolve todos os campos escolhidos à lista de campos disponíveis. Portanto é possível transportar quantos campos forem necessários à lista de campos escolhidos.

A lista de campos escolhidos é que determina a condição de restrição aos dados de forma geral.

Uma restrição aos dados de telas de cadastro ou relatório é definida campo a campo, cada um com sua condição, que pode ser uma das vinte elencadas abaixo:

1 | Igual | 11 | Preenchido
2 | Maior | 12 | Preenchido (Não)
3 | Maior/Igual | 13 | Sequência
4 | Menor | 14 | Intervalo (Não)
5 | Menor/Igual | 15 | que Comece (Não)
6 | Diferente | 16 | que Contenha (Não)
7 | Intervalo | 17 | que Termine (Não)
8 | que Comece | 18 | Sequência (Não)
9 | que Contenha | 19 | Mês Igual
10 | que Termine | 20 | Ano Igual

Vídeo de demonstração restrição aos dados do cadastro de trabalhadores para listar apenas os trabalhadores ativos (situação = 1).

Vídeo de Demonstração: passe o mouse

Exemplos de utilização de condições:

Item | Campo | Condição | Conteúdo
1 | Situação | Igual | 1
2 | Data de Admissão | Maior | 31/12/2008
3 | Data de Desligamento | Maior/Igual | 01/01/2009
4 | Data de Admissão | Menor | 01/01/2009
5 | Data de Desligamento | Menor/Igual | 31/12/2008
6 | Situação | Diferente | 6
7 | Nome | que Comece | João
8 | Nome | que Contenha | Aparecida
9 | Nome | que Termine | Silva
10 | Data de Desligamento | Preenchido | Conteúdo Indisponível
11 | PIS | Preenchido (Não) | Conteúdo Indisponível
12 | PIS | Igual |
13 | Matricula | Sequência | 100\209\1569
14 | Data de Nascimento | Mês Igual | 08
15 | Data de Admissão | Ano Igual | 2009
16 | Nome | que Contenha (Não) | Aparecida

Observações:

As condições "Preenchido" e "Preenchido (não)", itens 10 e 11, indisponibilizam a opção "Conteúdo", pois não é necessário já que a intenção é listar apenas os trabalhadores com data de desligamento informada, ou apenas os com PIS sem preencher, independente do que esteja informado no campo a fim de validar o cadastro, por exemplo.

A condição sequência deve ser preenchida com as opções entre barras contrárias. O exemplo 13 indica a intenção de listar apenas as matriculas aleatórias 100, 209 e 1569, portanto apenas elas serão listadas.

As condições "Mês Igual" e "Ano Igual" estão disponíveis apenas para campos do tipo Data.

Exemplos de utilização de condições especiais:

Item | Campo | Condição | Conteúdo
 |  |  | De | Até
17 | Data de Admissão | Intervalo | 01/01/2008 | 31/01/2008
18 | Data de Desligamento | Intervalo (Não) | 01/03/2009 | 31/03/2009
19 | Situação | Intervalo | 4 | 6

Note que todas as condições com a palavra "Não" entre parênteses indicam a intenção de negação. Portanto ao utilizar o exemplo 16 o usuário deseja listar os trabalhadores que não possuem a palavra "Aparecida" em seus nomes.

Essas foram as funcionalidades básicas do Filtro de Pesquisa, em seguida serão apresentadas as facilidades disponíveis.

Outras funções:

O Filtro de Pesquisa auxilia a digitação de vários tipos de dados, tais como campos com zeros à esquerda, data e valor monetário.

Em campos com zeros à esquerda, como o registro do trabalhador, por exemplo, o usuário pode digitar apenas os números válidos que o SIP preenche os zeros automaticamente.

Campos de valor monetário são alinhados à direita e possuem um botão de calculadora para contas, se necessário.

Por fim campos do tipo data podem ser preenchidos parcialmente que o SIP completará com os dados da data do computador, ou seja, se digitar apenas um número de dois dígitos o SIP entenderá que trata-se do dia e assumirá mês e ano atual. Se digitar dia e mês o SIP preencherá com o ano atual.

O Filtro de Pesquisa exibe um botão ao lado do conteúdo em que o campo selecionado é passível de ser escolhido numa lista, o código do cargo atual, a unidade de custeio, a referência salarial e o código do evento são exemplos de campos que disponibilizam lista de seleção, o que facilita e dinamiza a operação do Filtro de Pesquisa.

Portanto ao clicar no botão que aparece ao lado conteúdo o usuário poderá escolher numa lista qual ou quais itens deseja enviar ao Filtro de Pesquisa. Se selecionado mais de um item o próprio Filtro de Pesquisa transforma a condição em "Sequência".

Várias vezes ao dia um usuário pode executar a mesma pesquisa por diversos motivos, as condições recorrentes podem ser salvas para serem utilizadas sempre que necessário, ou seja, independente da estação de trabalho que o usuário estiver logado o SIP irá disponibilizar o filtro salvo para a tela em questão.

Salvar um filtro é muito simples e não requer informações complementares, o sistema apenas emite um aviso que o filtro foi salvo.

Abrir um filtro é tão simples quanto salvá-lo, basta escolher na lista apresentada com base nas opções desejadas. Porém o botão abrir tem uma função oculta muito útil, trata-se do clique com o botão direito do mouse, caso ele seja executado o SIP irá carregar o último filtro salvo sem a necessidade de abrir a tela de seleção de filtros salvos.

Por fim o filtro de pesquisa disponibiliza um menu de contexto sobre os campos disponíveis para que seja possível filtrar, caso o usuário tenha dificuldades em localizar o nome na lista de campos disponíveis. Uma tabela numerada contendo os campos será apresentada ao utilizar o menu de contexto ou ao pressionar a tecla de atalho "Control + F".


Telas de Cadastro

Telas de Cadastro Padronizadas

Instruções genéricas para todas as telas de cadastro do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, o resultado disso é que basta o usuário treinar uma tela do sistema para saber operar todas as outras.

Existe apenas uma pequena diferença entre algumas telas, trata-se do Filtro de Pesquisa , pois ele é omitido em telas que geralmente possuem poucos registros de dados, tais como o cadastro da empresa ou as faixas de previdência. Cadastros que são considerados de grande volume de dados apresentam a opção de filtragem.

O cadastro de trabalhadores, em especial, possui inteligência para omitir a tela de filtro com base no tempo de resposta avaliado quando do fechamento da folha mensal. O parâmetro que o cadastro de trabalhadores verifica é se é possível listar todos os registros ativos em menos de meio segundo, se isso for possível, ele omitirá a tela de filtro. Mas ainda será possível efetuar filtros se necessário, para isso basta clicar no botão voltar.

a) Toda tela de cadastro com filtro disponibiliza o botão "Incluir" junto com o botão pesquisar, de modo que não é necessário listar dados para depois incluir.

b) Toda tela de cadastro com filtro disponibiliza o botão "Voltar" junto com o botão imprimir, de modo que é possível trocar o filtro de pesquisa depois de visualizar o resultado.

Após realizado um Filtro de Pesquisa todas as telas são iguais, elas são divididas em três partes. A parte superior possui os botões incluir, alterar, excluir, imprimir e de navegação. Na parte central há a lista de dados, que pode ser chamada, também, de tabela. Por fim na parte inferior há o total de registros listados, o botão de Validação de Campos , o botão de Notas e Lembretes e o botão para fechar.

Existe ainda uma padronização nos chamados Campos de Referência, que são aqueles que disponibilizam o código e o sistema retorna o nome referente. Um exemplo deles é o campo evento no lançamento de eventuais, basta o usuário digitar o código do evento que o SIP mostra o nome.

Se o usuário não souber o código, basta pressionar F3 que terá o mesmo efeito que clicar no botão ao lado.

Teclas de atalho:

Tecla | Função
F5 | Pesquisar, Gravar ou Selecionar
Insert | Incluir
Delete | Excluir se cursor na lista de dados
F3 | Pesquisar Campos de Referência
ESC | Cancelar Inclusão/Alteração ou Fechar
Enter | Salta entre campos ou Altera Registro
TAB | Salta entre campos

F3:

Quando o cursor estiver posiconado dentro de um campo de referência e o usuário não souber o que digitar basta pressionar F3 que terá o mesmo efeito que clicar no botão ao lado. Uma lista contendo todos os eventos será apresentada para que o usuário selecione um deles. Em muitos casos esse botão leva o usuário à tela de cadastro do referido campo, no exemplo do código do evento o SIP apresentará o próprio cadastro de eventos, dessa forma o usuário poderá criar um evento e utilizá-lo imediatamente.

F5:

Caso a tela de cadastro esteja na fase de filtragem essa tecla terá o mesmo efeito que pessionar o botão "Pesquisar".

Se a tela de cadastro estiver na fase de inclusão ou alteração essa tecla terá o mesmo efeito que pressionar o botão "Gravar".

Quando telas de cadastro são mostradas para selecionar um item, como é o caso do atalho F3, essa tecla terá o mesmo efeito que pressionar o botão "Selecionar", que é apresentado abaixo da lista de dados (tabela).

ESC:

Se a tela de cadastro estiver posicionada em modo de inclusão ou alteração esta tecla terá o mesmo efeito que o botão "Cancelar", do contrário a tecla ESC fechará a tela de cadastro.

Enter:

Esta tecla tem o mesmo efeito ta tecla TAB, ou seja, ela salta o cursor para o próximo campo, porém se o usuário estiver manipulando uma lista de dados e pressionar a tecla Enter ela terá o mesmo efeito que o botão "Alterar".

O botão "Excluir" possui uma funcionalidade oculta que possibilita a exclusão de todos os itens listados no momento. Para isso é necessário que o usuário clique com o botão direito do mouse sobre o botão "Excluir", um pequeno menu de contexto será exibido e o usuário deverá clicar sobre ele.

LOG:

Todo cadastro do SIP escreve um LOG das operações que o usuário efetuou. Todos os registros de dados manipulados serão gravados no LOG, portanto uma inclusão é armazenada integralmente, numa alteração são guardados os dados alterados e os novos dados que os substituíram, campo a campo, por fim a exclusão guarda campo a campo os dados dos registros excluídos.

Além de dados o SIP armazena no LOG as perguntas feitas ao usuário, as respostas que ele indicou e seus efeitos em todo o sistema, independente de ser em tela de cadastro ou não.

Imprimir:

O botão imprimir leva o usuário a outra tela para selecionar os diversos tipos de layouts disponíveis para aquela tela de cadastro. Nela serão apresentadas opções para visualizar impressão, imprimir direto à impressora, controlar layouts e voltar.

É possível criar vários layouts derivados para cada relatório disponibilizado pelo SIP. Portanto o comportamento do botão "Layouts" será influenciado pelo relatório selecionado. Todo layout criado pode ser encontrato através do Painel de Opções. Para mais informações sobre alteração de layout, clique aqui .

Lista de dados:

Lista de dados, tabela e grid são sinônimos. O SIP sempre apresenta a mesma grid em todo o sistema, ela é visualmente padronizada, possui ordenação e busca. Para ordenar por um campo basta clicar sobre o título dele, se o campo já estiver ordenado de forma crescente a grid do SIP irá ordená-lo de forma decrescente. A busca da grid é muito simples, caso o usuário esteja navegando sobre ela é só digitar algum texto que ela tentará localizar seus dados com base no campo indicado.

Demonstração: passe o mouse

Menu de Contexto da lista de dados:

Menu de contexto é a lista de opções apresentada quando o usuário clica com o botão direito do mouse sobre um item de tela. A lista de dados é um item de tela e possui um menu de contexto.

O menu de contexto apresentado acima pertence a telas com opção de Filtro de Pesquisa . Telas de pouco volume de dados não possuem opção de filtragem e seu menu de contexto possui apenas os quatro primeiros itens.

As opçãos Incluir, Alterar e Excluir são exatamente as mesmas funções que os botões de mesmo nome, já a opção de atualizar está presente apenas aqui e deve ser utilizada quando o usuário sabe que outra estação de trabalho alterou algum dado da mesma tela.

A opção "Ir Para" tem a mesma função que a busca da grid , e deve ser utilizada como sua extensão uma vez que a grid permite localizar pelos campos hora mostrados, já o "Ir Para" disponibliza uma lista com todos os campos disponíveis, os mesmos campos presentes no Filtro de Pesquisa .

Telas com opção de filtragem permitem ainda a alteração do comando SQL da tela, essa opção deve ser utilizada quando o filtro do usuário ultrapassa o limite da capacidade da tela de filtragem do SIP. Para isso estão presentes as opções "Copiar SQL" e "Colar SQL". A primeira delas consiste em enviar à Area de Transferência do Windows o comando SQL da tela, em seguida o usuário pode "Colar: Control+V" o comando em qualquer editor de textos ou até mesmo na tela de Consulta SQL , pode editar o SQL e utilizar a segunda opção, a de colar o SQL, este sendo válido o SIP irá apresentar seu resultado na lista de dados.

SQL inválido será tratado de duas formas. A primeira é se o comando for incompatível com a tela, neste caso o usuário teria alterado os campos ou as tabelas do comando, o SIP emitirá um aviso e o usuário poderá refazer a operação. A segunda forma é a detecção de comando malicioso, chamado também de SQL Injection. Caso este último seja detectado o SIP irá gravar um log da operação contendo o comando, a tela, o usuário e outros dados.

Outra opção do menu de contexto é a Ordem, através dela é possível ordenar os dados através de mais de um campo, o que não seria possível através da própria grid.

A última opção padrão do menu de contexto é a Grid, através dela é possível aterar as colunas da lista de dados, feito isso o SIP salva essa alteração em nome daquele usuário, sempre que ele acessar aquela tela, independente da estação de trabalho, o SIP irá apresentar a lista de dados com aquele arranjo de colunas.

Imprimir a lista de dados:

A lista de dados, ou tabela, apresentada como resultado da pesquisa pode ter suas colunas e sua ordenação alterados, em seguida essa personalização pode ser emitida como relatório através do menu de contexto, observe a imagem abaixo.

Para mais informações sobre impressão da lista de dados, clique aqui.

Algumas telas excedem os itens padrões do menu de contexto e disponibilizam opções adicionais que dinamizam a utilização do SIP, como pode ser observado na imagem acima, a manutenção de lançamento de eventuais apresenta a opção de abrir o cadastro de trabalhadores já com o registro selecionado filtrado, ou até mesmo os dados do evento selecionado.


Notas e Lembretes de Campos

Personalizado pelo Usuário

Instruções genéricas para todas as telas de cadastro do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, o resultado disso é que basta o usuário treinar uma tela do sistema para saber operar todas as outras. Para mais informações sobre telas de cadastro padronizadas, clique aqui .

Todas as telas de cadastro do SIP possuem o botão de notas e lembretes de campos, através dele é possível criar observações para que todos os usuários do SIP padronizem a digitação de determinados campos.

O resultado da configuração pode ser observado na imagem abaixo.


Alterar Layout

Alteração de layout de relatórios do SIP

É necessário conhecer o Gerador de Relatórios

O SIP permite que o usuário altere o layout de todos os relatórios do sistema. Os relatórios que o SIP disponibiliza por padrão são todos baseados no Gerador de Relatórios , portanto basta conhecê-lo para saber alterar os layouts do SIP.

As alterações de layout estão disponíveis para as telas de cadastro e relatório.

Alteração de layout é na verdade uma inclusão de layout com base no padrão fornecido pelo SIP, o usuário pode incluir quantas alterações forem necessárias, mas ainda assim o layout original padrão nunca se perde.

Funções da Tela de Relação de Layouts

Incluir:

Original...: Consiste em derivar um novo layout a partir do já disponibilizado pelo SIP.

Importar...: Importa arquivos de layout enviados pelo suporte técnico.

Selecionado...: É possível derivar outro layout a paritr de um já criado pelo usuário.

Modelo...: Cria novo layout a partir dos modelos disponíveis no Gerador de Relatórios.

Laser...: Apresenta novo layout apenas com cabeçalho e rodapé padrão do SIP.

Matricial...: Apresenta novo layout apenas com cabeçalho e rodapé padrão do SIP.

Alterar:

Abre o ambiente de layout do Gerador de Relatórios com o layout selecionado pronto para alteração.

Excluir:

Exclui o layout selecionado.

Padrão:

Indica que o layout selecionado será o novo layout padrão para a tela, mesmo assim o layout padrão do SIP não se perde.

Exportar:

Salva o layout slecionado em arquivo numa pasta indicada pelo usuário.

Selecionar Layout Original:

Embora o layout padrão original fornecido pelo SIP não esteja na lista ele ainda pode ser selecionado, basta clicar neste botão.

Dica:

Uma alteração de layout interessante que pode ser feita em telas que utilizam o Filtro de Pesquisa é incluir um objeto texto com o campo "Parâmetros Selecioandos" do objeto de dados "frdsCabecalho" no cabeçalho do relatório. Isso fará com que o objeto texto imprima a descrição detalhada dos parâmetros selecionados.

Existe somente uma pequena diferença entre layouts de cadastro e de relatório

Além dos layouts prontos que o SIP disponibiliza nas telas de cadastro o usuário pode manter uma lista de layouts independentes do item de relatório selecionado a partir da opção "Relatórios do Usuário".

Para saber mais sobre telas de cadastro clique aqui .


Impressão de Grid

Imprimir Lista de Dados ou Tabela (Grid)

Grid Personalizada pelo Usuário

Instruções genéricas para todas as telas de cadastro do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, o resultado disso é que basta o usuário treinar uma tela do sistema para saber operar todas as outras. Para mais informações sobre telas de cadastro padronizadas, clique aqui .

Lista de dados, tabela e grid são sinônimos. O nome deste recurso no menu de contexto das telas de cadastro foi denominado como Grid, portanto esse é o nome que utilizaremos a partir de agora.

Ao clicar com o botão direito do mouse sobre a lista de dados na tela de resultados da pesquisa o menu de contexto disponibilizará vários recursos, alguns deles serão detalhados a seguir.

Um dos recursos que o menu de contexto expõe é a alteração das colunas da tabela de dados através da opção "Grid". Ao clicar nesta opção uma pequena tela contendo duas listas será apresentada. À esquerda estão os campos disponíveis, exatamente os mesmos campos disponíveis do Filtro de Pesquisas , à direita estão os campos que compõem a Grid atual. Através da interação entre os dois lados o usuário poderá personalizar sua lista de dados.

Concluída a personalização das colunas o usuário pode alterar a ordem dos registros de dados. Para isso acesse a opção Ordem no menu de contexto .

Ao impor uma ordem aos dados é possível fazê-lo utilizando vários campos. Para isso a tela que será apresentada para personalizar a ordem é ligeiramente diferente da tela de alteração de colunas. A única diferença é que a lista da direita, ou seja, os campos em ordem, terão um botão de checagem ao lado que deve ser utilizado somente para criar agrupamentos no relatório emitido pela opção "Grid".

Finalmente é possível de fato imprimir a lista de dados através do menu de contexto, para isso acesse a opção conforme mostra a imagem abaixo.

Ao imprimir o SIP solicitará o nome do relatório através da caixa de diálogo abaixo. O texto será previamente preenchido com o nome da tela atual como sugestão. Caso o usuário cancele o diálogo abaixo o SIP não cancelará a impressão, apenas assumirá o nome do relatório como sendo o título da tela atual.

Outras funções:

O SIP salva automaticamente as colunas personalizadas para o usuário logado e sempre que ele retornar à tela, independente da estação de trabalho, o SIP mostrará as mesmas colunas. Para Restaurar as Colunas basta acessar o menu de contexto conforme a imagem acima.

A opção Operações consiste na possibilidade de o usuário determinar o tipo de agregação de campos numéricos. O SIP, por padrão, indica o tipo soma de agregação para todos os campos numéricos. Portanto o usuário deve acessar essa opção quando deseja alterar a escolha do SIP. As opções disponíveis são soma, média, mínimo, máximo e nenhum.

Salvar Layout no Gerador de Relatórios é a opção indicada para casos em que o relatório é mais complexo do que o suportado pela opção "Grid", embora ela seja capaz de criar vários agrupamentos com totalização individual e geral e possui inteligência para acomodar os objetos texto no papel. Esta última capacidade segue o seguinte critério: se a soma das larguras das colunas for maior que uma folha A4 em retrato o papel é alterado para paisagem, porém se a soma for menor o campo nome será expandido, caso ele exista.

Para salvar o layout no Gerador de Relatórios o SIP solicitará três informações:

1. Título do relatório;

2. Nome do relatório no Gerador de Relatórios, pois o título pode ser formal e o nome informal.

3. A pasta em que o layout será salvo dentro do Gerador de Relatórios. Caso ainda não haja uma pasta o usuário poderá criá-la.


Ordem e Agrupamento por Caixa de Diálogo

Ordem e Agrupamento

Opções através de caixa de diálogo

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de ordenção, o resultado disso é que basta o usuário treinar um mecanismo do sistema para saber operar todos os outros.

Ao impor uma ordem aos dados é possível fazê-lo utilizando vários campos. O SIP disponibiliza uma caixa de diálogo em que o usuário encontrará duas listas paralelas, do lado esquerdo são apresentados os campos disponíveis, do lado direito os campos em ordem.

Para transferir os campos desejados da lista de campos disponíveis para a lista de campos em ordem o usuário deve clicar no botão "Adicionar". Para remover um item ou todos de uma vez, basta o usuário clicar nos botões "Remover Item" e "Remover Todos", respectivamente. Por fim o usuário pode alterar a ordem dos campos através dos botões "Trocar Ordem para Cima" e "Trocar Ordem para Baixo".

Outro recurso para manipular os campos é o de arrastar e soltar, portanto basta o usuário arrastar os campos de uma lista à outra para ter o mesmo efeito de "Adicionar" e "Remover".

Agrupamentos são definidos através do botão de checagem disponível eventualmente ao lado dos campos em ordem. Na imagem abaixo um exemplo de agrupamento pode ser verificado através dos campos "Divisão", "Subdivisão" e "Unidade/Custeio".


Ordem e Agrupamento Simples

Ordem e Agrupamento

Opções mais frequêntes

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de ordenção, o resultado disso é que basta o usuário treinar um mecanismo do sistema para saber operar todos os outros.

Ao impor uma ordem aos dados é possível fazê-lo utilizando vários campos. Este mecanismo disponibiliza os campos mais utilizados de forma simples, pois a opção de caixa de diálogo é tida como mais avançada.

Para selecionar um agrupamento basta o usuário clicar no botão de checagem dos itens "Divisão", "Subdivisão", "Unidade", "Local Trabalho", "Vinculo" e/ou "Cargo", este último pode ser alterado ao longo das telas do SIP em que o usuário pode encontrar vários campos além do cargo tais como a referência salarial, a categoria funcional ou até mesmo um tipo de documento.

Após selecionar o agrupamento, que é opicional, o usuário pode selecionar a ordem dos dados dentro de cada agrupamento, essa ordem pode ser através de um único campo. O usuário poderá escolher entre os campos "Registro", "Matricula" ou "Nome".

Abaixo o usuário pode verificar um exemplo do resultado da ordenação.


Validação de Campos

Personalizado pelo Usuário

Instruções genéricas para todas as telas de cadastro do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, o resultado disso é que basta o usuário treinar uma tela do sistema para saber operar todas as outras. Para mais informações sobre telas de cadastro padronizadas, clique aqui .

Todas as telas de cadastro do SIP possuem o botão de validação de campos, através dele é possível personalizar os campos que o usuário deseja que sejam obrigatórios ou de preenchimento recomendado.

A configuração informada será gravada para todas as empresas presentes no arquivo de dados. Portanto não é por empresa, nem é por usuário, é apenas por tela de cadastro.


CEP

Instruções para utilização do CEP.

O SIP dispõe de um banco de dados exclusivo do correio para consultar o endereço a partir do número do CEP informado. Sempre que uma tela de cadastro solicitar dados de endereço o usuário utilizará os mecanismos do SIPCEP.

A imagem abaixo ilustra o conjunto de dados solicitados para endereços.

Ao informar o número do CEP o SIP realiza a busca do endereço no banco de dados do correio (SIPCEP.FDB), caso o endereço seja encontrado o SIP preenche os campos conforme os dados recuperados, basta por fim o usuário informar o número do endereço e o complemento.

Além de encontrar o endereço com base no número do CEP o SIP também procura o CEP com base no endereço, para isto o usuário deve informar o logradouro, a cidade e o estado no próprio cadastro, em seguida deve clicar no link "Encontrar CEP" localizado acima do campo logradouro.

Caso o SIP encontre um único endereço, este é preenchido nos campos do cadastro. Porém quando o SIP encontra mais de um número de CEP uma mensagem é exibida e o usuário deve escolher entre os números listados abaixo do campo CEP. A imagem a seguir ilustra esta situação.

Ao escolher entre os números de CEP listados o usuário obterá os dados de endereço do cadastro preenchidos conforme recuperados do banco de dados do CEP.


Tela de Relatório

Telas de Relatório Padronizadas

Instruções genéricas para todas as telas de relatório do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de relatório, o resultado disso é que basta o usuário treinar uma tela do sistema para saber operar todas as outras.

Existe apenas algumas pequenas diferenças entre elas, tratam-se de parâmetros de filtragem ou opções de visualização do relatório a ser emitido. A imagem abaixo ilustra as opções genérias de emissão de relatórios.

Na parte superior da tela há o título, presente em todos os relatórios, em seguida há a faixa que corresponde a referência selecioanda, esta faixa é exibida apenas para relatórios que levam em consideração a referência, pois existem relatórios que não utilizam a referência selecionada, um exemplo deles é a ficha financeira do trabalhador .

No centro está disponível a área específica de cada relatório em que o SIP disponibiliza as opções de filtragem e visualização do relatório.

Por fim, na parte inferior da tela há o botão "Visualizar" que emite o relatório em tela, o botão "Imprimir" que emite o relatório diretamente para a impressora a deverá ser selecionada, o botão "Layouts" que controla os diversos layouts que o usuário pode criar, o botão "Exportar" que apresentará as diversas opções de exportação iguais as do Gerador de Relatórios , e o botão "Fechar" que encerrará a tela de relatório.

A visualização dos relatórios do SIP também é padronizada, a imagem abaixo ilustra as opções disponíveis.

1. Emitir relatório à impressora (selecionar impressora)

2. Localizar palavra ou texto no conteúdo do relatório

3. Atualizar o relatório

4. Configurar Página

5. Opções de Exportação

6. Zoom

7. Primeira Página

8. Página Anterior

9. Página Atual/Total de Páginas

10. Próxima Página

11. Última Página

12. Layout

13. Exibir/Ocultar Árvore de Contexto

14. Exibir/Ocultar Miniaturas

15. Fechar Visualização do Relatório

16. Indicador de alteração de layout


Telas de Cálculo

Telas de Cálculo Padronizadas

Opção disponível no menu Cálculo

Instruções genéricas para todas as telas de cálculo do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cálculo, o resultado disso é que basta o usuário treinar uma tela do sistema para saber operar todas as outras.

Existe apenas algumas pequenas diferenças entre elas, tratam-se de parâmetros de filtragem ou parâmetros de cálculo que auxiliam e dinamizam a utilização das telas. A final de contas são oito tipos de cálculo e alguma diferença entre eles é inevitável.

Basicamente todas as tela de cálculo funcionam do mesmo jeito, elas são divididas em duas partes, a primeira disponibiliza o Filtro de Pesquisa , a data de fechamento, a data de pagamento e condições de continuação de cálculo abortado. A segunda parte consiste nos resultados do cálculo, que representam um holerite dinâmico em que o usuário pode interagir com os eventos e suas bases de cálculo a fim de conferir os valores apurados. Todas as funções de checagem do cálculo serão abordadas mais adiante.

Filtro de Pesquisa

No filtro de pesquisa o SIP disponibiliza campos dos mais restringentes, tais como registro, PIS, CPF, aos mais abrangentes tais como cargo, vinculo e unidade. Com eles o usuário pode separar o cálculo em etapas que abrigam diferentes tipos de trabalhadores, por exemplo, o usuário deseja calcular primeiro todos os admitidos no mês, em seguida deseja calcular apenas os com prazo determinado que findam no mês, etc.

O filtro de pesquisa das telas de cálculo é auxiliado por parâmetros de filtragem extra, eles são disponibilizados quando a filtragem se torna complicada para ser inserida na lista de campos disponíveis. Na tela do cálculo mensal, por exemplo, existem dois parâmetros de filtragem extra, um para filtrar apenas trabalhadores que possuem informações de afastamento e outro para filtrar apenas trabalhadores que receberam férias. Existe ainda um filtro que está presente em todas as telas e tem efeito apenas sobre os resultados, trata-se do filtro de apenas congelados, com esse filtro o usuário pode conferir apenas os trabalhadores que foram congelados.

Condições para continuação de cálculo abortado

O cálculo pode ser abortado de três formas, a primeira é através de um erro grave no cálculo, a segunda é através de problemas na infraestrutura de informática e o terceiro é pela intenção do usuário através do botão "Cancelar".

Independente da forma o usuário pode continuar o cálculo de onde parou, basta para isto indicar o item imediatamente anterior ao parado. Observe a imagem abaixo, nela o SIP mostra 134 trabalhadores calculados do total de 809. Se um erro tivesse ocorrido ou o usuário tivesse cancelado intencionalmente, o trabalhador de item 134 é quem ficou com o cálculo incompleto. Note que o item é independente da matricula, pois a matricula é 308 mas o item é 134.

Resultados do cálculo

Após definir os parâmetros desejados o usuário pode calcular ou visualizar os resultados. Ao visualizar o SIP apresenta outra tela no lugar dos parâmetros. A tela de resultados contém a lista de trabalhadores que satisfazem os parâmetros de filtragem. Para cada registro selecionado nessa lista o SIP mostra o holerite dinâmico ao lado.

Todas as informações mostradas nesta parte da tela têm a intenção de auxiliar a checagem do cálculo. Na parte superior o SIP mostra dados cadastrais, dentre eles, o vinculo e a carga horário que influenciam diretamente o resultado. Na parte inferior o SIP mostra as bases de cálculo dos encargos, além dos totais de proventos, descontos e liquido.

Os dados hora visualizados podem ser impressos, para isto o usuário deve clicar no botão "Imprimir", em seguida deve clicar na opção "Extrato", uma tela de visualização de relatório será exibida contendo o máximo de informações possíveis para auxiliar a checagem do cálculo pelo papel, nesse extrato além de valores e bases o SIP mostra as movimentações de afastamento e/ou de férias.

O usuário pode imprimir, também, a lista dos trabalhadores do cálculo, para isto deve clicar no botão "Imprimir", em seguida deve clicar na opção "Listagem", uma tela de visualização de relatório será exibida contendo a lista de trabalhdores com as informações de afastamento e/ou férias.

Além do extrato acima mencionado o SIP disponibiliza a opção "Extrato Repaginado", este relatório é exatamente igual ao extrato ja mencionado, a diferença é que o usuário poderá digitar o número da página. Esta opção é útil para impressões de extrato que serão anexadas a documentos legais como um processo administrativo, dessa forma o digitador do processo pode mencionar o extrato anexo da página que ele desejar.

Outro extrato pode ser disponibilizado nas telas de cálculo além dos já mencionados caso a empresa esteja configurada para calcular rateios , trata-se do "Extrato do Rateio", este relatório auxilia o usuário na checagem dos resultados que o SIP gerou, ele é agrupado por unidade de custeio e possui os totais que são exatamente os eventos pagos no holerite. Ao utilizar este relatório o usuário pode clicar sobre o título da unidade de custeio para retraí-la ou expandí-la, isto auxilia a checagem em tela. Além disso o relatório mostra a legenda das naturezas e configurações exibidas.

Existem inúmeras informações que o usuário pode consultar para checar o cálculo, o SIP disponibiliza todas as opções necessárias para isto. Algumas informações são referentes ao trabalhador, outras referentes ao evento e outras referentes a empresa.

Para verificar informações referentes ao trabalhador o SIP disponibiliza um menu de contexto no registro do trabalhador, para ter acesso a ele o usuário deve clicar com o botão direito do mouse sobre o registro na tela do cálculo. A imagem abaixo ilustra as principais opções disponíveis.

Calcular Selecionado

Através do menu de contexto o usuário pode recalcular o registro selecionado, que é um atalho produtivo, pois evita de o usuário memorizar o registro, voltar a tela anterior, informar o filtro e clicar no botão calcular.

Ir Para

O SIP disponibiliza, também a opção de localizar um registro rapidamente através da oção "ir para", nesta função basta o usuário digitar o número da matricula que o SIP exibe o holerite dinâmico se o registro for encontrado. Essa opção pode ser substituida pela nova funcionalidade de busca na grid .

Abrir Cadastro

Outra função que o menu de contexto disponibiliza é a de abrir o cadastro do trabalhador selecionado, este que é um atalho produtivo pois evita de o usuário memorizar o registro, abrir o cadastro manualmente, informar o filtro de pesquisa e então clicar no botão pesquisar.

Para evitar outro trabalho em cima da abertura do cadastro o SIP disponibiliza a opção de abrir o cadastro de eventos fixos, eventuais diversos, faltas, afastamento, férias, licença prêmio e dependentes direto da tela do cálculo. Portanto todo o trabalho que o usuário teria de acessar cada tela independentemente, tendo ainda que informar os parâmetros de filtragem, não são necessárias, pois o SIP automatiza esse processo.

Outras telas, independentes do cadastro, mas de igual trabalho são as de cargo e vinculo, pois influenciam diretamente no cálculo.

Além das opções de cadastro o SIP disponibiliza verificação de relatórios e outros cálculos. O item "Valores", disponível no menu de contexto, possibilida ao usuário consultar outros cálculos realizados em nome do registro selecionado no mês atual. Essa função é um atalho muito produtivo, pois evita que o usuário realize o processo manualmente de abrir outra tela de outro cálculo, informar o filtro e clicar no botão resultado. Ainda assim o mais importante é que o usuário talvez não saiba se um certo tipo de cálculo fora realizado para aquele trabalhador. Por exemplo, se o usuário está analisando o cálculo mensal e deseja verificar o cálculo de adiantamento de 13o Salário, mas não sabe se foi feito o SIP ajuda nisso também. Observe a imagem abaixo, nela o SIP mostra apenas os cálculos que realmente existem para o registro selecionado.

Além dos tipos de cálculo realizados para aquele registro o SIP disponibiliza a emissão dos relatórios de Ficha Financeira e de Média conforme a movimentação. Por exemplo, se o trabalhador tem movimentação de férias para o mês atual o SIP disponibiliza a emissão da ficha financeira e da média conforme o período de férias, bem como o de licença prêmio. A opção de emissão por exercício está sempre disponível e obedece o ano atual. Para o cálculo de rescisão o SIP disponibiliza apenas o último período, ou seja o proporcional. Não é necessário salientar que tratam-se de atalhos de alta produtividade.

Avos

Para checagem dos avos o SIP disponibiliza a opção de mesmo nome para emissão de relatório por exercício e por período de movimentação de férias, além dos relatórios o SIP permite a manutenção dos dias para contagem dos avos, pois há casos em que o banco de dados de origem da conversão não dispunha dos dados.

Congelar Trabalhador

O SIP tem um mecanismo de travamento do cálculo para cada registro alterado manualmente pelo usuário, ou seja, quando o usuário altera o movimento manualmente, através de recursos que veremos a seguir, o SIP congela aquele trabalhador para que ele não seja calculado novamente. É possível congelar e descongelar o trabalhador, para isto o usuário deve acessar o menu de contexto do registro e selecionar a opção "Congelar Trabalhador", quando um registro está congelado o SIP marca um sinal de checagem ao lado da opção de menu. Quando há um trabalhador congelado para aquele cálculo o SIP mostra também um pequeno cadeado ao lado do registro do trabalhador.

Exibir Informações Adicionais

A tela de cálculo do SIP disponibiliza ao usuário a possibilidade de visualização dos detalhes do afastamento que influenciam aquele registro no mês, bem como os detalhes de férias. Para isto o usuário deve acessar a opção "Exibir Informações Adicionais". Um painel abaixo do holerite dinâmico será mostrado contendo os dados de afastamento e/ou férias, que são os mesmo dados mostrados inadivertidamente no extrato mencionado anteriormente.

Visualizar Aviso

Alguns avisos durante o cálculo são gerados quando o SIP identifica discrepâncias de configurações, esses avisos são registrados para poderem ser mostrados na tela do cálculo. Quando há um aviso o SIP exibe um pequeno balão ao lado do registro do trabalhador. Nesse caso o usuário pode clicar na opção "Visualizar Aviso" do menu de contexto que o SIP emitirá uma caixa de diálogo contendo a informação gravada pelo cálculo.

Excluir Movimento

Por diversos motivos o usuário pode desejar excluir o cálculo do trabalhador, para isso basta acessar o menu de contexto na opção "Excluir Movimento", o SIP irá solicitar dupla confirmação e registrará log da operação.

Excluir Todos os Registros listados

Assim como nas telas de cadastro padronizadas a tela de cálculo também disponibiliza a opção de excluir todos os registros listados.

Menu de contexto do holerite dinâmico

Para verificar dados referentes aos eventos o SIP disponibiliza o menu de contexto do holerite dinâmico que possibilita desde a exibição da fórmula de cálculo do evento selecionado à alteração do resultado do cálculo. Este último recomendado apenas em caso de emergência. A imagem abaixo representa o menu de contexto do holerite dinâmico.

Exibir Base de Cálculo [Normal]

Esta opção mostra em negrito os eventos que fazem parte da base de cálculo do evento selecionado. Por exemplo, ao clicar com o botão direito do mouse sobre o evento de previdência e selecionar esta opção o SIP irá mostrar em negrito os eventos de salário base e adicional de tempo de serviço de um holerite hipotético, sendo que isto representa os eventos que incidem para a previdência. Ou então para esse mesmo holerite ao clicar com o botão direito do mouse sobre o evento adicional de tempo de serviço e selecionar esta opção o SIP irá mostrar em negrito o evento de salário base, sendo que isto significa que o salário base está na base de cálculo do evento de adicional de tempo de serviço.

Na parte inferior do holerite dinâmico o SIP mostra algumas configurações importantes e a soma dos eventos em negrito. Observe a imagem abaixo ela representa o mecanismo geral da demonstração de bases de cálculo.

Outro exemplo de obtenção da base de cálculo é através dos totalizadores que ficam na parte inferior do holerite. Nesse caso o usuário deve clicar sobre um deles para visualizar os eventos que compõem sua base. Por exemplo, ao clicar sobre "Base Cálc. FGTS" o SIP mostrará como na imagem abaixo.

Observe que o caso do FGTS é um bom exemplo das informações adicionais mostradas além da simples soma dos eventos, pois ele indica se o trabalhador é ou não optante do fundo de garantia.

Note, também, o sinal de "x" ao lado da base de cálculo, é através dele que o usuário pode fechar as informações da base de cálculo e retirar o negrito dos eventos.

Exibir Base de Cálculo [Integral]

Em casos de afastamento ou rescisão o SIP calcula os eventos de vantagem fixa de forma proporcional aos dias trabalhados, portanto para cada evento existem dois valores, o valor proporcional, que é o que o usuário vê no holerite e o valor integral, que sempre corresponde ao valor que teria o evento se calculado com trinta dias.

Esta opção mostra a soma dos valores integrais dos eventos que são base de cálculo do evento selecionado.

Exibir Base de Cálculo de Outro Evento [Normal]

Existem casos em que o usuário precisa veriricar os eventos que fazem parte da base de cálculo de algum evento que não está presente visualmente no cálculo. Para isso o usuário deve utilizar esta opção que tem exatamente o mesmo mecanismo das opções anteriores. Ao acionar esse item o SIP solicitará o código do evento através de uma caixa de diálogo.

Exibir Base de Cálculo de Outro Evento [Integral]

Com o mesmo mecanismo do item anterior o usuário obterá através dessa opção a soma do valor integral dos eventos que compõem a base de cálculo do evento informado.

Exibir Fórmula

Através desta opção o usuário obtém acesso completo ao cadastro do evento selecionado dispensando o trabalho manual de memorizar o número, abrir a tela, informar o filtro e clicar no botão de pesquisa. Outra forma de acessar o cadastro do evento é através do duplo clique. Quando os dados de incidência ou qualquer dado do evento for alterado o usuário deve recalcular o trabalhador para que as alterações tenham efeito.

Fonte do Cálculo

Esta opção mostra uma tela contendo as origens do evento, da quantidade e do valor.

A fonte do evento pode ser uma das a seguir.

Eventos Fixos | Todos os eventos que o usuário lançar no cadastro de eventos fixos.
Eventuais | Eventos lançados pelo usuário na manutenção de eventuais diversos ou de faltas.
Conversão | Ao consultar holerites dinâmicos de meses anteriores aos calculados pelo SIP 7 o usuário verificará que a origem dos eventos será sempre de conversão.
Folha Complementar | Todos os eventos lançados na manutenção de eventos de folha complementar e calculados pelas folhas complementares mensal e ou de rescisão. Note que os eventos de demonstração de folha complementar em folha mensal são marcados como Automáticos.
Manutenção | Eventos alterados pelo usuário após o cálculo são remarcados como provenientes de manutenção.
Cartão de Ponto | Eventos apurados pelo cálculo do cartão de ponto tais como faltas e horas extras.
Automático | São eventos lançados no cálculo automáticamente conforme configurações do usuário. Exemplo: Geralmente o evento de previdência é automático, a não ser que o usuário se utilize de lançamento no eventuais ou manutenção do cálculo, nesse caso o SIP atribui a origem real substituindo a marcação de Automático para Eventuais ou Manutenção.

Além da origem do evento o SIP marca as origens da quantidade e do valor. Esses dados são indicados como sendo calculado, digitado ou de conversão.

Dessa forma o usuário pode solucionar um problema corriqueiro que é o de lançamento desatendo no cadastro de eventos fixos, em que o valor do salário base é diferente do programado em sua fórmula. Ao acionar a opção para verificar a fonte do cálculo o usuário constatará que o evento tem como origem o cadastro de eventos fixos mas o valor está marcado como digitado, com isso é fácil identificar que houve um equívoco quando do lançamento do evento no cadastro.

Exibir Valor Integral

O SIP armazena dois valores para cada evento calculado, um deles é o valor que o usuário normalmente vê, este chama-se valor proporcional, o outro é o valor integral, que trata-se do valor que o evento teria se calculado com trinta dias. Esses valores são diferentes um do outro em casos de afastamento ou rescisão. Para o usuário visualizar este valor oculto do sistema basta acionar esta opção que o SIP disponibilizará uma nova coluna no holerite dinâmico contendo os valores de todos os eventos listados. Note que este recurso é apenas temporário para verificação do cálculo, que não se trata de configuração pois ao fechar a tela do cálculo e reabrí-la o SIP não mais o exibirá.

Para ocultar o valor integral dos eventos do holerite dinâmico o usuário deve acionar a mesma opção, porém agora ela estará com a descrição Esconder Valor Integral.

Exibir Base de Cálculo

O SIP armazena o valor apurado como base de cálculo de cada evento calculado, mesmo para aqueles que não possuem fórmula. O mecanismo desta opção é idêntico ao da opção Exibir Valor Integral, e portanto para ocultar a base de cálculo dos eventos do holerite dinâmico o usuário deve acionar a mesma opção, que porém está com sua descrição alterada para Esconder Base de Cálculo.

Relação de Trabalhadores do Evento

Através desta opção é possível emitir o relatório de Trabalhadores por Evento, disponível no menu mensais, diretamente pela tela do cálculo conforme o evento selecionado, tornando desnecessário o trabalho manual de memorizar o número do evento, encontrar o relatório no menu mensais, informar os parâmetros necessários e clicar no botão "Visualizar". Portanto, ao selecionar esta opção, o usuário obterá a lista de trabalhadores que possuem o evento selecionado, independentemente da tela do relatório estar aberta ou não. Observe que se o relatório já estiver aberto com outros parâmetros o SIP os limpa e em seguida informa o novo código de evento tal como um usuário faria manualmente, porém de forma automática e instantânea.

Manutenção do Cálculo

Através da tela do cálculo o usuário pode alterar os valores e eventos apurados pelo SIP. Todas as operações realizadas são gravadas no LOG do SIP e em seguida o trabalhador é automaticamente congelado. As opções para que o usuário possa realizar esse tipo de manobra são elencadas abaixo.

Ao acionar esta opção o usuário obterá uma tela com todos os dados necessários aos resultados do cálculo, a partir dessa ação o usuário é o responsável direto pelo holerite. A imagem abaixo ilustra a tela que será apresentada.

A tela de manutenção manual do movimento é uma tela normal de cadastro padronizada com a pequena diferença de não disponibilizar a grid . Através dessa tela é possível incluir ou alterar apenas um item, ao concluir, o usuário é levado de volta a tela do cálculo.

No campo Evento o usuário deve informar o código do evento que deseja incluir no movimento do trabalhador selecionado. Caso não saiba o código o usuário pode clicar no botão ao lado para escolher o evento numa lista.

O campo Qtde. Proporcional é a quantidade que o usuário gostaria de armazenar para fins de controle.

O campo Qtde. Integral é a quantidade referente ao valor integral que o usuário gostaria de armazenar para fins de controle.

O campo Referência representa a coluna de referência do holerite, esta sim é vista por todos, nela é possível digitar até sete caracteres livres.

O campo Porcentagem é intuitivo e é armazenado apenas para controle.

O campo Valor Proporcional é o valor que é exibido no holerite e fará parte da soma dos totalizadores.

O campo Valor Integral é o valor que não é exibido no holerite e não fará parte da soma dos totalizadores, é apenas um valor que o usuário gostaria de armazenar para fins de controle.

O campo Base de Cálculo é um valor que o usuário gostaria de armazenar para fins de controle.

Incluir Evento

A operação de inclusão de um evento disponibiliza a tela de manutenção com seus dados em branco e zerados, basta que o usuário indique as informações que deseja para que o SIP adicione mais um evento ao holerite do trabalhador selecionado.

Alterar Evento

Esta opção disponibiliza ao usuário a tela de manutenção com os dados em modo de alteração.

Excluir Evento Selecionado

O SIP solicitará duas confirmações e se aceitas removerá definitivamente o evento do holerite do trabalhador.

Excluir Todos os Eventos

Após duas confirmações o SIP remove definitivamente os eventos do holerite do trabalhador, inclusive os eventos ocultos, tais como os de base de cálculo, o FGTS e os de patronal.

Recalcular Evento

Esta opção está disponível apenas para eventos automáticos. É útil quando o usuário incluiu, alterou ou excluiu algum evento que influencia na base de eventos automáticos. Nesse caso o usuário pode acionar essa opção para que o evento de previdência, por exemplo, seja recalculado sem ter que recalcular o holerite todo, uma vez que isso não é possível pois o usuário está mantendo-o manualmente.

Alterar Valor do FGTS

O evento de fundo de garantia é especial pois tem sua natureza como vantagem, e portanto não é mostrado no holerite. Mesmo assim o SIP disponibiliza opções de manutenção do evento e esta é a que permite sua alteração.

Recalcular FGTS

Da mesma forma que o usuário pode recalcular algum evento automático ele também pode recalcular o FGTS, mas como este evento não é visível o SIP disponibiliza esta opção especial para ele.

Excluir Evento de FGTS

Por sua natureza ser de vantagem o SIP oculta esse evento mas ele pode ser excluido através dessa opção.

Alterar Bases de Cálculo

Além de manutenção nos eventos o usuário pode alterar algumas bases de cálculo, principalmente aquelas que influenciam a SEFIP, RAIS e DIRF. Note que esta base de cálculo não é a mesma base de cálculo armazenada para cada evento, mesmo que os valores sejam iguais, esta base é aquela armazenada exclusivamente para eventos do sistema. A imagem abaixo ilustra a tela que o SIP disponibiliza ao usuário.

A tela de manutenção de bases de cálculo também é uma tela de cadastro padronizada com a diferença de não disponibilizar a grid .


Adicionar Layout Pronto GR

Vídeo passo-a-passo para inclusão de layout pronto no gerador de relatórios.


Manual Básico GR

Gerador de Relatórios

A função desse módulo é de criar novos relatórios de acordo com a necessidade do usuário.

Instruções para utilização do Gerador de Relatórios

Abra o SIP 7 e clique no botão Relatórios.

O módulo do Gerador de Relatórios será executado.

Funcionalidades e Capacidades do Gerador de Relatórios

No Gerador de Relatórios é possível criar relatórios do tipo Laser ou do tipo Matricial e exportação para diversos formados conhecidos.

O tipo Laser é aquele relatório capaz de imprimir em impressoras Laser ou a Jato de Tinta, esse tipo de relatório é preparado para que todos os controles visuais sejam posicionados livremente no papel, suas unidades de medida são expressas em milímetros.

O tipo Matricial é um tipo de relatório especial capaz de imprimir em impressoras de agulha, chamadas também, de impressoras de impacto. Esse tipo de relatório é diferente pois suas unidades de medida são em caracteres e o posicionamento dos controles visuais é dado por coluna e linha.

O relatório criado, independente do tipo pode ser exportado para os formatos abaixo:

· PDF da Adobe: Esse formato solicita diversos parâmetros, tais como as páginas que serão exportadas, nível de compactação, informações adicionais como título, autor, assunto, palavras chave, autenticação por usuário e senha, se o arquivo poderá ser impresso, modificado ou copiado, se o visualizador poderá exibir suas barras de ferramentas, de menu, entre outros.

· HTML da W3C: Esse formato solicita quais páginas podem ser exportadas, seus estilos, se haverá quebra de página, o tipo das imagens a ser exportada caso existam, entre outros.

· Tabela Excel (OLE): Esse formato permite selecionar quais páginas serão exportadas, se haverá quebra de página, união de células, figuras entre outros. É necessário ter o Microsoft Excel instalado.

· Tabela Excel (XML): Esse formato solicita alguns parâmetros tais como as páginas que serão exportadas, se será haverá quebra de página, entre outros.

· RTF – Rich Text Format: Esse formato pode ser lido em qualquer leitor de textos-formatados tais como Microsoft WordPad, Microsoft Word e OpenOffice. São solicitados alguns parâmetros tais como as páginas que serão exportadas, o formato do cabeçalho/rodapé, entre outros.

· Imagens: Esse formato transformará o relatório em um dos tipos de arquivos elencados abaixo, solicita parâmetros para seleção de páginas, separação das páginas em arquivos, qualidade e resolução em dpi.

· BMP – Imagem Bitmap;

· JPEG - Joint Photographic Experts Group;

· TIFF - Tagged Image File Format;

· GIF - Graphics Interchange Format;

· Texto: Esse formato captura apenas objetos de texto no relatório ignorando as imagens e traços, solicita parâmetros para quais páginas serão exportadas, se haverá quebra de página, entre outros.

· CSV - Comma-separated values: Esse formato captura apenas objetos de texto no relatório separando-os por ponto-e-vírgula ou por qualquer outro separador escolhido através dos parâmetros solicitados que incluem quais páginas serão exportadas.

· Planilha ODS – Open Document Sheet: Formato do OpenOffice/BrOffice. Esse formato solicita alguns parâmetros tais como se haverá quebra de página e quais serão exportadas. É necessário ter o BrOffice Instalado.

· Documento ODT – Open Document Text: Formato do OpenOffice/BrOffice. Esse formato solicita alguns parâmetros tais como se haverá quebra de página e quais serão exportadas. É necessário ter o BrOffice Instalado.

· E-mail: Esse tipo de exportação não é um formato propriamente dito mas sim um mecanismo que inclui todos os formatos acima citados de forma que é possível enviar diretamente por e-mail sem a utilização de programas gerenciadores de mensagens de correio eletrônico, pois ele solicitará todos os parâmetros necessários para o envio da mensagem.

Para a criar novos relatórios, antes é necessário a criação de uma pasta, para isso clique no botão Nova Pasta, atribua o nome desejado e clique em ok.

Em seguida selecione a pasta criada e clique em Novo Relatório (lembrando que a opção novo relatório tem como padrão a opção Laser) ou em Relatórios / Novo Relatório / Laser ou Matricial, de acordo com a necessidade.

Obs.: Nessa versão do Gerador de Relatórios não é possível criar sub pastas.

Antes de criar um novo relatório vamos entender o que compõe um relatório que agora chamaremos de layout.

Um layout é composto por objetos visuais, objetos não visuais e código, esse último é raramente utilizado e não será abordado nesse manual. Já objetos visuais são aqueles que podem ser arrastados até a página e vistos ao imprimir. Por fim objetos não visuais são os objetos de dados, que conterão as fontes dos dados do relatório, por exemplo o cadastro de trabalhadores será um objeto não visual para uma possível listagem de trabalhadores.

Clicando no Novo Relatório/Laser, vamos começar o desenvolvimento de um relatório usando a ferramenta “Fast Report”. Nele existem três abas: Código, Data e Page1.

A aba código é utilizada para criação de textos em linguagem de programação, tais como PascalScript, C++Script, BasicScript, Jscript. Essa aba é utilizada opcionalmente para casos extremamente difíceis de serem resolvidos através das funcionalidades normais de criação de layout, de forma que o código irá interferir na geração normal do relatório para produzir um resultado visual esperado, e portanto está a cargo do suporte técnico ou de usuários que já conheçam essas linguagens.

A aba Data armazena os objetos do tipo dado, já mencionados anteriormente. A aba Page1 representa uma página do relatório e conterá os objetos visuais, tais como texto, linhas, figuras e planilhas. Um relatório pode conter várias páginas iguais a Page1, por exemplo quando o relatório possui dez páginas com capa e contra-capa, haverá o Page1 para a capa, o Page2 para o conteúdo do relatório que serão as oito páginas e o Page3 para a contra-capa.

O ambiente de desenvolvimento do layout

A figura abaixo ilustra a tela que será mostrada ao clicar em novo relatório, do lado esquerdo está a barra de ferramentas de objetos visuais e a lista de propriedades do objeto selecionado, do lado direito está a lista de objetos não visuais ou de dados e as listas de variáveis, funções e classes. No centro é mostrado uma das abas Código, Data ou Page.

Um relatório deve ser iniciado pela camada de dados e a imagem abaixo mostra o conteúdo da aba Data e suas funcionalidades.

Dentro da aba Data são encontrados os objetos não visuais que compõem os dados do relatório, inúmeros objetos de dados podem ser criados nessa aba. Quando um novo relatório é iniciado o Gerador fornece um objeto chamado DBXQuery1, dentro desse objeto devemos adicionar uma instrução SQL. Normalmente o SQL será fornecido pelo suporte técnico, portanto não é necessário mas apenas desejável seu conhecimento.

SQL é um acrônimo para Select Query Language, que é uma linguagem contratual em que um humano consegue especificar os dados que deseja recuperar do banco de dados. Esse contrato é composto por diversas cláusulas, as quatro principais são:

· Select: é obrigatoriamente a primeira cláusula e indica entre vírgulas os campos que desejamos mostrar no relatório.

· From: é obrigatoriamente a segunda cláusula que indica de quais tabelas virão os dados. Os campos selecionados pela cláusula select deverão existir em pelo menos uma das tabelas especificadas na cláusula from.

· Where: é obrigatoriamente a terceira cláusula e indica as restrições aos dados que desejamos mostrar no relatório. Digamos que o relatório é apenas de trabalhadores ativos, é nessa cláusula que indicaremos essa intenção.

· Order by: é obrigatoriamente a última cláusula e indica a ordem dos dados, para isso basta elencar os itens que compõem a cláusula select dos quais deseja ordenar.

·

O Gerador de Relatórios possibilita a escrita dinâmica dessa instrução através de uma tela chamada Fast Query Builder ou Gerador de Consultas. Para acessá-la basta clicar duas vezes sobre o objeto de dados e em seguida clicar no primeiro botão da tela que é mostrada.

Do lado direito da tela que se apresentará há a lista de todas as tabelas do sistema, ao arrastá-las para o centro indicaremos a cláusula From da instrução SQL e ao selecionar os campos da lista que será exibida indicaremos os campos da cláusula Select e Where.

Assim que todas as opções estiverem selecionadas basta clicar no botão de checagem verde na parte superior da tela que a instrução SQL será mostrada na tela anterior.

Clique novamente no botão de checagem verde na parte superior da tela para confirmar a instrução SQL gerada.

Observe que do lado direito onde está a lista de objetos não visuais o DBXQuery1 ficou em negrito e passou a listar subitens que são os mesmos itens indicados na cláusula Select (Registro, Matricula, Contrato, Nome e Sexo).

Após definir a camada de dados deve-se criar os objetos visuais que vão representar cada registro de dado no relatório, para isso existem os objetos chamados Banda. Nem todos as Bandas representam dados.

Bandas são objetos visuais que agregam outros objetos visuais em seu interior representando alguma sessão ou região do relatório, ou registro de dados.

Existem vinte e seis bandas, a seguir serão elencadas apenas as sete principais, pois serão elas que a grande maioria dos relatórios exigirão.

· Título do Relatório: mostra seu conteúdo apenas uma vez na primeira página.

· Sumário do Relatório: mostra seu conteúdo apenas uma vez na última página.

· Cabeçalho da Página: mostra seu conteúdo no topo de todas as páginas.

· Rodapé da Página: mostra seu conteúdo no fim de todas as páginas.

· Dados mestre: representa cada linha de registro dos dados a ela relacionados.

· Cabeçalho de grupo: representa um cabeçalho de agrupamento.

· Rodapé de grupo: representa um rodapé de agrupamento.

Outras bandas são capazes de representar detalhamento de registros em até cinco níveis, cabeçalhos e rodapés adicionais e ainda bandas que representam dados na vertical, mas esse assunto não será abordado.

Ao iniciar um novo layout o Gerador cria as quatro principais, das sete bandas mais utilizadas (cabeçalho da página, rodapé da página, dados mestre e sumário do relatório).

A primeira banda que aparece na página é a banda PageHeader1, infelizmente esse nome não é traduzido mas ela é a banda Cabeçalho da Página, nela será possível adicionar objetos visuais que representem data e hora, número da página e o nome do relatório, mesmo que esse último pertença a banda Título do Relatório as boas práticas de secretariado indicam que o nome do relatório deve ser emitido em todas as páginas. Mas enfim, qualquer objeto visual pode ser colocado dentro de qualquer banda, esta é apenas uma abordagem didática.

Observe que a banda que se destaca das demais é a banda que representa os dados, para saber quais dados ela representa basta checar o canto superior direito dela, lá encontraremos o nome do objeto não visual a que ela está associada (DBXQuery1), essa associação já foi criada automaticamente pelo Gerador mas ela pode ser alterada, para isso dê um duplo clique na banda que, se houver, outras fontes de dados serão listadas.

A terceira banda é o Sumário do Relatório geralmente utilizada para totalizações, ela será emitida logo abaixo do último registro impresso. Observe que o Gerador criou um objeto texto contendo uma função contadora de registros, nesse caso esse objeto mostrará a quantidade de registros emitida pela instrução SQL, que é representada pela banda MasterData1 (Dados mestre).

A última banda é o Rodapé da Página, nela o Gerador cria um objeto texto que representa um texto estático contendo o nome da empresa, mas é possível adicionar outros objetos tais como a numeração de páginas, entre outros.

Objeto texto é um objeto visual muito versátil pois ao contrário de muitos geradores de relatório disponíveis no mercado ele suporta expressões complexas, concatenação de texto, comandos HTML, posicionamento do texto em ângulo e destacamento condicional. Infelizmente nem todas as funções citadas serão abordadas detalhadamente.

Para adicionar um título ao relatório basta clicar uma vez sobre o botão do objeto texto na barra de ferramentas e em seguida clicar uma vez sobre a banda PageHeader1, ao fazer isso uma caixa de diálogo contendo um espaço em branco para digitação será exibida.

Digite o título do relatório e clique em ok. Em seguida altere as propriedades de fonte desejadas e posicione o objeto texto no local apropriado. Observe que o Gerador já havia criado um objeto linha na base da banda PageHeader1, ele pode ser excluído se necessário, mas geralmente é sempre utilizado.

Para adicionar dados como data e paginação utilize o objeto Variável do Sistema, porém a tela que será apresentada é diferente da do objeto texto. Nela é possível indicar o conteúdo desejado sendo dividido em três categorias, a primeira são os dados que desejamos para este exemplo, a segunda são dados de agregação que serão abordados quando finalizarmos o relatório na banda sumário e o terceiro é um texto simples tal como já fizemos para o título do relatório.

Vamos adicionar um agrupamento pelo campo sexo. Para isso clique uma vez sobre o botão de bandas e escolha cabeçalho de grupo. Na caixa de diálogo que se apresenta selecione o campo Sexo e outras opções desejáveis.

Ao clicar em ok a banda criada estará posicionada abaixo da banda MasterData1, infelizmente o Gerador não foi tão inteligente quanto o esperado mais isso não é problema frente aos benefícios que ele traz, portanto arraste a banda recém criada para antes da MasterData1. Em seguida adicione a banda Rodapé de Grupo, que pode ser encontrada no mesmo local e adicionada da mesma forma, ela não pede parâmetros adicionais nem é posicionada incorretamente.

Vamos finalmente adicionar objetos texto que represente dados, para isso arraste o campo sexo que está presente na lateral direita, abaixo de DBXQuery1 para dentro da banda GroupHeader1, em seguida aumente o tamanho do objeto texto. A seguir utilizaremos o recurso de concatenação no objeto texto, citado anteriormente, para isso dê um duplo clique sobre ele, o cursor estará posicionado antes de uma expressão criada automaticamente pelo Gerador, escreva a palavra Sexo seguida de dois pontos e um espaço, clique em ok para confirmar.

Arraste os outros campos para dentro da banda MasterData1, na disposição desejada. Em seguida copie o objeto texto presente na banda sumário e cole dentro da banda rodapé do grupo, ou crie um objeto texto que exibirá a quantidade de registros.

Para calcular e mostrar a quantidade de registros crie um objeto texto dentro da banda rodapé do grupo, na tela que apresentada escreva a palavra “quantidade” seguida de dois pontos e um espaço. Em seguida clique no botão de agregações que outra tela será apresentada, nela selecione a função COUNT, selecione a banda MasterData1 e clique em ok.

Para salvar o relatório basta fechar a tela do ambiente de desenvolvimento que o nome do layout será solicitado e em seguida armazenado na pasta selecioanda.

Modelos de Relatórios

Modelos de relatórios são layouts pré-desenvolvidos pela Fiorilli e podem ser alterados ou adicionados pelo usuário, eles podem ser encontrados na lateral direita da tela principal do Gerador.

O intuito é que o usuário deixe preparado seu papel timbrado nos modelos e crie relatórios sempre a partir desses. Dessa forma o trabalho repetitivo é excluído aumentando a produtividade de layouts.

Para criar um novo modelo clique em Modelos / Novo Modelo, a criação é exatamente igual ao um layout normal, a diferença é o usuário quem faz, para isso um modelo deve conter apenas o trabalho repetitivo de construção de layout.

Para criar relatórios a partir de um modelo selecione uma pasta e clique em Relatório Modelo.


Calculo Mensal

Tela do Calculo Mensal

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo mensal

O filtro de pesquisa das telas de cálculo é auxiliado por parâmetros de filtragem extra, eles são disponibilizados quando a filtragem se torna complicada para ser inserida na lista de campos disponíveis. Na tela do cálculo mensal, existem dois parâmetros de filtragem extra, um para filtrar apenas trabalhadores que possuem informações de afastamento e outro para filtrar apenas trabalhadores que receberam férias.


Calculo de Adiantamento Mensal

Tela do Calculo de Adiantamento Mensal

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Adiantamento Mensal

Nenhuma instrução específica.


Calculo de Folha Complementar Mensal

Tela do Calculo de Folha Complementar Mensal

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Folha Complementar Mensal

A folha complementar disponibiliza parâmetros extras de cálculo, a maioria deles é de configuração estática e podem ser encontrados no cadastro de empresas, já outros são de configuração dinâmica, ou seja, podem mudar a cada cálculo.

Para verificar todos os detalhes do cálculo da folha complementar acesse o tópico Folha Complementar Mensal , nele o usuário terá a visão passo-a-passo com exemplo desde a necessidade do cálculo, as configurações, os possíveis lançamentos, o processo de cálculo e por fim a apuração do resultado.


Calculo de Adto. 13º Salário

Tela do Calculo de Adiantamento do 13º Salário

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Adiantamento de 13º Salário

A tela deste cálculo disponibiliza quatro opções extras de filtragem.

· Todos

· Apenas aniversariantes do mês

· Apenas aniversariantes do próximo mês

· Apenas admissões com aniversário no mês

· Apenas férias vencidas programadas

O primeiro item das opções indica que nenhum dos quatro itens abaixo serão utilizados, pois pode haver o engado da dedução de que o termo Todos quer dizer que os 215 (78+53+84) serão calculados, mas na verdade serão calculados os 800 trabalhadores de uma empresa hipotética, desde que tenham qualificação para isso, como por exemplo o vinculo e a categoria do trabalhador devem estar configurados para calcular 13º Salário.

O cálculo de adiantamento de 13º salário pode ser realizado mais de uma vez para cada trabalhador ao longo do exercício. No fechamento do 13º salário o SIP somará os valores pagos a título de adiantamento para deduzir do valor a ser pago como fechamento do 13º salário. Portanto o termo "1ª parcela", utilizado no título da tela é apenas didático, já que 99% das entidades calculam apenas um adiantamento no exercício.


Calculo de Fechamento 13º Salário

Tela do Calculo de Fechamento do 13º Salário

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Fechamento de 13º Salário

A tela deste cálculo disponibiliza quatro opções extras de filtragem.

· Todos

· Apenas aniversariantes do mês

· Apenas aniversariantes do próximo mês

· Apenas admissões com aniversário no mês

· Apenas férias vencidas programadas

O primeiro item das opções indica que nenhum dos quatro itens abaixo serão utilizados, pois pode haver o engado da dedução de que o termo Todos quer dizer que os 160 (67+78+15) serão calculados, mas na verdade serão calculados os 800 trabalhadores de uma empresa hipotética, desde que tenham qualificação para isso, como por exemplo o vinculo e a categoria do trabalhador devem estar configurados para calcular 13º Salário.

O fechamento do 13º salário possui a opção de apagar todas as simulações de fechamento de 13º salário realizadas ao longo do exercício. Para isso o usuário deve acionar a opção "Gerar novo Lançto. para Calculados no Exercício".

Simulação de cálculo não é uma operação especial, para ser considera uma simulação basta que o usuário não encerre a referência nem gere o crédito bancário .


Calculo de Recibo de Férias

Tela do Calculo de Recibo de Férias

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Recibo de Férias

Não existem instruções específicas para a tela do cálculo de férias, basta que o usuário informe a ordem de pagamento no cadastro do trabalhador. O SIP calcula férias somente mediante ordem de pagamento, diferentemente do 13º salário que pode ser automático no mês do aniversário ou para remanescentes em novembro.

Pagamento de férias através do recibo consiste no lançamento de eventos de férias num cálculo separado, esse cálculo será realizado sob o tipo de referência de número 6 e a impressão do recibo de férias poderá ser emitida.

Existem duas formas de emitir o recibo de férias, a primeira é através do menu mensais, a segunda é através da tela de resultados do cálculo de férias. Observe as imagens abaixo.

A imagem abaixo ilustra a expansão das opções de impressão da tela do cálculo, que por padrão possui apenas a emissão do extrato e da listagem, porém a tela de férias inclui dois novos relatórios, o recibo de férias e o aviso de férias.

A ordem de pagamento pode ser acessada através do botão "Férias" a partir do cadastro do trabalhador, conforme imagem abaixo.


Calculo de Rescisão

Tela do Calculo de Rescisão

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Rescisão

Serão calculados nessa tela todos os trabalhadores que possuirem motivo de desligamento com data dentro do mês da referência .

Existem duas formas de emitir o Termo de Rescisão, a primeira é através do menu mensais, a segunda é através da tela de resultados do cálculo de rescisão. Observe as imagens abaixo.

A imagem abaixo ilustra a expansão das opções de impressão da tela do cálculo, que por padrão possui apenas a emissão do extrato e da listagem, porém a tela de rescisão inclui dois novos relatórios, o termo de rescisão e o demonstrativo de rescisão.

Quando existir mais de um período aquisitivo para ser indenizado é possível discriminá-los separadamente para que os avos ou dias restantes sejam exibidos permitindo maior controle sobre os resultados do cálculo.

Porém essa função é apenas para checagem do cálculo, não recomendamos que a rescisão seja paga nem impressa dessa forma.

Para discrimitar os períodos de férias acione a opção "Discriminar Férias Indenizadas" no menu de contexto do registro do trabalhador na tela de resultados do cálculo.


Calculo de Rescisão Complementar

Tela do Calculo de Rescisão Complementar

Opção disponível no menu Cálculo

Instruções específicas para a tela do cálculo de Rescisão Complementar

Para verificar todos os detalhes do cálculo da folha complementar acesse o tópico Folha Complementar de Rescisão nele o usuário terá a visão passo-a-passo com exemplo desde a necessidade do cálculo, as configurações, os possíveis lançamentos, o processo de cálculo e por fim a apuração do resultado.


Referência

Referências do SIP

Opção disponível no módulo Folha

A referência do SIP é o conjunto dos mês, ano e tipo. Esses dados podem ser sintetizados numa única informção, o código da referência. Na imagem abaixo o código é 442.

A referência do SIP está disponível o tempo todo e pode ser alterada pelo usuário quando necessário. São oportunidades de alteração da referência relatórios e lançamentos. O SIP disponibiliza oito tipos de referência que podem ser selecionadas de forma individual ou múltipla.

Para cada tipo de referência há uma tela de cálulo, ou seja, existem oito tipos de cálculo no SIP.

O tipo de referência pode ser alterado ao clicar no botão de reticências, observe a imagem abaixo.

Quando o relatório permitir o usuário poderá selecionar mais de uma referência. São exemplos de relatório com essa funcionalidade o resumo contábil, o crédito bancário e a relação de trabalhadores por evento. A imagem abaixo ilustra a seleção múltipla de tipos de referência.

Referências podem e devem ser encerradas mensalmente, o encerramento consiste no travamento do cálculo, travamento dos lançamentos e transferência de situação dos trabalhadores rescindidos da referência selecionada. Em contrapartida há também a reabertura de referências. Todas as operações com referências também são armazenadas no log do SIP.

Para encerrar ou reabrir referências acesse a opção "Encerramento/Reabertura de Referência" do menu "Calculo" no módulo "Folha".

A tela que será apresentada possui duas opções de filtragem, uma para o exercício, que é obrigatória, e outra para o mês, que é opcional. Para que as opções de filtro tenham efeito o usuário deve clicar no botão "Aplicar Filtro".

O usuário pode verificar se a referência está vazia clicando no botão "Exibir Qtd. Trabalhadores", em seguida o SIP irá preencher a coluna "Trabalhadores" da lista de referências.

A lista de referências possui a coluna código que é o mesmo número indicado no canto superior direito do módulo. O SIP mostra um pequeno lápis quando existem trabalhadores congelados naquela referência.

A segunda coluna da lista é a da situação da referência, ela pode estar encerrada ou aberta. Quando a referência está encerrada o SIP mostra um pequeno cadeado, caso não haja um cadeado ela está aberta. Esse mesmo cadeado é mostrado no canto superior direito do módulo.

Para encerrar uma referência o usuário deve clicar no botão "Encerrar Referência Selecionada", esse mesmo botão tem sua descrição trocada para "Reabrir Referência Selecionada". Portanto para reabrir uma referência o usuário deve clicar no mesmo botão.

Além de encerrar referências esta tela permite ao usuário alterar alguns dados complementares, tais como as datas de pagamento e de fechamento, o primeiro e o último dia do mês, o primeiro e o último dia da freqüência, o número de domingos e o número de feriados apurados para aquela referência.

O número de domingos e feriados é apurado apenas uma vez na criação da referência, portanto se houver alguma alteração no número de feriados por falta de preenchimento da tabela de feriados o usuário deverá alterar a referência manualmente.

Existe outro mecanismo de mensagens no holerite além do presente no cadastro da empresa. O SIP permite a gravação de mensagens diferentes para cada referência, para isto basta o usuário deve clicar no botão "Mensagem". Em seguida, caso já não tenha feito, o usuário deve alterar o layout dos relatórios que deseja que a mensagem seja emitida, geralmente a mensagem é utilizada na impressão do recibo de pagamento.

A imagem abaixo demonstra a origem da mensagem para layouts de relatórios .

Referências também podem ser excluídas, desde que não hajam trabalhadores calculados nela. Para excluir uma referência o usuário deve selecioná-la e em seguida clicar no botão "Excluir".

Por fim o SIP promove algumas operações quando do encerramento de uma referência. A primeira trata-se da verifiação de exclusões de movimento, que quando houverem o SIP emitirá um relatório contendo os usuários e os respectivos trabalhadores excluídos do cálculo.

A segunda é quanto a transferência da situação dos trabalhadores rescindidos. Portanto quando uma referência de tipo 7 - Rescisão é encerrada os trabalhadores que estiverem nas situações 2 - Desligamento sem Rescisão, 4 - Aviso Indenizado e 5 - Aviso Trabalhado, serão transferidos para a situação 6 - Desligado.

Por fim o encerramento da referência mensal avalia o desempenho da abertura do cadastro de trabalhadores com todos os registros ativos, caso o tempo de resposta do servidor seja inferior a meio segundo, então a tela do cadastro de trabalhadores será exibida sem o filtro de pesquisa , já com todos os trabalhadores ativos em tela. Caso o usuário deseje realizar outro filtro basta clicar no botão "Voltar".


Agência/Contas Banco do Brasil

Cadastro de Agências/Contas do Banco do Brasil

Núm.Agência:

5 caracteres - Preencher com o número da agência mantenedora da conta.

dv:

1 caracter - Preencher com o número do digito verificador da agência.

Conta:

12 Caracteres - Número da conta corrente da Empresa.

dv:

1 caracter - Digito verificador da Conta.

tipo:

Campo não utilizado no preenchimento do layout.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome padrão do banco que é CNAB240 e a extensão REM.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Agência/Contas Banco Banespa

Cadastro de Agências/Contas do Banco Banespa

Núm.Agência:

3 caracteres. - Caso tipo de Layout for 200 posições, e 5 caracteres se o tipo de Layout for 240 posições.

dv:

1 caracter - Preencher com o número do digito verificador da agência.

PS. Se o tipo de Layout for 200 posições, não é necessário o preenchimento.

Conta:

12 Caracteres - Número da conta corrente da Empresa.

dv:

1 caracter - Digito verificador da Conta.

tipo:

Campo não utilizado no preenchimento do layout.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome BANESPA e a extensão TXT.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Agência/Contas Caixa Federal

Cadastro de Agências/Contas Caixa Federal

Núm.Agência:

4 caracteres. - Numero da agência mantenedora da conta da empresa.

dv:

1 caracter - Preencher com o número do digito verificador da agência. É usado apenas no tipo de layout SIACC(240 posiçoes)

Conta:

8 Caracteres - Número da conta corrente da Empresa.

dv:

1 caracter - Digito verificador da Conta.

tipo:

2 Caracteres - Número do tipo / modalidade da conta corrente da Empresa.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome CREDCEF, e a extensão TXT, se o tipo de Layout for 150 posições (SIACC ou SICOV), caso o tipo de Layout for 240 posições (SIACC) o sistema criará com o nome ACC+dia,mês,ano da geração + codigo do convênio + num.sequencial do arquivo, e a extensão REM.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Agência/Contas Nossa Caixa

Cadastro de Agências/Contas Nossa Caixa

Núm.Agência:

5 caracteres. - Numero da agência mantenedora da conta da empresa.

dv:

1 caracter - Preencher com o número do digito verificador da agência.

Conta:

6 Caracteres - Número da conta corrente da Empresa.

dv:

1 caracter - Digito verificador da Conta.

tipo:

2 Caracteres - Número modalidade da conta corrente da Empresa.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome F88CNAB e a extensão TXT.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Agência/Contas Banco Bradesco

Cadastro de Agências/Contas do Banco Bradesco

Núm.Agência:

5 caracteres. - Numero da agência mantenedora da conta da empresa.

dv:

1 caracter - Preencher com o número do digito verificador da agência. Não utilizado no Layout do Banco

Conta:

12 Caracteres - Número da conta corrente da Empresa. Informar 5 caracteres com o nº da Razão e 7 caracteres com o nº da C/C.

dv:

1 caracter - Digito verificador da Conta.

tipo:

Campo não utilizado no preenchimento do layout.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome FP + dia e mês da geração do arquivo + o número do arquivo informado na manutenção de layout (0...9) e com a extensão REM, se a opção arquivo remetido na manutenção de layout for (Real), caso for (Teste), com a extensão TST.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Agência/Contas Banco Bandepe (Pernambuco)

Cadastro de Agências/Contas do Banco Bandepe (Pernambuco)

Núm.Agência:

4 caracteres. - Numero da agência mantenedora da conta da empresa.

dv:

Não há necessidade do preenchimento, campo não utilizado no Layout do banco.

Conta:

Número da conta corrente da Empresa.

Não há necessidade do preenchimento, campo não utilizado no Layout do banco.

dv:

Digito verificador da Conta.

Não há necessidade do preenchimento, campo não utilizado no Layout do banco.

tipo:

Campo não utilizado no preenchimento do layout.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome CSENNN e a extensão TXT.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Agência/Contas Banco Real ABN AMRO

Cadastro de Agências/Contas Banco Real ABN AMRO

Núm.Agência:

5 caracteres - Preencher com o número da agência mantenedora da conta.

dv:

1 caracter - Preencher com o número do digito verificador da agência.

Conta:

12 Caracteres - Número da conta corrente da Empresa.

dv:

1 caracter - Digito verificador da Conta.

tipo:

Campo não utilizado no preenchimento do layout.

PS: Não há necessidade de preencher zeros a esquerda, pois o sistema ira fazer automaticamente.

Nome do arquivo para layout:

Informar o nome do arquivo a ser gerado. Caso o usuário deixar em branco, o sistema criará com o nome padrão do banco que é BANCOREAL e a extensão TXT.

Extensão:

3 caracteres - nome da extensão do arquivo a ser gerado.


Convênios Banco do Brasil

Cadastro de Convênios do Banco do Brasil

Código do Convênio:

20 caracteres - Na seguinte regra 9999999994444CCVVVBB, onde

999999999 -> código com nove digitos preenchidos com zeros a esquerda

4444 -> código do produto:

0014 - cobrança cedente

0019 - cobrança sacada

0126 - pagamento fornecedores PGT

0024 - captura de cheques

CC -> carteira de cobrança para o caso de cobrança cedente obrigatório

VVV -> variação da carteira de cobrança p/caso de cobrança cedente obrigatório

BB -> Nos lotes de crédito em Conta, Doc ou pagamento eletronico de

titulos, deixar obrigatoriamente em branco.

* PS: É necessário preencher os 20 caracteres, campo obrigatório fornecido pelo banco.

Nome do Convênio /Recurso:

Campo não utilizado no preenchimento do layout enviado ao banco, usado apenas para controle gerencial do Sistema.

Núm. Convênio EDO (Recibo no terminal bancário):

12 caracteres - Número do contrato atribuido pelo EDO ( Trata-se da prestação de serviço de disponibilização de contracheques em Terminais de Auto-Atendimento e Internet, para correntistas que recebem salário no Banco, com a desoneração da distribuição física de holerity/contra cheques pelo Orgão pagador.

* PS: Campo de preenchimento obrigatório fornecido pelo banco, não é necessário digitar zeros a esquerda.

Sequencial (FPS - PIS)

5 caracteres - Numero sequencial para informações na geração de arquivo de participantes do PIS usado no Menu eventuais - PIS/PASEP - FPS PIS/PASEP (arquivo)

* PS: Não é necessário digitar zeros a esquerda.


Convênios Banco Banespa

Cadastro de Convênios do Banespa

Código do Convênio:

Se o Tipo de Layout for 200 posições preencher o codigo do convênio com 4 caracteres, caso o Tipo de Layout padrão for 240 posições o codigo deverá ser preenchido com 20 caracteres

* PS: É necessário preencher todos os caracteres, campo obrigatório fornecido pelo banco.

Nome do Convênio /Recurso:

Campo não utilizado no preenchimento do layout enviado ao banco, usado apenas para controle gerencial do Sistema.


Convênios Caixa Federal

Cadastro de Convênios da Caixa Federal

Código do Convênio:

6 caracteres - Para tipo de layout SICOV(150 posições) e SIACC(240 posições).

20 caracteres - Para tipo de layout SIACC(150 posições), na seguinte orderm:

6 caracteres: com o numero do convenio

2 caracteres: com o tipo de compromisso, podendo ser "02" Pagto de Salários, "06"

Salário ampliação de Base ou "11" Débito automático.

4 caracteres: com o nº do compromisso, ex: "0001".

8 caracteres: brancos.

* PS: É necessário preencher todos os caracteres, campo obrigatório fornecido pelo banco.

Nome do Convênio /Recurso:

Campo não utilizado no preenchimento do layout enviado ao banco, usado apenas para controle gerencial do Sistema.


Convênios Nossa Caixa

Cadastro de Convênios da Nossa Caixa

Código do Convênio:

5 caracteres - Identifica a Empresa no Banco para determinados tipos de serviço.

* PS: É necessário preencher todos os caracteres, campo obrigatório fornecido pelo banco.

Nome do Convênio /Recurso:

Campo não utilizado no preenchimento do layout enviado ao banco, usado apenas para controle gerencial do Sistema.


Convênios Banco Bradesco

Cadastro de Convênios do Bradesco

Código do Convênio:

5 caracteres - Codigo Fornecido pelo Banco

* PS: É necessário preencher todos os caracteres.

Nome do Convênio /Recurso:

Campo não utilizado no preenchimento do layout enviado ao banco, usado apenas para controle gerencial do Sistema.


Convênios Banco Bandepe (Pernambuco)

Cadastro de Convênios do Banco Bandepe (Pernambuco)

Código do Convênio:

4 caracteres, Identificação da Empresa, junto ao Banco

* PS: É necessário preencher todos os caracteres, campo obrigatório fornecido pelo banco.

Nome do Convênio /Recurso:

Campo não utilizado no Layout, portanto não é necessário o preenchimento.


Convênios Banco Real ABN AMRO

Cadastro de Convênios Banco Real ABN AMRO

Código do Convênio:

20 caracteres - Código adotado pelo Banco para identificar o contrato de Prestação de Serviço entre este e a Empresa Cliente, na seguinte regra AAAACCCCCCCPG, onde

AAAA -> código da agência do convênio

CCCCCCC -> número da conta do convênio

PG -> literal fixa

* PS: É necessário preencher todos os caracteres, campo obrigatório fornecido pelo banco.

Nome do Convênio /Recurso:

Campo não utilizado no preenchimento do layout enviado ao banco, usado apenas para controle gerencial do Sistema.


Configuração Layout Banco Brasil

Configurações para Layout do Banco do Brasil

Câmara Compensação:

3 caracteres - Preencher o código da camara de compensação da agência mantenedora da conta do favorecido.

NúmeroSequencial:

6 caracteres - Evoluir um número sequencial a cada header de arquivo.

*PS: o sistema gera automático esse número, pois se for gerado o mesmo arquivo mais de uma vez, não esquecer de voltar a última sequência.

Versão do Layout:

3 caracteres - Identifica o Nº da versão do,layout do lote, composto de:

versão - 2 digititos

release - 1 digito

*PS:: somente poderá ser modificado quando houver alteração nos lotes de serviço e desde que aprovadas pelo CNAB.

Avisa Favorecido:

Avisar o favorecido Sim ou Não

Mensagem de Aviso:

Descrição da mensagem enviada ao favorecido, campo opcional da Empresa.

Gerar Arquivo para Demonstrativo de Pagto. em Terminal Bancário (EDO001) ?

Se o usuário optar por SIM o Sistema irá gerar o arquivo de crédito, conforme layout EDO001 que é aquele demonstrativo efetuado através dos terminais de auto atendimento e internet disponibilizado pelo Banco. Caso o usuário optar por NÃO o sistema gerará o arquivo de crédito conforme layout padrão CNAB240 (posições).

Gerar Registro Tipo "B":

Se o usuário optar por SIM o Sistema irá gerar o registro tipo 3B, conforme layout fornecido pelo banco (CNAB240), para todos os trabalhadores cadastrados no referido convênio. Caso o usuário optar por NÃO o Sistema gerará esse tipo de registro apenas para os funcionários configurados com forma de crédito tipo DOC (no cadastro de trabalhadores botão Contas)


Configuração Layout Banco Banespa

Configurações para Layout do Banco Banespa

Ident. por extenso TS:

14 caracteres - Somente usado se o Tipo de Layout for 200 posições, na orientação do banco preencher com "CRÉDITOS EM CC"

Câmara Compensação:

3 caracteres - Preencher o código da camara de compensação da agência mantenedora da conta do favorecido.

NúmeroSequencial:

6 caracteres - Evoluir um número sequencial a cada header de arquivo.

*PS: o sistema gera automático esse número, pois se for gerado o mesmo arquivo mais de uma vez, não esquecer de voltar a última sequência.

Versão do Layout:

2 caracteres - Somente usado se o Tipo de Layout for 200 posições, na orientação do banco versão Abril/2005 preencher com "01"

Avisa Favorecido:

Avisar o favorecido Sim ou Não

Mensagem de Aviso:

Descrição da mensagem enviada ao favorecido, campo opcional da Empresa.

Tipo Layout:

Escolher se o Convênio efetuado junto ao Banco usará o tipo de layout 1-Padrão 200 posições ou 2-Padrão 240 posições. Caso o usuário não selecionar nenhuma das opções, o sistema irá automaticamente usar como padrão o ítem 2, ou seja de 240 posições.


Configuração Layout Caixa Federal

Configurações para Layout da Caixa Econ. Federal

Identificação do Serviço:

17 caracteres - Preencher com "FOLHA PAGAMENTO", usado apenas no tipo layout SIACC(150 posições)

Câmara Compensação:

3 caracteres - Campo não usado no layout do referido banco.

Avisa Favorecido:

Avisar o favorecido Sim ou Não

NúmeroSequencial:

6 caracteres - Evoluir um número sequencial a cada header de arquivo.

*PS: o sistema gera automático esse número, pois se for gerado o mesmo arquivo mais de uma vez, não esquecer de voltar a última sequência.

Versão do Layout:

2 caracteres - Para tipo de Layout SIACC(150 posições) orientação do manual v003 preecher com "04".

3 caracteres - Para tipo de Layout SIACC(240 posições). Lembrando que há variação do nº conforme data firmada do convênio.

*PS: Para tipo de Layout SICOV(150 posições) não é necessário o preenchimento

Versão do Lote::

3 caracteres - Apenas para tipo de Layout SIACC(240 posições). Lembrando que há variação do nº conforme data firmada do convênio.

*PS: Para tipo de Layout SICOV(150 posições) e SIACC(150 posições), não é necessário o preenchimento

Mensagem de Aviso:

Descrição da mensagem enviada ao favorecido, campo opcional da Empresa.

Tipo Layout ?

Selecionar o tipo de layotu que a Empresa irá usar:

1-SIACC (150 posições)

2-SIACC(240 posições)

3-SICOV(150 posições)

Tipo Compromisso:

Selecionar o tipo de compromisso a ser preenchido, caso o usuário deixar em branco o sistema ira gerar como "02" Pagamento Salário.

Tipo Arquivo:

Selecionar a Identificação do Ambiente Cliente, caso o usuário deixar em branco o sistema ira gerar como "T" teste.

Opções usada apenas nos tipos SIACC (150 e 240 posições)

Cód Compromisso:

4 caracteres - Codigo informa pelo banco

Parâmetro Transmissão:

2 caracteres - Codigo informado pelo banco

Opções usada apenas nos tipos SIACC (150 e 240 posições)


Configuração Layout Nosa Caixa

Configurações para Layout da Nossa Caixa

Modalidade Conta

2 caracteres - Nº da Modalidade/tipo da conta corrente da Empresa no Banco.

NúmeroSequencial:

6 caracteres - Evoluir um número sequencial a cada header de arquivo.

*PS: o sistema gera automático esse número, pois se for gerado o mesmo arquivo mais de uma vez, não esquecer de voltar a última sequência

Versão do Layout:

3 caracteres - Identifica o Nº da versão do,layout do lote, composto de:

versão - 2 digititos

release - 1 digito

Na orientação do Banco versão 1.3/2001 preencher com "020"

Avisa Favorecido:

Avisar o favorecido Sim ou Não

Câmara Compensação:

3 caracteres - Preencher o código da camara de compensação da agência mantenedora da conta do favorecido. Pela orientação do Banco se a forma de Pagamento for diferente de DOC, preencher com "000", versão 1.3/2001 .

Mensagem de Aviso:

Descrição da mensagem enviada ao favorecido, campo opcional da Empresa.


Configuração Layout Banco Bradesco

Configurações para Layout do Banco Bradesco

Ident. por extenso TS:

15 caracteres - Identificação por extenso do tipo de serviço. Na orientação do banco preencher com "CREDITO C/C".

Câmara Compensação:

3 caracteres - Preencher o código da camara de compensação da agência mantenedora da conta do favorecido.

Número do Arquivo [0..9]:

Número de 0 a 9, usado na formação do nome do arquivo a ser gerado pelo sistema automaticamente, quando o nome do arquivo para layout, informado no cadastro de contas estiver em branco . Esse arquivo será criado com o seguinte formato: FP + dia e mês da geração do arquivo + o número do arquivo.(0...9)

Arquivo remetido:

Se o usuário escolher "Real", e o nome do arquivo para layout, informado no cadastro de contas estiver em branco, o sistema irá gerar automaticamente com o nome de extensão "REM", caso a escolha do usuário for "Teste", será criado com a extensão "TST".

Gerar Arquivo para Demonstrativo de Pagto. em Terminal Bancário ?

Se o usuário optar por SIM o Sistema irá gerar o arquivo de crédito, conforme Layout Emissão de Comprovante Salarial - Versão 06 de 28/06/2006, que é aquele demonstrativo efetuado através dos terminais de auto atendimento e internet disponibilizado pelo Banco. Caso o usuário optar por NÃO o sistema gerará o arquivo de crédito conforme layout padrão.

Referência da Operação do Lote ?

Deverá ser 'I' para Inclusão, ou 'A' para Acerto ou 'S' para Substituição, conforme instrução do layout do banco. Lembrando q o padrão será 'I' de Inclusão.

* PS. Se o usuário optar po 'A' Acerto (irá funcionar como Exclusão e Inclusão simultaneamente, alterando o conteúdo existente caso ja exista, ou incluindo caso não exista.


Configuração do Layout Banco Bandepe(Pernambuco)

Configurações para Layout do Banco Bandepe (Pernambuco)

Código da Lotação:

12 caracteres, Codigo de Identificação da lotação fornecido pelo Banco

Descrição da Lotação:

40 caracteres - Descrição da lotação no sistema do cliente, informação fornecida pelo Banco

Informar dados de Lotação:

Se o usuário optar por Sim, o sistema criará o tipo de registro (B1) com a função C - Cadastrar (Incluir/Alterar), conforme layout fornecido pelo Banco, caso o usuário optar por Não, esse tipo de registro não será gerado.

Informar Apenas Admitidos no Mês/Ano:

Se o usuário optar por Sim, o sistema criará o tipo de registro (B2) com a função C - Cadastrar (Incluir/Alterar), apenas dos funcionários admitidos, e com movimentação no mês/ano referência,

caso o usuário optar por Não, o sistema criará esse tipo de registro para todos os funcionários com movimentação no mês/ano referência.

Data Validade Início:

Indica a partir de que dia este provento estará disponível para o funcionário.

Data Validade Fim:

Indica até que dia este provento estará disponível para o funcionário.

*PS- A data de fim de validade dever ser, no mínimo dez dias depois da data de início de validade.


Configuração do Layout Banco Real ABN AMRO

Configurações para Layout Banco Real ABN AMRO

NúmeroSequencial:

6 caracteres - Evoluir um número sequencial a cada header de arquivo.

*PS: o sistema gera automático esse número, pois se for gerado o mesmo arquivo mais de uma vez, não esquecer de voltar a última sequência.

Versão do Layout:

3 caracteres - Código adotado pela FEBRABAN para identificar qual a versão de layout do arquivo encaminhado. No banco real este layout atende as versões 030, 040 e 050.

Avisa Favorecido:

Avisar o favorecido Sim ou Não

Mensagem de Aviso:

Descrição da mensagem enviada ao favorecido, campo opcional da Empresa.


Integração Contábil

Opção disponível no menu Parâmetros

A tela de parâmetros da integração contábil deve ser utilizada por entidades que desejam automatizar o processo de contabilização da folha de pagamento. Para isso o usuário deve classificar todos os eventos de proventos nos termos da tabela da despesa do SCPI, inclusive o número da ficha.

A classificação contábil dos eventos é feita por unidade de custeio e por exercício, mas isso não significa trabalho repetitivo, pois o SIP automatiza 90% das tarefas transferindo a configuração dos eventos automaticamente de um exercício para o outro e disponibilizando botões na tela de configuração que replicam a classificação nas demais unidades de custeio.

Na parte superior da tela de configuração estão o nome da unidade atual e o navegador de unidades. Ao centro são listados os eventos com a classificação da unidade atual. Na parte inferior há o botão de importação da tabela da despesa, o botão de seleção da classificação da despesa e o botão de replicação das configurações. Por fim, na lateral direita há a tela de acesso direto ao SCPI 8, essa tela é apresentada apenas se o SIP estiver conectado ao banco de dados do SCPI.

Para informações sobre a conexão do SIP ao SCPI consulte o item "Integração Contábil" do tópico Configurações .

O navegador de unidades é disposto conforme a imagem abaixo. Além dos botões de funções há a régua de acompanhamento, ela é somente leitura e serve para o usuário identificar se está o começo, no meio ou no fim da lista de unidades da entidade.

A busca de unidade aceita números e letras, quando o usuário digita somente números o SIP busca pelo código da unidade, caso o usuário digite letras o SIP buscará pelo nome da unidade.

Ao selecionar a classificação através da conexão com o SCPI o usuário obterá a mesma tela de seleção que a contabilidade utiliza. A imagem abaixo demonstra parte dela.

Para que seja possível a configuração sem conexão com o SCPI o SIP disponibiliza uma tabela interna de classificação da despesa. Caso o usuário deseje utilizá-la basta clicar no botão "Classificação" da parte inferior da tela do SIP. Se a tabela interna estiver vazia o usuário pode importar o arquivo TABCATEC.XML do SCPI. Para informações detalhadas sobre exportação do sistema de contabilidade consulte o manual do SCPI.

Na tela de acesso direto ao SCPI há as opções de importação que consiste, intuitivamente, em quais itens serão trazidos do SCPI para o SIP. Portanto ao selecionar um item na imagem acima o SIP copiará apenas os dados selecionados nesta opção, podendo ser somente a categoria, somente a ficha ou a categoria e a ficha.

Não obstante a seleção da classificação há também a possibilidade de digitação, para isso basta o usuário digitar cada número que compõe a classificação seguido da tecla enter.

Para digitar 3.1.90.11.01 e ficha 23 o usuário deverá clicar uma vez na posição da categoria e começar a digitar:

"3" seguido de enter;

"1" seguido de enter;

"90" seguido de enter;

"11" seguido de enter;

"01" seguido de enter;

"23" seguido de enter;

Ao pressionar o último enter o SIP posicionará o cursor na coluna categoria do próximo evento.

Terminada a configuração dos proventos o usuário pode trocar de guia e configurar o número da ficha dos descontos.

Finalizada a configuração de uma unidade de custeio o usuário pode replicar as configurações através do botão "Replicar" disponível na parte inferior da tela. Ao clicar no botão o SIP apresentará uma lista de opções conforme a imagem abaixo.

A opção "Replicar Evento Selecionado" copiará a configuração do evento para todas as outras unidades. Já a opção "Replicar Apenas Proventos" copiará a configuração de todos os proventos para as outras unidades. Esta segunda opção troca de nome ao trocar de guia, quando a guia de descontos estiver ativa então o nome será "Replicar Apenas Descontos", e portanto esta opção copiará a configuração de todos os descontos para as outas unidades. Por fim a opção "Replicar Todos" copiará todos os proventos e todos os descontos para as outras unidades.

A guia de Importação/Exportação refere-se a criação e recuperação de arquivos XML que armazenam a configuração dos eventos, e não os dados a serem empenhados, estes que serão exportados pelo menu mensais, opção "Resumo Contábil", subopção " Integração Contábil ".

Por fim o usuário pode imprimir a configuração das unidades através da guia "Imprimir Configuração", nela o SIP disponibiliza opções de impressão apenas dos eventos configurados, ou apenas dos eventos não configurados, apenas a unidade selecionada, entre outros.


Código Reduzido de Afastamento

Opção disponível no menu Parâmetros

Instruções específicas para utilização da tela de cadastro do código reduzido de afastamento do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O código reduzido de afastamento é um agrupamento de até cinco informações de afastamento, dentre elas as principais são a causa, o código de saída e o código de retorno.

O intúito desse código é facilitar a digitação de afastamentos e licenças fazendo com que o usuário memorize apenas um número ao invés de repensar três outros códigos para cada lançamento.

Ao informar os dados do código reduzido o usuário pensa apenas uma vez na configuração dos casos mais frequêntes tais como licença maternidade, afastamento por doença inferior a quinze dias, etc.

A imagem abaixo ilustra o cadastro do código reduzido com um exemplo preenchido de maternidade.

Observe que além dos códigos é possível indicar a quantidade fixa de dias do afastamento/licença, com isso o usuário ganha cinco informações preenchidas automaticamente quando do preenchimento da movimentação, pois o SIP calcula a data de retorno.

O usuário deve informar no mínimo a código e o nome, sendo desnecessário o preenchimento da causa e demais informações, pois o código reduzido pode ser utilizado para controlar licenças que não influenciam na SEFIP nem na RAIS.

A imagem abaixo ilustra o que ocorre no preenchimento da movimentação de afastamento ao utilizar o código reduzido.


Definição de Cargos Funções e Emprego

Definição:

Cargos: Criado por Lei e admissão através de concurso público, regime estatutário.

Função: Livre nomeação e exoneração para cargos de chefia, direção e assessoria.

Emprego: Trabalho pelo regime celetista.


Calcular Avos (X/12)*Avos

Essa nova opção tem como valor padrão o "Sim", que corresponde a maioria dos casos de férias, que é o cálculo normal do SIP.

Selecione "Não" apenas quando não for necessário apurar a proporcionalização em avos das férias.

Informar a quantidade 12 avos no período aquisitivo tem o mesmo efeito, porém é no exemplo a seguir que elas se divergem.

Exemplo:

Empresa utiliza a opção de média por avos nos eventos e o cálculo é de um professor que não possui 12 avos ainda mas é obrigado a receber férias. Nesse caso o divisor da média é os avos reais do trabalhador, por exemplo 8 avos, mas ele não pode sofrer prejuízo em razão de ainda não ter completado o período, então o cálculo (X/12)*Avos não será realizado.


Cadastro de Trabalhadores

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de cadastro de trabalhadores do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O cadastro de trabalhadores do SIP é o único cadastro disponível para calcular através das opções de cálculo do SIP. O Filtro de Pesquisas do cadastro do trabalhador é posicionado automaticamente na opção "Matricula" que facilita a rápida busca de uma única pessoa. Caso o filtro informado seja mais abrangente o SIP disponibilizará duas facilidades ao apresentar os resultados da pesquisa.

A primeira facilidade é a de busca por matricula ao digitar algum número na grid, diferentemente da busca na automática da grid , o SIP sempre localizará matriculas quando o usuário digitar números. Por outro lado se o usuário digitar letras o SIP sempre localizará nomes de trabalhadores.

A segunda facilidade é a busca pelo F10, que é uma tela que disponibiliza a opção de busca por vários campos do cadastro do trabalhador. Ao visualizar a tela o usuário poderá escolher qual campo utilizar para realizar a busca, em seguida o usuário informa os dados que deseja localizar e pressiona o botão "Confirmar".

O cadastro de trabalhadores é dividido em fichas que podem ser acessadas através do botão "Dados Cadastrais". A seguir cada item desse botão serão exemplificados.

Dados Pessoais

Nesta ficha o usuário poderá informar dados de diversos documentos do trabalhador tais como nacionalidade, grau de instrução, estado civil, endereço, características físicas, entre outros.

Admissão/Contrato

Esta ficha armazena as informações do tipo de emprego, vinculo, carga horária, salário inicial, salário atual, cargo inicial, cargo atual, entre outros.

O provimento de cargos e salários é dado através de histórico, portanto o usuário não poderá alterar o cadastro do trabalhador e substituir o cargo indicado inicialmente, apenas informará o novo cargo que o trabalhador ocupará através da inclusão de um item de histórico em que o SIP armazenará os dados do cargo anterior, do posterior, a data e hora atual, o usuário, e a data, o número e o tipo do documento que deu a ordem de alteração.

Assim como a alteração de cargo a alteração de salário também é através de histórico e possui o mesmo mecanismo, pois todos os históricos são padronizados.

Cartão de Ponto

É nesta ficha que o usuário encontrará os dados que influenciam no cálculo do cartão de ponto, pois nela há dados como a jornada, o número do cartão, limite de horas extras, data da implantação do cálculo, entre outros.

Lotação

A ficha de lotação armazena os dados da divisão, subdivisão, unidade de custeio, local de trabalho, que somente podem ser alterados mediante histórico que possui o mesmo mecanismo do ja citado cargo, pois todos os históricos são padronizados. Além desses dados o usuário pode armazenar o local onde a ficha real do trabalhador está armazenada.

Por exemplo, existem quatro gavetas de um armário separadas para a letra "A", neste caso o usuário pode indicar em qual delas a ficha real do trabalhador está armazenada facilitando sua localização.

Calculo

Nesta ficha o usuário poderá informa as configurações que incluenciam o cálculo do trabalhador, tais como a configuração de previdência, imposto de renda, aposentadoria, adiantamento de 13º salário, entre outros.

Situação

Esta ficha armazena as informações da situação do trabalhador que pode ser uma dentre as a seguir.

· 0 - Calculo desativado

esta opção é utilizada pelo SIP automaticamente quando a empresa está configurada para calcular no regime de RPPS. Neste caso o SIP desativa o cálculo quando o trabalhador volta do afastamento.

· 1 - Normal

esta situação é apontada pelo SIP quando o trabalhador participa de calculos que não sejam de rescisão. Nesta situação estão mesmo os trabalhadores afastados, pois a situação do trabalhador em relação ao afastamento não é estática e sim dinâmica, podendo ser respondida apenas mediante uma data. Portanto o cadastro não pode estaticamente estar na situação afastado. Esta opção existe somente como "dispositivo legado" da versão anterior e deve ser descartada em breve.

· 2 - Desligamento sem rescisão

esta opção deve ser utilizada pelo usuário quando ele deseja que o cálculo da rescisão apure apenas o saldo de salários sem computar férias e ou 13º salário.

· 3 - Afastado

esta situação não deve ser utilizada, ela será desativada em breve.

· 4 - Aviso indenizado

esta opção deve ser utilizada quando o usuário deseja calcular a rescisão do trabalhador mediante aviso indenizado. Caso o evento 932 tenha fórmula de cálculo programada e a causa informada seja 11 - sem justa causa, o SIP lançará automaticamente o evento 932 - Aviso Indenizado sem Justa Causa no cálculo da rescisão.

· 5 - Aviso trabalhado

esta situação deve ser escolhida quando o usuário deseja calcular a rescisão do trabalhadr mediante aviso trabalhado.

· 6 - Desligado

esta situação é automaticamente apontada pelo SIP quando o usuário encerra uma referência do tipo 7 - Rescisão. Nesse caso todos os trabalhadores que estiverem nas situaçãoes 2, 4 ou 5 serão transferidos para a situação 6 - desligado.

Ao informar as situação 2, 4 ou 5 o SIP disponibilizará campos adicionais para o usuário informar a data da situação e a data do desligamento, além de solicitar se o dia da rescisão foi um dia trabalhado e se haverá reposição de vaga.

Após informar uma das situações 2, 4 ou 5 o usuário poderá acessar o botão "Movimentação de Afastamentos/Desligamentos" que se apresentará condições do usuário informar as causas e motivos do desligamento. A tela que será exibida é semelhante a tela de informação de afastamentos , com a diferença de omitir as informações de retorno.

Além das situções o usuário pode indicar, nesta fica, dados da aposentadoria de trabalhadores inativos, portanto o SIP considerará para todos os efeitos trabalhador inativo aquele que possuir os motivos de aposentadoria aqui indicados.

SEFIP

Nesta ficha o usuário tem a oportunidade de indicar duas configurações que influenciam diretamente a SEFIP, são elas a categoria do trabalhador e o tipo de ocorrência.

SIPREV

Esta ficha armazena os dados pertinentes a geração do arquivo para o SIPREV, tais como situação previdênciária, órgão e situação funcional.

Sindicato

Nesta ficha o usuário pode indicar a qual sindicato o trabalhador está filiado.

Observações

A ficha de observações é uma grande tela de texto simples disponível para o usuário armazenar notas sobre o trabalhador.

Emprego Anterior

Nesta ficha o usuário pode incluir as diversas empresas que o trabalhador teve vinculo com data de início e término, além de endereço completo e ocupação.

Férias Coletiva

Este item não é uma ficha mas uma opção de replicação da configuração da ordem de pagamento das férias do trabalhador hora selecionado. O primeiro passo para utilizar este mecanismo é filtrar todos os trabalhadores que receberão férias coletiva, em seguida o usuário deve escolher um deles e informar a ordem de pagamento de férias. Concluído o cadastramento da movimentação de férias o usuário deve acionar esta opção para que o SIP replique ela em todos os trabalhadores listados.

Eventos Fixos

Através deste cadastro o usuário pode acessar a lista de eventos fixos do trabalhador, para isso deve clicar no botão "Eventos" e em seguida no item "Eventos Fixos". A tela que será apresentada é uma tela padrão sem filtro de pesquisa em que o usuário poderá incluir, alterar e excluir os eventos que são fixos ao cálculo do trabalhador.

Na tela de eventos fixos o usuário não precisa excluir um evento que hora não participará do cálculo, basta para isto desativá-lo. Além disso o SIP permite que um mesmo evento seja incluir mais de uma vez. Porém os eventos lançados duplamente não serão somados no cálculo.

Os dados de quantidade, referência, valor e porcentagem substituirão os apurados no cálculo e serão marcados como "Digitado" quando a tela de fonte do cálculo for solicitada.

Um exemplo de utilização da data de inicio e a da data limite pode ser um evento de auxilio faculdade em que a data de inicio é a data da matricula na faculdade e a data limite é o término do curso.

Eventuais Diversos

Além do acesso aos eventos fixos o usuário pode acessar exclusivamente os dados dos eventos eventuais do trabalhador selecionado, para isto basta que o usuário acesse a opção "Eventuais Diversos" através do botão "Eventos". Todas as funções disponíveis no lançamento de eventuais estão disponíveis nesta tela também.

Faltas

O cadastro de faltas também pode ser acessado diretamente através do cadastro do trabalhador. Todas as funções disponíveis do lançamento de faltas estão disponíveis, também, exclusivamente no trabalhador.

Férias

A tela de férias é acessada unicamente através do cadastro do trabalhador, na parte superior estão listados os períodos aquisitivos, na parte inferior são listados as ordens de pagamento e gozo de cada período. O SIP admite apenas uma ordem de pagamento, porém inúmeros períodos de gozo. Estes que por sua vez podem ser cancelados ou convocados, somente, ou seja, apenas o gozo e não o pagamento.

Licença Prêmio

A tela de licença prêmio é acessada unicamente através do cadastro do trabalhador, na parte superior estão listados os períodos aquisitivos, na parte inferior são listados as ordens de pagamento e gozo de cada período. O SIP admite apenas uma ordem de pagamento, porém inúmeros períodos de gozo. Estes que por sua vez podem ser cancelados ou convocados, somente, ou seja, apenas o gozo e não o pagamento.

Caso o vinculo do trabalhador não esteja configurado para controlar licença prêmio o SIP emitirá um aviso ao acessar a tela de licença prêmio. Através deste aviso o usuário poderá configurar o vinculo se desejar.

Dependentes

A tela de dependentes é acessada unicamente através do cadastro do trabalhador, nela o usuário poderá incluir e administrar os registros dos dependentes do trabalhador.

Contas

A tela de contas bancárias é acessada unicamente através do cadastro do trabalhador, nela o usuário poderá incluir e administrar as diversas possíveis contas bancárias que um trabalhador possa ter, porém sempre haverá uma conta definida como padrão que será a utilizada na geração do crédito bancário.

Na tela de contas do trabalhador o usuário poderá indicar a qual convênio a conta está vinculada. Dependendo do banco do convênio o usuário poderá escolher diversas formas de pagamento, tais como conta corrente, conta poupança, DOC, cheque administrativo ou cartão salário eletrônico. Para DOC ainda é possível informar outro banco que não o do convênio.

Pensão Alimentícia

A tela de beneficiários de pensão alimentícia é acessada unicamente através do cadastro do trabalhador, nela o usuário poderá incluir e administrar as diversas possíveis pessoas que receberão o valor descontado judicialmente do trabalhador. Cada beneficiário(a) é vinculado a um evento de desconto presente no cadastro de eventos fixos do trabalhador.

Além do nome e CPF o usuário pode indicar um convênio bancário para que a exportação do crédito bancário possa incluir este valor no arquivo a ser enviado ao banco, do contrário o SIP disponibiliza outros dados para que a tesouraria pague a(o) beneficiária(o) através de uma listagem emitida pelo SIP.

Dependendo do banco do convênio o usuário poderá escolher diversas formas de pagamento, tais como conta corrente, conta poupança, DOC e cheque administrativo.

Pensionistas

A tela de pensionistas é acessada unicamente através do cadastro do trabalhador, nela o usuário poderá incluir e administrar as diversas possíveis pessoas que receberão o benefício da pensão sobre o falecido.

Para que os pensionistas sejam pagos pelo SIP é necessário incluí-los no cadastro de trabalhadores, o usuário deve configurá-lo como se fosse um trabalhador normal com eventos fixos e dados de cálculo, em seguida deve alterar o registro do falecido e informar o registro do pensionista anteriormente adicionado através desta tela.

Apenas registros com causa de aposentadoria preenchida poderão ter seu cadastro de pensionistas alterado.

Apenas registro incluídos com a opção "Pensionista" marcada na ficha "Cálculo" poderão ser indicados na lista de pensionistas de algum registro falecido.

Valores

Através do cadastro do trabalhador o usuário pode ter acesso direto aos cálculos efetuados para o mês selecionado na referência . O botão "Valores" disponibiliza todas as opções de cálculo seguidas de duas outras opções a de exibir o cálculo e a de calcular.

Este é um atalho de alta produtividade pois dispensa a memorização da matricula, a abertura manual da tela de cálculo, a informação do filtro e o clique no botão "Resultados" da tela de cálculo .

Ao acessar a exibição de um cálculo o usuário obtém apenas a visualização do mesmo em que não é permitido a realização do cálculo.

O botão "Valores" também disponibiliza três opções de emissão direta da ficha financeira, a primeira é para o exercício selecionado na referência , a segunda é para o período de pagamento das férias do mês, a terceira é para o período de pagamento da licença prêmio do mês.

Ficha financeira para férias e licença prêmio estão disponíveis apenas se houver ordem de pagamento configurada para o mês selecionado na referência .

Imprimir

A opção de impressão do trabalhador possui uma especialidade, trata-se do botão de checagem denominado "Emitir Apenas Registro Selecionado". Esta opção está disponível apenas para as fichas cadastrais e para os relatórios do usuário. A função desta opção é evitar que o usuário tenha que voltar à tela do filtro de pesquisas para imprimir apenas um trabalhador. Portanto caso a pesquisa retorne vários registros e o usuário deseja imprimir apenas a ficha cadastral do registro selecionado, ele deve utilizar esta opção.


Afastamentos/Licenças

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de lançamento de afastamentos e licenças do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O SIP disponibiliza de uma única tela para lançamento de afastamentos, licenças e desligamentos. Para lançar afastamentos e licenças o usuário pode acessar esta tela através do menu "Manutenção", porém para lançamento de desligamento, ou seja, afastamento definitivo, o usuário deve acessar esta tela através do cadastro do trabalhador .

A tela é dividida em três partes, a primeira é onde o usuário deve informar a matricula do trabalhador, a segunda são os dados de saída e a terceira são os dados de retorno.

No geral o importante é preencher a data da saida, a causa e o código SEFIP de saída, o SIP disponibiliza um campo chamado de Código Reduzido que consiste no agrupamento de até cinco informações do movimento, para mais informações sobre esse código consulte o tópico Código Reduzido de Afastamento .

Além dos dados obrigatórios para o afastamento o usuário pode informar outros dados complementares tais como os dados do documento que autoriza o afastamento, os dados do médico e perito e os respectivos códigos de CID atribuido por cada um deles.

Os códigos de CID são interessantes para geração opcional de relatórios estatísticos de doenças relacionadas ao cargo ou local de trabalho. O controle cadastral dos médicos e peritos é importante para a responsabilização do documento de afastamento.

A data da alta em nada influencia o cálculo do trabalhador, já a data do retorno é o primeiro dia trabalhado após o afastamento e influencia diretamente no cálculo.

Observações:

A causa que o SIP utiliza é exatamente a mesma causa que a RAIS solicita.

O código do movimento SEFIP de saída é exatamente o mesmo código que a SEFIP solicita.

O código do movimento SEFIP de retorno é exatamente o mesmo código que a SEFIP utiliza.


Eventos Fixos - Coletivo

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de lançamento de eventos fixos coletivo do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, porém esta tela não se enquadra nos padrões de manutenção por tratar-se de um assistente, caso haja algum item de tela não mencionado neste tópico consulte os artigos sobre padronizações.

A tela de lançamento de eventos fixos coletivo é um assistente que possibilida ao usuário cadastrar de uma única vez vários trabalhadores que possuem características em comum. Todos os eventos lançados através deste assistente ficam interligados aos parâmetros informados para que seja possível desfazer a operação.

Além do lançamento coletivo o assistente possibilita incluir, alterar e excluir dados de um ou vários trabalhadores, bem como também disponibiliza a opção de troca de evento de determinado grupo de trabalhadores.

Este assistente disponibiliza o filtro de pesquisas para a identificação dos trabalhadores que participarão do lançamento.


Eventuais - Coletivo

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de lançamento de eventos eventuais diversos coletivo do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, porém esta tela não se enquadra nos padrões de manutenção por tratar-se de um assistente, caso haja algum item de tela não mencionado neste tópico consulte os artigos sobre padronizações.

Através desta tela o usuário pode lançar para vários trabalhadores um único evento com as mesmas informações de data, quantidade, referência, valor e percentual. Não é possível informar parcelamentos através deste assistente, apenas eventos únicos.

Todos os eventos ficam interligados aos parâmetros informados para que seja possível alterar ou desfazer o lançamento. Para isso o usuário deverá selecionar a opção "Localizar" na primeira tela do assistente.

Este assistente disponibiliza o filtro de pesquisas para a identificação dos trabalhadores que participarão do lançamento.


Lançamento Coletivo de Férias - Desfazer

Desfazer Lançamento Coletivo de Férias

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de desfazer lançamento coletivo de férias do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, porém esta tela não se enquadra nos padrões de manutenção por tratar-se de um assistente, caso haja algum item de tela não mencionado neste tópico consulte os artigos sobre padronizações.

Esta tela possibilita que os lançamentos coletivos de férias, relizados através do cadastro do trabalhador , sejam desfeitos, pois todas as ordens de pagamento lançadas coletivamente ficam interligadas.

Para desfazer um lançamento coletivo de férias basta o usuário selecionar o item que lhe é apresentado conforme os padrâmetros informados e clicar no botão "Selecionar".


Eventuais - Diversos

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de lançamento de eventuais diversos do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

Compete aos eventuais diversos os eventos que não são falta e que não são destinados a folha complementar. São exemplos de eventuais diversos horas extras, adiantamentos e empréstimos bancários.

Através desta tela o usuário pode localizar qualquer registro de lançamento com base nos parâmetros do filtro de pesquisas , além de oferecer o congelamento de itens do lançamento o que agiliza a manutenção de vários itens.

O recurso de congelamento terá efeito se a pesquisa retornar algum registro ou após a primeira inclusão completa.

Ao congelar o evento para lançamento o usuário fica responsável por informar as diversas matrículas que receberão o evento e o SIP preencherá automaticamente o código do evento congelado. Já ao congelar a matrícula o usuário digitará apenas os diversos eventos que a matrícula congelada receberá.

Ao pesquisar o usuário obtém o total da quantidade e o total do valor unitário dos lançamentos, uma vez que esta tela estende a padronização de cadastros, que mostra apenas a contagem de registros.

O lançamento de eventuais diversos é por tipo de referência , portanto o usuário deve ficar atento ao campo de mesmo nome, pois se o evento for lançado na referência 2 - Adiantamento ele não será calculado na referência 1 - Mensal. Porém existe uma excesão quanto ao tipo de referência de rescisão pois ele absorve os eventos lançados na folha mensal.

Eventos de empréstimo devem ser lançados através do controle de parcelamentos e ficará registrado apenas uma vez no arquivo do SIP, diferentemente de versões em que o lançamento é replicado para todos os meses do parcelamento. O controle pode ser em meses ou anos, o usuário deverá informar a data inicial e a quantidade de meses/anos das prestações para que o SIP calcule a data final. A opção "Quitado", disponívels para parcelamentos, deve ser utilizada para casos em que o trabalhador quita o débto direto com a financiadora antecipando o fim das prestações. Portanto o usuário não deve nem pode excluir o lançamento, mas sim quitá-lo.

Por fim o usuário pode registrar observações sobre o lançamento independentemente de ser parcelamento ou não.

Todos os lançamentos têm suas datas verificadas quanto ao encerramento da referência a que elas correspondem, o SIP não permite que a data esteja numa referência encerrada.

Lançamento de horas extras têm suas datas cruzadas com a frequência do trabalhador caso assim a empresa esteja configurada. Isso significa que uma hora extra não poderá ser lançada antes da admissão, depois da demissão, dentro do gozo de férias, licença-prêmio ou afastamento.


Eventuais - Faltas

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de lançamento de falta do trabalhador do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

Esta tela é apresentada com o filtro de pesquisa preenchido com o mês e ano da referência selecionada. Permite o congelamento do evento, da matricula ou de ambos.

O recurso de congelamento terá efeito se a pesquisa retornar algum registro ou após a primeira inclusão completa.

Ao congelar o evento para lançamento o usuário fica responsável por informar as diversas matrículas que receberão a falta e o SIP preencherá automaticamente o código do evento congelado. Já ao congelar a matrícula o usuário digitará apenas os diversos eventos que a matrícula congelada receberá. Por fim, ao congelar ambos matricula e evento o usuário fica responsável por digitar apenas as quantidades em dias ou em horas.

Ao iniciar um lançamento e informar a matricula o usuário obterá a quantidade de horas efetivas do trabalhador que consiste na divisão das horas mensais pelos dias do mês (ex: 220/30 = 7,3333).

Em seguida o usuário deve informar o código do evento de falta que o SIP validará se trata-se de um evento classificado como falta ou não.

Após informar o evento o usuário deverá apontar a data da falta que não necessariamente será calculada no mês da data, pois se a empresa estiver configurada para trabalhar em frequência diferente da do mês o SIP irá atribuir outro para o cálculo.

Um exemplo de falta que não será calculada no mês da data é em empresas configuradas para apurar a frequência do dia 21 ao dia 20, nesse caso para faltas apontadas entre os dias 21 e 30 o SIP atribuirá o mês seguinte como sendo o cálculo.

A quantificação das faltas pode ser dada em dias ou em horas, depende do evento e da real situação da falta.

Por fim o usuário pode registrar observações referentes ao evento hora lançado.


Eventuais - Folha Complementar

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de lançamento de eventos para folha complementar do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

Esta tela deve ser utilizada somente quando a empresa está configurada para calcular folha complementar de eventos lançados. Para mais informações sobre configuração e caluculo de folha complementar consulte o tópico Folha Complementar Mensal .

Caso a empresa não esteja configurada um aviso será emitido alertando o usuário sobre a configuração.

Ao acessar esta tela o usuário terá a opção de filtrar dados com base no filtro de pesquisas . Para informar o trabalhador o usuário poderá ter problemas se o contrato for inativo, para resolver esse problema o usuário deve demonstrar a conciência da operação através do acionamento da opção "Lançar contrato inativo", dessa forma o lançamento poderá ser efetuado para folha complementar de rescisão .

O restante dos dados a serem informados consiste no código do evento, data, quantidade, referência, valor e porcentagem. Não existe restrição quanto a essas informações, basta o usuário atentar para a data que deve ser exatamente a data do pagamento configurado para o cálculo da folha complementar.


Importar Eventuais

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de importação de eventuais no SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, porém esta tela não se enquadra nos padrões de manutenção por tratar-se de importação de arquivo, caso haja algum item de tela não mencionado neste tópico consulte os artigos sobre padronizações.

A importação de eventuais deve ser utilizada quando existe convênio entre instituições financeiras ou com o comércio local para desconto consignado em folha de pagamento.

Firmado o convênio o usuário deve disponibilizar o layout do SIP para a instituição, que poderá escolher entre dois layouts, um para arquivos texto e outro para arquivos xls. O layout pode ser emitido através do botão "Layout" que ao ser clicado disponibilizará as duas opções de layout disponíveis.

Mensalmente a instituição gerará um arquivo no formato escolhido e enviará ao usuário do SIP através de qualquer meio magnético, pode ser disquete, pendrive, CD, internet, etc.

Ao receber o arquivo da instituição o usuário deverá clicar no botão "Importar" que disponibilizará três opções, a primeira é para arquivos do layout de arquivos texto, o segundo para arquivos do layout de arquivos xls e o terceiro é para arquivos do layout da versão anterior do SIP que não deverá ser mais utilizado.

Selecionada a opção desejada de importação o SIP apresentará uma caixa de diálogo em que o usuário deverá apontar o arquivo que deseja importar.

Terminada a importação o SIP tomará dois cursos, caso o arquivo contenha erros de layout a tela apresentará os erros descritos um a um para auxiliar a instituição que está gerando o arquivo para o SIP. Caso o arquivo não contenha erros de layout a tela apresentará a lista de trabalhadores importados com seus valores e situação.

A imagem abaixo ilustra o sucesso da importação do arquivo.

A própria tela possui a legenda do motivo pelo qual alguns registros estão destacados em negrito. São destacados em negrito os nomes dos trabalhadores que apresentam diferença entre o cadastro do SIP e o arquivo. Finalmente são destacados em negrito os valores que foram atualizados pois o evento já se encontrava lançado para o trabalhador naquele mês.

Há casos em que é necessário importar o arquivo novamente devido a falha nas informações enviadas pela instituição. Nesse caso o usuário deve escolher a ação que o SIP tomará ao encontrar o lançamento já efetuado.

Com a lista de importação em tela o usuário pode checar as informações e decidir se irá gravá-las, cancelá-las ou emitir o e-mail de inconsistências.

Ao clicar no botão e-mail o usuário obterá a lista de inconsistências de informações, tais como os já mencionados nomes incorretos e a situação do trabalhador. Este e-mail informa a lista de trabalhadores desligados, afastados, não encontrados e os com nomes incorretos.

Além da lista de inconsistências em tela o SIP abre o gerenciador padrão de e-mail do computador já com o assunto e o corpo da mensagem contendo as inconsistências. Caso o usuário deseje imprimir ao invés de enviar o e-mail basta clicar no botão imprimir localizado na parte inferior da tela.

A imagem abaixo ilustra a lista de inconsistências.

Trabalhadores afastados e com nomes incorretos são importados, já trabalhadores não encontrados ou desligados não são importados. É importante enviar a lista dessas inconsistências para que a instituição financeira ou do comércio local possa cobrar seus devedores através de outro meio que não o da folha de pagamento.

Ao verificar a lista de inconsistências o usuário pode acionar uma nova importação através do botão "Novo".

O SIP não tem como saber o saldo de trabalhadores afastados no momento da importação do arquivo de consignação, é para isso que a lista de afastados é emitida. Portanto caso o usuário decida que um determinado trabalhador afastado pode pagar seu débto através da folha então o usuário deve remover o nome da lista que será enviada a instituição.


Cadastro de Autônomos

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de cadastro de autônomos do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O SIP disponibiliza um controle de prestadores de serviço composto por cadastro e movimento mensal para prestação de contas a SEFIP e a DIRF. Entidades que não controlam o autônomo dentro da administração de pessoal mas controlam dentro da tesouraria também podem utilizar o SIP para enviar dados a SEFIP e a DIRF, basta que o SIP tenha acesso ao arquivo do SCPI e que a empresa esteja configurada para isto.

Para enviar dados dos prestadores de serviço cadastrados no SCPI o usuário deve informar o código da entidade do SIP no SCPI através da guia "SCPI Autônomos" do cadastro de empresas. Com essa configuração o controle de autônomos do SIP será desativado.

O cadastro de autônomos do SIP é completo para a gerência e envio das informações a outros órgãos públicos após preencher todos os dados necessários basta o usuário entrar com os dados da movimentação mensal do autônomo através do menu "Manutenção".


Movimento Mensal Autônomo

Movimento Mensal do Autônomo

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de cadastro do movimento mensal do autônomo do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O SIP disponibiliza um controle de prestadores de serviço composto por cadastro e movimento mensal para prestação de contas a SEFIP e a DIRF. Entidades que não controlam o autônomo dentro da administração de pessoal mas controlam dentro da tesouraria também podem utilizar o SIP para enviar dados a SEFIP e a DIRF, basta que o SIP tenha acesso ao arquivo do SCPI e que a empresa esteja configurada para isto.

Para enviar dados dos prestadores de serviço cadastrados no SCPI o usuário deve informar o código da entidade do SIP no SCPI através da guia "SCPI Autônomos" do cadastro de empresas. Com essa configuração o controle de autônomos do SIP será desativado.

O movimento mensal de autônomos do SIP é completo para a gerência e envio das informações a outros órgãos públicos, após preencher todos os dados necessários o SIP fará o cálculo da previdência e do imposto de renda, tornando possível a emissão do RPA - Recibo de Pagamento de Autônomo.

O RPA pode ser acessado através do botão "Imprimir" da tela deste movimento. Além do recibo o usuário pode imprimir a listagem simples e a listagem por unidade.

A unidade de custeio é a unidade que pagará pelos serviços que o autônomo prestou, e que portanto, será nela empenhado.

Um autônomo pode prestar serviço várias vezes ao longo do mês, para isso o SIP controla todas as datas de cada serviço prestado, porém a data do serviço não necessariamente está dentro do mês de competência do empenho. Portanto é possível registrar a prestação de um serviço em 24 de dezembro e indicar o mês do empenho como sendo janeiro do ano seguinte.

Os demais dados de valores são cópias fiéis da tela de movimentação da SEFIP, o SIP disponibiliza todos os valores para que qualquer imprevisto possa ser resolvido, mas na maioria dos casos apenas o valor da remuneração sem 13º salário é preenchida, há ainda alguns casos que é necessário o preenchimento do campo valor do segurado.

Por fim o usuário pode indicar uma breve descrição do serviço prestado.


CAT

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de cadastro da CAT do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O SIP disponibiliza o preenchimento da CAT - Comunicado de Acidente de Trabalho para que o usuário possa emití-la com todos os dados do trabalhador e da empresa já preenchidos, bastando portanto que o usuário indique apenas os dados pertinentes ao acidente.

A tela da CAT é uma das únicas que possui auto-ajuda, observe que do lado esquerdo da tela há uma grande área em branco que é preenchida quando um dado da CAT é apontado.

Portanto para saber sobre o motivo ou razão de cada campo basta o usuário entrar nele e observer a ajuda que será exibida no lado esquerdo da tela.

O texto da ajuda dessa tela foi retirado do manual de preenchimento do MPS - Ministério da Previdência Social.

Caso a informação de afastamento seja indicada contendo os dados do atestado médico o SIP apresentará a tela de movimentação de afastamento logo após a gravação da CAT. Várias informações de afastamento estarão pré-preenchidas sendo, porém, passíveis de alteração.

Após apresentada a Previdência Nacional a CAT receberá um número e uma data de registro, ao voltar para o SIP o usuário deve alterar a CAT e preencher o campo "Dados do Registro da CAT".


PPP

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de cadastro da PPP do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de cadastro padronizadas .

O SIP disponibiliza o preenchimento do PPP - Perfil Profissiográfico Previdenciário para que o usuário possa emití-lo com todos os dados do trabalhador e da empresa já preenchidos, bastando portanto que o usuário indique apenas os dados pertinentes ao perfil.

A tela do PPP é uma das únicas que possui auto-ajuda, observe que do lado esquerdo da tela há uma grande área amarela que é preenchida quando um dado do PPP é apontado.

Portanto para saber sobre o motivo ou razão de cada campo basta o usuário entrar nele e observer a ajuda que será exibida no lado esquerdo da tela.

O texto da ajuda dessa tela foi retirado do manual de preenchimento do MPS - Ministério da Previdência Social.

O PPP é separado em vários campos, os quais o SIP separa do 13 ao 18 em telas específicas, pois cada um deles pode ser preenchido com vários registros. Para acessar cada campo basta o usuário clicar sobre sua descrição. Quando um desses campos está preenchido o SIP exibe a figura de um papel preenchido, do contrário a figura é de um papel em branco. Observe a imagem abaixo.

Após o preenchimento o usuário pode emitir o documento do PPP através do botão "Imprimir".


Solicitação de 13º Salário no Aniversário

Solicitação de Adiantamento de 13º Salário no Aniversário

Opção disponível no menu Manutenção

Instruções específicas para utilização da tela de Solicitação de Adto. 13º no Aniversário do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de cadastro, porém esta tela não se enquadra nos padrões de manutenção por tratar-se de um assistente, caso haja algum item de tela não mencionado neste tópico consulte os artigos sobre padronizações.

O usuário deve utilizar este assistente quando desejar armazenar a lista de trabalhadores que solicitam adiantamento de 13º Salário no aniversário, diferentemente de entidades que já preveêm o adiantamento em seus estatutos.

Este assistente consiste na inclusão rápida de vários registros de trabalhadores para que ao término o SIP possa alterar a configuração do adiantamento no cadastro de todos os registros de uma única vez. A imagem abaixo ilustra a principal etapa do assistente.

O mecanismo de digitação da listagem é bastante simples, o usuário deve digitar a matricula e pressionar a tecla "Enter" de seu teclado, caso o SIP encontre a matricula ela será incluída na listagem abaixo. Se o usuário deseja incluir vários trabalhadores com características em comum ele pode clicar no botão "Incluir Vários", através dele o SIP disponibilizará a própria tela de cadastro de trabalhadores onde o usuário poderá realizar o filtro que desejar e em seguida clicar no botão "Selecionar" da tela de trabalhadores.

Caso o usuário deseje incluir todos os trabalhadores hora ativos basta clicar no botão vermelho.

Na etapa seguinte a de inclusão o SIP solicita algumas informações finais conforme a imagem abaixo.

Ao concluir o SIP fará a alteração no cadastro de todos os trabalhadores incluídos na listagem.


Layout de arquivos para remessa à Previdência - Modelo I

Leiaute de arquivos para remessa à Unidade de Gestão Previdenciária

· Organização: indexado

· Sistema de codificação: Texto(ASCII)

· Tamanho de registro: 111

1 - Header - Identificador do Ente(estado ou município), data da geração do arquivo, mês/ano de referência.

Grupo | Nº | Nome Campo | Tipo | Tam | Posição | Descrição
Operação | 1 | Tipo de registro | N | 1 | 1 | Preencher com 1
Identificação | 2 | Município | S | 60 | 2 a 61 | Nome do Município
Geração | 3 | Data Geração | N | 8 | 62 a 69 | Data em que foi gerado o arquivo Formato: aaaammdd
Competência | 4 | Data de competência | N | 6 | 70 a 75 | Ano e mês de competência Formato: aaaamm
Preencher com zeros | 5 | Preencher com zeros | N | 36 | 76 a 111 | Preencher com zeros

2 – Registro para efetuação dos dados relativos aos dados cadastrais do Servidor:

Grupo | Nº | Nome Campo | Tipo | Tam | Posição | Descrição
Operação | 1 | Tipo de registro | N | 1 | 1 | Preencher com 2
Matricula | 2 | Matricula | S | 12 | 2 a 13 | Matricula do Servidor
Chave | 3 | CPF | N | 11 | 14 a 24 | CPF do Servidor incluindo o digito verificador
Nome | 4 | Nome do Servidor | S | 60 | 25 a 84 | Nome Completo do servidor sem abreviações
Admissão | 5 | Data admissão | N | 8 | 85 a 92 | Data de admissão do servidor no Ente. Formato: aaaammdd
Nascimento | 6 | Data nascimento | N | 8 | 93 a 100 | Formato: aaaammdd
Orgão | 7 | Sigla do Orgão | S | 10 | 101 a 110 | Sigla do Orgão
Sexo | 8 | Sexo do servidor | S | 1 | 111 | M – Masculino F – Feminino

3 – Registro para migração de dados relativos ao controle financeiro do Servidor:

Grupo | Nº | Nome Campo | Tipo | Tam | Posição | Descrição
Operação | 1 | Tipo de registro | N | 1 | 1 | Preencher com 3
Matricula | 2 | Matricula | S | 12 | 2 a 13 | Matricula do Servidor
Chave | 3 | CPF | N | 11 | 14 a 24 | CPF do Servidor incluindo o digito verificador
Competência | 4 | Data de competência | N | 6 | 25 a 30 | Ano e mês de competência Formato: aaaamm
Salário | 5 | Valor da Remuneração para fins de benefício | N | *17 | 31 a 47 | Remuneração para fins de cálculo de benefícios previdenciários Obs: no campo deve ser incluso as casas decimais
Contr. Partic. | 6 | Valor de Contribuição do Servidor | N | *17 | 48 a 64 | Valor da contribuição previdenciária descontada do servidor/pensionista no mês referente. Obs: no campo deve ser incluso as casas decimais
Contr. Patroc. | 7 | Valor de Contribuição Patronal | N | *37 | 65 a 101 | Valor da contribuição previdenciária patronal, no mês de referência, em relação à remuneração/provento/ pensão do servidor/pensionista Obs: no campo deve ser incluso as casas decimais
Preencher com zeros | 5 | Preencher com zeros | N | 10 | 102 a 111 | Preencher com zeros

* EX: R$ 1.789,53 ® 00000000000178953

Legendas:

N – Campo numérico

S – Campo alfanumérico

OBS:

1 – Os campos numéricos devem ser colocados à direita, preenchendo com zeros as posições não utilizadas.

2 – Os campos alfanuméricos devem ser colocados à esquerda, preenchendo com espaços as posições não utilizadas.


Layout de arquivos para remessa à Previdência - Modelo II

CONTROLE DE ADMINISTRAÇÃO PREVIDENCIÁRIA

LAYOUT DE IMPORTAÇÃO – GENÉRICO II

Observações:

Campos tipo ‘N’ (Numérico) devem ser alinhados à direita e preenchidos com zeros à esquerda, não devendo conter nenhum tipo de pontuação;

Campos tipo ‘C’ (Caracter) devem ser alinhados à esquerda e preenchidos espaços a direita,

Campos tipo ‘D’(Data) devem estar com formato de acordo com o campo Obs.

Serão gerados arquivos de servidores e movimentos.

Cabeçalho do arquivo

Campo | Tipo | Início | Tam | Observação | Nota
Identificador | N | 1-1 | 1 | Fixo 0 (Zero) |
Ente | N | 2-3 | 2 | Código do Ente de Origem | 1
Data de Geração | D | 4-13 | 10 | Data de geração do arquivo (dd/mm/aaaa) |
Período | C | 14-20 | 7 | Período de Referencia (formato mm/aaaa) |
TipoPagto | N | 21-28 | 8 | Código(s) do(s) Tipo(s) de Pagamento. | 2
Descr.TipoPagto | C | 21-8 | 50 | Descrição do(s) Tipo(s) de Pagamento. | 2

OBS. Para cada servidor será agrupado os dados do servidor, os dependentes e Movimentação do Período de Pagamento, quando existir.

Detalhe Servidor

Campo | Tipo | Início | Tam | Observação | Nota
Identificador | N | 1-1 | 1 | Fixo 1 |
Código do Servidor | N | 2-7 | 6 | Código do Servidor na instituição |
Nome do Servidor | C | 8-57 | 50 |  |
Data de Nascimento | D | 58-67 | 10 | dd/mm/aaaa |
Data de Admissão | D | 68-77 | 10 | dd/mm/aaaa |
Situação | N | 78-78 | 1 | Situação do Servidor na Instituição | 3
Código/Cargo | C | 79-128 | 50 | Código e Descrição do Cargo |
Vinculo Empregatício | C | 129-130 | 2 | * Conforme tabela de Vínculos do SIP 7 |
Salário Atual | N | 131-144 | 14 | Salário do servidor |
Grau de Insalubridade | N | 145-146 | 2 |  | 4
PIS/PASEP |  | 147-157 | 11 |  |
CPF | N | 158-168 | 11 |  |
RG | N | 169-180 | 12 |  |
Órgão Emissor do RG | C | 181-187 | 7 |  |
DataEmissão do RG | C | 181-187 | 10 |  |
Nome da Mãe | C | 188-237 | 40 |  |
Nome do Pai | C | 238-277 | 40 |  |
Dt_InicioPrevPropria | D | 278-287 | 10 | Data de início da previdência própria (dd/mm/aaaa) |
Data de Demissão | D | 288-297 | 10 |  |
Sexo | C | 298-298 | 1 | M – Masculino F – Feminino |
Grau de Instrução | N | 299-300 | 2 |  | 5
Nacionalidade | N | 301-302 | 2 |  | 6
Local de Nascimento | C | 303-337 | 35 |  |
N° CTPS | N | 338-344 | 7 |  |
Série CTPS | N | 345-349 | 5 |  |
Estado Civil | N | 350-350 | 1 |  | 7
Endereço | C | 351-420 | 70 | Nome darua, número e complemento |
Bairro | C | 421-460 | 40 |  |
Município | C | 461-495 | 35 |  |
UF | C | 496-497 | 2 |  |
Cep | N | 498-505 | 8 |  |
N° Telefone | N | 506-520 | 15 |  |
N° Celular | N | 521-535 | 15 |  |
Centro de Custo | C | 536-595 | 60 |  |

Detalhe Dependente

Campo | Tipo | Início | Tam | Observação | Nota
Identificador | N | 1-1 | 1 | Fixo 2 |
Código do Servidor | N | 2-7 | 6 | Código do Servidor na instituição |
Código Dependente | N | 8-9 | 2 | Código ou Seqüencial do Dependente |
Nome do Dependente | C | 10-59 | 50 | Nome do Dependente |
Grau Parentesco | C | 60-61 | 2 |  | 8
Data de Nascimento | D | 62-71 | 10 | dd/mm/aaaa |
Sexo | C | 72-72 | 1 | M – Masculino F – Feminino |
Depte.Sal.Família | C | 73-73 | 1 | S – Sim N - Não |
Depte.IRRF | C | 74-74 | 1 | S – Sim N - Não |

Detalhe (Movimento)

Campo | Tipo | Início | Tam | Observação | Nota
Identificador | N | 1 | 1 | Fixo 3 |
Código do Servidor | N | 2-7 | 6 | Código do Servidor na instituição |
Valor Base Calculo | N | 8-21 | 14 | Valor da Base de Cálculo |
Valor Alíquota Contr. | N | 22-31 | 10 | Valor da Alíquota de Contribuição |
Valor Contribuição | N | 32-45 | 14 | Valor da Contribuição |
Valor Alíquota Enc. | N | 46-55 | 10 | Valor da Alíquota do Encargo Patronal |
Valor do Encargo | N | 56-69 | 14 | Valor do Encargo |

Rodapé

Campo | Tipo | Início | Tam | Observação | Nota
Identificador | N | 1-1 | 1 | Fixo 9 |
Qtde.Reg. | N | 2-11 | 10 | Qtde. dos Registro 1 |
Total Base Calculo | N | 12-25 | 14 | Soma do Valor Bases Calculo - Registro 3 |
Total Contribuição | N | 26-39 | 14 | Soma do Valor Contribuição - Registro 3 |
Total de Encargos | N | 40-53 | 14 | Soma do Valor Encargo - Registro 3 |

Arquivo de servidores: Composição do Nome do Arquivo Conforme abaixo:

Sigla do ente:

01 - Prefeitura Municipal

02 - Câmara Municipal

03 - Fundo de Previdência

04 - Serviço Autônomo de Água e Esgoto

05 - Saúde Pública

06 - Autarquia Educacional

07 - Fundação

08 - Hospital

09 - Escritório

10 - Conselho Regional

11 - Farmácia

00 - Outro

+

“PREVSIP”

+

Período do movimento (“MMAAAA”)

Exemplo. Arquivo da Prefeitura do período de 09/2008 (01PREVSIP092008.TXT)

Notas

Nota 1

01 | Prefeitura Municipal
02 | Câmara Municipal
03 | Fundo de Previdência
04 | Serviço Autônomo de Água e Esgoto
05 | Saúde Pública
06 | Autarquia Educacional
07 | Fundação
08 | Hospital
09 | Escritório
10 | Conselho Regional
11 | Farmácia
00 | Outros

Nota 2

1 | Mensal
2 | Adto.Salário
3 | Folha Complementar
4 | Adto.13º Salário
5 | Fechto. 13º Salário
6 | Férias
7 | Rescisão
8 | Compl. Rescisão

Nota 3

1 | Servidor Ativo
2 | Afastado
8 | Aposentado
9 | Pensionista
0 | Desligado

Nota 4

00 | NUNCA FOI EXPOSTO A AGENTES NOCIVOS
01 | NÃO EXPOSIÇÃO AGENTES NOCIVOS (MAS JÁ ESTEVE)
02 | EXPOSIÇÃO AGENTES 15 ANOS
03 | EXPOSIÇÃO AGENTES 20 ANOS
04 | EXPOSIÇÃO AGENTES 25 ANOS
05 | NÃO EXPOSIÇÃO AGENTES NOCIVOS (MULTIPLOS VÍNCULOS)
06 | EXPOSIÇÃO AGENTES 15 ANOS (MULTIPLOS VÍNCULOS)
07 | EXPOSIÇÃO AGENTES 20 ANOS (MULTIPLOS VÍNCULOS)
08 | EXPOSIÇÃO AGENTES 25 ANOS (MULTIPLOS VÍNCULOS)

Nota 5

1 | Analfabeto
2 | Até a 4ª série incompleta do 1º grau
3 | Com a 4ª Série completa do 1º grau
4 | Da 5ª a 8ª série do 1º grau
5 | Primeiro grau completo
6 | Segundo Grau incompleto
7 | Segundo Grau completo
8 | Superior Incompleto
9 | Superior Completo
10 | Mestrado completo
11 | Doutorado completo

Nota 6

10 | Brasileiro
20 | Brasileiro Naturalizado
21 | Argentino
22 | Boliviano
23 | Chileno
24 | Paraguaio
25 | Uruguaio
30 | Alemão
31 | Belga
32 | Britânico
34 | Canadense
35 | Espanhol
36 | Norte Americano
37 | Francês
38 | Suíço
39 | Italiano
41 | Japonês
42 | Chinês
43 | Coreano
45 | Português
48 | Outros - Latino Americano
49 | Outros - Asiáticos
50 | Outros

Nota 7

1 | Solteira(o)
2 | Casada(o)
3 | Viúva(o)
4 | Separada(o)
5 | Outros
6 | Ignorada(o)

Nota 8

00 | Outros
01 | Conjuge
02 | Companheiro
03 | Filho(a) não emancipado menor de 21 Anos
04 | Filho(a) Inválido(a)
05 | Pai(Mãe) com dependência Econômica
06 | Irmão não emancipado menor de 21 Anos com dependência econômica
07 | Irmão inválido com dependência econômica
08 | Enteado não emancipado menor de 21 Anos com dependência econômica
09 | Enteado inválido com dependência econômica
10 | Menor tutelado não emancipado menor de 21 anos c/dependência econômica
11 | Menor tutelado inválido com dependência econômica
12 | Pai
13 | Mãe


Layout SIPREV

SISTEMA INTEGRADO DE INFORMAÇÕES PREVIDENCIÁRIAS

S I P R E V

MANUAL DE IMPORTAÇÃO – Versão 7.00.00

Secretaria de Previdência Social – SPS

Departamento dos Regimes de Previdência no Serviço Público – DRPSP

Coordenação-Geral de Estudos Técnicos, Estatísticas e Informações Gerencias - CGEEI

Esplanada dos Ministérios, Bloco “F”, Anexo Ala “A”, sala 456

CEP: 70.059-902

Telefone: (61) 3317-5380

E-mail: comunidadesiprev@previdencia.gov.br

1.2 – CRIANDO OS ARQUIVOS DE IMPORTAÇÃO

Existem 10 tipos de arquivos que podem ser importados para o SIPREV. São eles:

ORG – contém os dados básicos dos ÓRGÃOS ligados ao Ente

CRR – contém informações referentes às CARREIRAS do Ente

CRG – contém informações referentes aos CARGOS do Ente e seus órgãos

PLN – contém informações referentes aos REGIMES/PLANOS do Ente

VNC – contém informações referentes aos dados de VINCULAÇÃO dos órgãos aos REGIMES/PLANOS do Ente

SR1 – contém informações referentes aos dados básicos dos SERVIDORES (dados pessoais)

SR2 – contém informações referentes aos dados de VÍNCULOS DO SERVIDOR com o órgão (dados funcionais).

DPN – contém informações referentes aos dados dos DEPENDENTES dos servidores

CPV – contém informações referentes aos dados de Remunerações e CONTRIBUIÇÕES Previdenciárias de servidores e pensionistas

TMP – contém informações referentes aos dados de TEMPOS de RPPS e RGPS do servidor

Para importarmos todos os dados contidos nos arquivos de importação do SIPREV, devemos nos atentar para a ordem de precedência dos mesmos, ou seja, determinados arquivos não podem ser importados sem antes importarmos os dados de seu precedente. Exemplo: para importarmos os Dados Funcionais (SR2) precisamos antes nos certificar que os Dados Pessoais (SR1) já estejam alimentados na base de dados do SIPREV, para que o sistema possa relacionar os campos das tabelas.

SUGESTÃO IMPORTANTÍSSIMA:

Para facilitar o processo de importação, aconselhamos aos Entes que possuem poucos registros referentes aos arquivos de ÓRGÃOS (ORG), CARREIRAS (CRR), CARGOS (CRG), REGIMES/PLANOS (PLN) e VÍNCULOS (VNC) em suas bases de dados, que façam o cadastro destas informações manualmente no Site SIPREV, sem a necessidade de criação destes arquivos para posterior importação, pois desta forma agilizaremos o processo de carregamento da base do SIPREV. Uma vez carregadas, manualmente, estas informações diretamente no Site SIPREV, nos preocuparemos apenas com a criação dos últimos cinco (5) arquivos: DADOS PESSOAIS (SR1), DADOS FUNCIONAIS (SR2), DEPENDENTES (DPN), CONTRIBUIÇÕES (CPV) e TEMPOS (TMP).

Para inserir as informações dos dados referentes aos arquivos ORG, CRR, CRG, PLN e VNC, manualmente, no Site SIPREV, localize os Capítulos destes cadastros no manual de Cadastro, pois neles você irá encontrar todas as orientações para o preenchimento correto dos dados, deixando a Base de Dados bem consistente, possibilitando assim uma importação sem muitas complicações dos demais arquivos (SR1, SR2, DPN, CPV e TMP).

Se você optar por esta orientação, inicie o processo de criação dos arquivos de importação diretamente no arquivo de Dados Pessoais do Servidor (SR1).

O layout dos arquivos do SIPREV segue um padrão de estrutura. Todos são divididos em três partes:

1. Header, ou cabeçalho, que contém as informações de identificação do arquivo,

2. Corpo, como conjunto de dados propriamente dito, e

3. Trailler, ou rodapé, com as informações finais.

A seguir, um exemplo de arquivo TXT, contendo o as informações de três Órgãos/Entidades a serem importadas para o SIPREV:

ORG.txt

CABEÇALHO

ßHßORGß990000ß00ß20000101ß20000101ß120010ßN

1

2

3

ßIß1ß15101ßGOVERNO DO ESTADOßGE

ßIß1ß15101ßSECRETARIAßSE

RODAPÉ

ßIß1ß15101ßDEPARTAMENTO DE TRANSITOßRR

ßTß3

1.3.1 – CABEÇALHO

Vamos começar a visualizar a forma como esses arquivos são preenchidos tomando como base o padrão para o header, ou cabeçalho dos arquivos.

Antes de mais nada, uma informação importantíssima: para os arquivos de importação do SIPREV, adotou-se o símbolo Beta (ß) para demarcar a separação dos campos. Portanto, o preenchimento de cada campo, deve ser iniciado com o símbolo Beta (ß). Para inserir o símbolo Beta (ß), digite no teclado “Alt+225”.

ßHßAAAßEEEEEEßCCßAAAAMMDDßAAAAMMDDßHHMMSSßR

Esta representação contém todos os campos que integram o cabeçalho dos arquivos de importação do SIPREV. Observe que o sinal gráfico Beta (ß) separa os diversos campos:

H = indicativo de header (cabeçalho)

AAA = Indicativo do tipo de Arquivo (ORG, CRR, CRG, PLN, VNC, SR1, SR2, DPN, CPV, TMP). Estes serão detalhados posteriormente.

EEEEEE = código SIAFI do Ente

CC = Código seqüencial de envio do arquivo, com início em 00 e fim em 99, reiniciando a cada mês em 00

AAAA = ano de referência do movimento

MM = mês de referência do movimento

DD = dia de referência do movimento

AAAA = ano de geração do arquivo

MM = mês de geração do arquivo

DD = dia de geração do arquivo

HH = hora de geração do arquivo

MM = minuto de geração do arquivo

SS = segundo de geração do arquivo

R = tipo de remessa conforme descrito: N = normal, C = complementar, S = suplementar.

1.3.2 – RODAPÉ

O Trailler, ou rodapé segue a mesma linha:

ßTßQQQQQQQ

T = indicativo de trailler (rodapé)

QQQQQQQ = quantidade de registros (linhas) no corpo do arquivo (excluindo as linhas referentes ao cabeçalho e ao rodapé).

1.3.3 – CORPO

Tomando um exemplo prático, vejamos como é constituído o layout da Tabela de Órgãos, que tem o objetivo de identificar, de forma única, os órgãos ligados ao Ente no SIPREV.

Arquivo para migração de dados básicos dos ÓRGÃOS ligados ao Ente para o SIPREV (ORG.TXT)

Layout ORG.txt

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Poder | 2 | Código do Poder | N | 1 | X | Código do Poder: 1- Executivo, 2 – Legislativo, 3 – Judiciário, 4 – Ministério Público
Órgão | 3 | Código do Órgão | S | 12 | X | Número do órgão no Sistema de orçamento do Ente
 | 4 | Nome do Órgão | S | 100 | X | Nome do órgão
 | 5 | Sigla do Órgão | S | 10 |  | Sigla do órgão

LEGENDAS:

Tipo - Tipo de Campo

N - Campo numérico

S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo. Caso o valor do campo tenha tamanho inferior ao máximo, não preencher com zeros à esquerda ou espaços em branco.

Exemplos:

Campo Alfanumérico: Nome do Servidor: ßJoão da Silvaß.

Campo Numérico: Tipo de campo N(13,2) - o campo terá 13 números inteiros e 2 decimais, SEM SEPARADOR, ou seja sem vírgula ou ponto, e sem zeros à esquerda (Ex: ß567833ß, quando o número for 5.678,33)

Campo Obrigatório

X - Indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

NOTAS:

1 – Cada registro (linha) deverá vir separado com CRLF (ENTER);

2 – No caso de não haver a informação para o campo, colocar somente o caracter separador (ß), sem espaço entre o beta anterior, Isto é, quando não existir uma informação não obrigatória, basta não informá-la.

3 – Se o valor do campo numérico for zero, deve ser enviado um caracter 0 (zero) , caso contrário (campo vazio) será considerado como null (informação não fornecida, inexistente);

4 – Os Códigos SIAFI dos Entes (Estados e Municípios) encontram-se disponíveis na Internet no endereço http://www.previdencia.gov.br/docs/SIAFI.zip

A seguir, temos um exemplo de uma linha, do corpo do arquivo de ORG, que pode ser criada a partir do layout:

Exemplo: ßIß1ß100001ßGABINETE CIVIL DO GOVERNADORßGABI

3

4

5

1 – O primeiro grupo, denominado Operação, contém um campo de número 1 que identifica a Operação a ser realizada:

Ø Deve ser preenchido com a letra “I” que indica que será uma Inclusão de dados; Ou preenchido com a letra “A” que indica uma Alteração de dados.

Ø O tipo está definido como string (alfanumérico);

Ø Aceita no máximo 1 caracter (ou seja, 1 dígito);

Ø É um campo obrigatório (ou seja, deve ser preenchido).

2 – O segundo grupo, denominado Poder, contém o campo Código do Poder de número 2:

Ø Ele informa o Código do Poder, que pode ser Executivo(1), Legislativo(2), Judiciário(3) ou Ministério Público(4).

Ø O tipo está definido como numérico, ou seja, aceita somente números;

Ø Aceita no máximo 1 caracter (ou seja, 1 dígito);

Ø É um campo obrigatório (ou seja, deve ser preenchido).

3 – O terceiro grupo, denominado Órgão, contém três campos:

Ø O campo de número 3 informa o Código do Órgão, que é o Número do órgão no sistema de orçamento do Ente;

Ø Ele é do tipo string (alfanumérico), ou seja, aceita letras e números;

Ø Aceita até 12 caracteres (ou seja, 12 dígitos)

Ø É um campo obrigatório (ou seja, deve ser preenchido).

4 – O campo de número 4 informa o Nome do Órgão:

Ø Ele é do tipo string (alfanumérico), ou seja, aceita letras e números;

Ø Aceita até 100 caracteres (ou seja, 12 dígitos);

Ø É um campo obrigatório (ou seja, deve ser preenchido).

5 – O campo de número 5 informa a Sigla do Órgão:

Ø Ele é do tipo string (alfanumérico), ou seja, aceita letras e números;

Ø Aceita até 10 caracteres (ou seja, 10 dígitos);

Ø Não é um campo obrigatório (ou seja, não precisa ser preenchido).

1.4 – LAYOUT DOS ARQUIVOS DE IMPORTAÇÃO

1.4.1 – ARQUIVO DE ÓRGÃOS (ORG.txt)

Arquivo para migração de dados básicos dos ÓRGÃOS ligados ao Ente para o SIPREV (ORG.txt)

Objetivo: Identificar de forma única os órgãos ligados ao Ente no SIPREV.

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Poder | 2 | Código do Poder | N | 1 | X | Código do Poder: 1- Executivo, 2 – Legislativo, 3 – Judiciário, 4 – Ministério Público
Órgão | 3 | Código do Órgão | S | 12 | X | Número do órgão no Sistema de orçamento do Ente
 | 4 | Nome do Órgão | S | 100 | X | Nome do órgão
 | 5 | Sigla do Órgão | S | 10 |  | Sigla do órgão

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: ORG.txt

CABEÇALHO

ßHßORGß990000ß00ß20000101ß20000101ß120010ßN

ßIß1ß15100ßGOVERNO DO ESTADOßGE

ßIß1ß15101ßSECRETARIAßSE

RODAPÉ

ßIß1ß15102ßDEPARTAMENTO DE TRANSITOßRR

ßTß3

IMPORTANTE:

Devido as diversas peculiaridades de cada Ente, foram definidos alguns padrões de preenchimento dos campos nos quais, o Técnico responsável pela criação destes arquivos, não disponha de tais informações.

Desta forma, caso aconteça de no momento da criação dos arquivos, você se deparar com alguns campos nos quais suas Descrições não estejam bem definidas, causando dúvidas quanto ao seu preenchimento, ou até mesmo se o seu Ente não disponha das informações solicitadas pelo Layout, recomendamos que sejam inseridos o que chamaremos de “DADOS PADRÕES”.

Estes “DADOS PADRÕES” serão importados para o SIPREV e, no momento oportuno, serão identificados em Relatórios, possibilitando ao Ente listar rapidamente os dados inconsistentes e tomar as devidas providências para atualização dos mesmos.

DADOS PADRÕES DO ARQUIVO DE ÓRGÃOS (ORG.txt)

1. Não sofre alteração

2. Caso não tenha a informação, deverá ser preenchido com o valor “1” (Executivo).

3. Caso não tenha a informação, deverá ser preenchido com um determinado intervalo começando de 90000 até 99999.

4. Caso não tenha a informação deverá ser preenchido com o termo NÃO INFORMADO.

5. Não sofre alteração

1.4.2 – ARQUIVO DE CARREIRAS (CRR.txt)

Arquivos para migração das CARREIRAS do Ente para o SIPREV (CRR.txt)

Objetivo: Identificar de forma única a Carreira no SIPREV.

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Órgão | 2 | Código do Órgão | S | 12 | X (*) | Número do órgão no Sistema de orçamento do Ente
Carreira | 3 | Código da Carreira | S | 10 | X | Código da Carreira no Ente/órgão
 | 4 | Nome da Carreira | S | 60 | X | Nome da Carreira

(*) Caso o Ente possua uma tabela única de carreiras, informar no campo Código do Órgão o Código SIAFI do Ente.

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: CRR.txt

CABEÇALHO

ßHßCRRß990000ß00ß20000101ß20000101ß120010ßN

ßIß15100ß1ßANALISTA

ßIß15100ß2ßTECNICO

RODAPÉ

ßIß15100ß3ßAUDITOR

ßTß3

DADOS PADRÕES DO ARQUIVO DE CARREIRAS (CRR.txt)

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela ORG.

Caso não tenha a informação deverá ser preenchido com um determinado intervalo começando de 90000 até 99999

Caso não tenha a informação deverá ser preenchido com NÃO INFORMADO.

1.4.3 – ARQUIVO DE CARGOS (CRG.txt)

Arquivo para migração dos CARGOS do Ente e seus órgãos para o SIPREV (CRG.txt):

Objetivo: Identificar de forma única o Cargo no SIPREV.

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Órgão | 2 | Código do Órgão | S | 12 | X (*) | Número do órgão no Sistema de orçamento do Ente
Carreira | 3 | Código da Carreira | S | 10 | X | Código da carreira a que pertence este cargo
Cargo | 4 | Código do Cargo | S | 10 | X | Código do Cargo no Ente/órgão
 | 5 | Nome do Cargo | S | 60 | X | Nome do Cargo
 | 6 | Aposentadoria Especial | N | 1 |  | 1 – Professor 2 – Magistrado 3 – Membro do MPU 4 – Membro do TCU
 | 7 | Acumulação de Cargo | S | 1 |  | A – Acumulável N – Não Acumulável

(*) Caso o Ente possua uma tabela única de cargos, informar no campo Código do Órgão o Código SIAFI do Ente.

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: CRG.txt

CABEÇALHO

ßHßCRGß990000ß00ß20000101ß20000101ß120010ßN

ßIß15100ß1ß1ßANALISTA DE SISTEMASßßN

ßIß15100ß2ß1ßTECNICO ADMINISTRATIVOßßN

RODAPÉ

ßIß15100ß2ß2ßTECNICO JUDICIARIOßßN

ßTß3

DADOS PADRÕES DO ARQUIVO DE CARGOS (CRG.txt)

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela ORG.

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela CRR.

Caso não tenha a informação deverá ser preenchido com um determinado intervalo começando de 90000 até 99999.

Caso não tenha a informação deverá ser preenchido com NÃO INFORMADO.

Não sofre Alteração

Não sofre Alteração

1.4.4 – ARQUIVO DE REGIMES/PLANOS (PLN.txt)

Arquivo para migração dos REGIMES/PLANOS do Ente para o SIPREV (PLN.txt)

Objetivo: Identificar de forma única cada Regime/Plano do Ente no SIPREV.

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Regime | 2 | Código do REGIME no Ente | N | 1 | X | 1 – Regime Próprio dos Servidores Civis, 2 – Regime Próprio dos Militares 3 – Regime Geral de Previdência Social
Plano | 3 | Código do PLANO no Ente | S | 2 | X | Identificação única do plano no Ente
 | 4 | Nome do Plano | S | 60 | X | Nome do PLANO no Ente
 | 5 | Código de Situação do Plano | N | 1 | X | 1 – Em Manutenção, 2 – Em Extinção, 3 – Extinto

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: PLN.txt

CABEÇALHO

CORPO

ßHßPLNß990000ß00ß20000101ß20000101ß120010ßN

RODAPÉ

ßIß1ßP1ßPlano de Previdência dos Servidores Civisß1

ßTß1

DADOS PADRÕES DO ARQUIVO DE REGIMES/PLANOS (PLN.txt)

1. Não sofre Alteração

2. Caso não tenha a informação deverá ser preenchida como padrão Nº. 1 “Regime Próprio dos Servidores Civis”.

3. Caso não tenha a informação deverá ser preenchido com um intervalo de 90 a 99

4. Caso não tenha a informação deverá ser preenchido com NÃO INFORMADO.

5. Caso não tenha a informação deverá ser preenchido como padrão Nº. 1 “Em Manutenção”.

1.4.5 – ARQUIVO DE VÍNCULO DOS ÓRGÃOS AOS REGIMES/PLANOS (VNC.txt)

Arquivo para migração dos dados relativos à vinculação dos órgãos aos REGIMES/PLANOS do Ente (VNC.txt)

Objetivo: Identificar de forma única os planos aos quais os órgãos são vinculados:

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Órgão | 2 | Código do Órgão | S | 12 | X | Número do órgão no Sistema de orçamento do Ente
Plano | 3 | Código do PLANO no Ente | S | 2 | X | Código do Plano no Ente
 | 4 | Data de início da vinculação | N | 8 | X | Data de início vinculação do PLANO ao órgão. Formato: AAAAMMDD

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: VNC.txt

CABEÇALHO

ßHßVNCß990000ß00ß20000101ß20000101ß120010ßN

ßIß15100ßP1ß18000101

ßIß15101ßP1ß18000101

RODAPÉ

ßIß15102ßP1ß18000101

ßTß3

DADOS PADRÕES DO ARQUIVO DE VÍNCULO DOS ÓRGÃOS AOS REGIMES/PLANOS (VNC.txt)

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela ORG.

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela PLN.

Caso não tenha a informação deverá ser preenchido com a data 1800/01/01.

1.4.6 – ARQUIVO DE DADOS PESSOAIS DO SERVIDOR (SR1.txt)

Arquivos para migração de dados básicos dos Servidores (SR1.txt)

Objetivo: Identificar de forma única os servidores dos órgãos ligados ao Ente no SIPREV e transferir seus dados pessoais complementares.

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A = Alteração
Chave única do Servidor no SIPREV | 2 | CPF servidor | N | 11 | X | Formato: 00000000000
 | 3 | Data de Nascimento do Servidor | N | 8 | X | Formato: AAAAMMDD
 | 4 | Sexo do servidor | S | 1 | X | M – Masculino e F –Feminino
Dados da Pessoa | 5 | Nome Servidor | S | 60 | X | Completo sem abreviações
 | 6 | Data óbito | N | 8 |  | Formato: AAAAMMDD
Nome Mãe | 7 | Nome da Mãe do Servidor | S | 60 | XX(*) | Completo sem abreviações
Estado Civil | 8 | Código do Estado Civil | N | 1 | XX | Vide Tabela 4
Telefone | 9 | Telefone | S | 15 |  |
E-mail | 10 | E-mail | S | 60 |  |
Documentos pessoais | 11 | Número da Carteira de Identidade | S | 15 | XX | Pode conter separadores
 | 12 | Órgão/UF expedidor | S | 10 | XX | Sigla órgão / UF
 | 13 | Data de Emissão | N | 8 |  | Formato: AAAAMMDD
Endereço Residencial do servidor | 14 | Endereço | S | 60 | XX |
 | 15 | Bairro | S | 20 |  |
 | 16 | Município | N | 6 | XX | Código do Município no Sistema SIAFI
 | 17 | CEP | N | 8 | XX | Formato: 00000000
Características Pessoais | 18 | NÃO INFORMAR ESTE CAMPO |  |  |  | Este campo foi desativado no SIPREV (preencher com ßß)
 | 19 | NÃO INFORMAR ESTE CAMPO |  |  |  | Este campo foi desativado no SIPREV (preencher com ßß)
 | 20 | PASEP/PIS/NIT | N | 11 | X | Informar o PASEP, ou PIS, ou NIT.

(*) O valor “XX” representa um campo não-obrigatório, porém essencial para a Gestão.

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: SR1.txt

ATENÇÃO: neste exemplo temos apenas um (1) registro no corpo do arquivo, ou seja, temos apenas os dados de um (1) Servidor.

CABEÇALHO

CORPO

ßHßSR1ß990000ß00ß20000101ß20000101ß120010ßN

RODAPÉ

ßIß11111111111ß18000101ßNßNOME SERVIDORßßNOME DA MAEß0ß33013344ß@ß1.234.567ßSSP/SPß19000101 ßENDERECOßBAIRROß123ß70000100ß18000101ß99999999999ß99999999999

ßTß1

* Todo o conteúdo do corpo do arquivo texto, no exemplo acima, deve permanecer na mesma linha, conforme demonstrado abaixo:

ßHßSR1ß990000ß00ß20000101ß20000101ß120010ßN

ßIß11111111111ß18000101ßNßNOME SERVIDORßßNOME DA MAEß0ß33013344ß@ß1.234.567ßSSP/SPß19000101 ßENDERECOßBAIRROß123ß70000100ß18000101ß99999999999ß99999999999

ßTß1

DADOS PADRÕES DO ARQUIVO DE DADOS PESSOAIS DO SERVIDOR (SR1.txt)

Não sofre Alteração

Caso não tenha a informação ou o CPF seja inválido, deverá ser preenchido com “11111111111”.

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Caso não tenha a informação deverá ser preenchido com “M” ou “F”.

Não sofre Alteração

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido como “NÃO INFORMADO”

Caso não tenha a informação deverá ser preenchido com “0” (zero) que corresponde a “OUTROS”.

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não informar este campo

Não informar este campo

Caso não tenha a informação deverá ser preenchido com o número “99999999990”

1.4.7 – ARQUIVO DE DADOS FUNCIONAIS DO SERVIDOR (SR2.txt)

Arquivos para migração de dados relativos aos vínculos do Servidor com o órgão (SR2.txt)

Objetivo: Identificar de forma única cada Registro funcional que o Servidor mantém com o órgão ao qual está vinculado na data da transferência deste arquivo:

Grupo | N° | Nome Campo | Tipo | Tam | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Órgão | 2 | Código do Órgão | S | 12 | X | Número exclusivo do Órgão no Sistema de Orçamento do Ente
Chave única do Servidor no SIPREV | 3 | CPF servidor | N | 11 | X | Formato: 00000000000
 | 4 | Data de Nascimento do Servidor | N | 8 | X | Formato: AAAAMMDD
 | 5 | Sexo do servidor | S | 1 | X | M – Masculino e F – Feminino
Chave única do vínculo do Servidor ao Ente | 6 | Matrícula | S | 12 | X | Pode conter separadores
 | 7 | Data de Ingresso no Ente | N | 8 | X | Data de Ingresso do Servidor no Ente. Formato: AAAAMMDD
 | 8 | Código do Vínculo | N | 2 | X | Identifica o Vínculo do Servidor com o Ente Vide Tabela 2
Situação Previdenciária | 9 | Código da Situação Previdenciária do Servidor | N | 2 | X | Identifica a Situação Previdenciária do Servidor Vide Tabela 1
Situação Funcional | 10 | Código Situação Funcional | N | 2 | X | Identifica a Situação Funcional do Servidor Vide Tabela 3
Plano Previdenciário | 11 | Código do Plano no Ente | S | 2 | X | Identificação única do plano no Ente
 | 12 | Data de vinculação do servidor ao plano | N | 8 | X | Formato: AAAAMMDD
Carreira e Cargo Atual do Servidor | 13 | Código da Carreira | S | 10 | X | Tabela do Ente
 | 14 | Data de Ingresso na Carreira | N | 8 | X | Formato: AAAAMMDD
 | 15 | Código do Cargo | S | 10 | X | Tabela do Ente
 | 16 | Data da Posse no Cargo | N | 8 | X | Formato: AAAAMMDD
Exoneração | 17 | Data de Exoneração | N | 8 |  | Data de Exoneração do Servidor no Ente
Órgão de Origem | 18 | NÃO INFORMAR ESTE CAMPO |  |  |  | Este campo foi desativado no SIPREV (preencher com ßß)

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: SR2.txt

ATENÇÃO: neste exemplo temos apenas um (1) registro no corpo do arquivo, ou seja, temos apenas os dados funcionais de um (1) Servidor.

CABEÇALHO

CORPO

ßHßSR2ß990000ß00ß20000101ß20000101ß120010ßN

RODAPÉ

ßIß15100ß11111111111ß18000101ßNß12345ß20000101ß0

ß99ß99ßP1ß20000101ß1ß20050101ß1ß20050101ßß15100

ßTß1

DADOS PADRÕES DO ARQUIVO DE DADOS FUNCIONAIS DO SERVIDOR (SR2.txt)

ATENÇÃO:

Para o SR2 (Dados Funcionais) a importação com os Dados Padrões só será permitida caso as inconsistências das informações encontradas, em seus arquivos precedentes (SR1, ORG, CRR e CRG), já estejam corrigidas ou atualizadas no SIPREV. Desta forma, sugerimos que o Ente atualize o maior número de informações inconsistentes no SIPREV, para posteriormente preencher este arquivo com os Dados Padrões aqui definidos.

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com um intervalo de NI0000000000 a NI9999999999 (NI = Não informado).

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Caso não tenha a informação deverá ser preenchido com “0” (zero) que corresponde a “OUTROS”.

Caso não tenha a informação deverá ser preenchido com “99” que corresponde a “SEM VÍNCULO”.

Caso não tenha a informação deverá ser preenchido com “99” que corresponde a “SEM VÍNCULO”.

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela PLN.

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 3 da tabela CRR.

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Caso não tenha a informação deverá ser preenchido com um registro do campo nº. 4 da tabela CRG.

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Não sofre Alteração

Não informar este campo

1.4.8 – ARQUIVO DE DEPENDENTES (DPN.txt)

Arquivo para migração de dados relativos aos DEPENDENTES dos servidores (DPN.txt):

Objetivo: Identificar de forma única, como uma PESSOA no SIPREV, cada dependente que possua vínculo de parentesco e/ou dependência com os servidores previamente informados.

Grupo | Nº | Nome Campo |  | Tipo | Tam |  | Obrig | Descrição
Operação | 1 | Operação |  | S | 1 |  | X | Identifica a operação: I = Inclusão, A= Alteração
Chave única do SERVIDOR no SIPREV | 2 | CPF servidor |  | N | 11 |  | X | Formato: 00000000000
 | 3 | Data de Nascimento do Servidor |  | N | 8 |  | X | Formato: AAAAMMDD
 | 5 | Sexo do servidor |  | S | 1 |  | X | M – Masculino e F – Feminino
 | 4
Chave única do DEPENDENTE no SIPREV | 5 | CPF Dependente |  | N | 11 |  | X | Formato: 00000000000
 | 6 | Data de Nascimento do Dependente |  | N | 8 |  | X | Formato: AAAAMMDD
 | 7 | Sexo do dependente |  | S | 1 |  | X | M – Masculino e F – Feminino
 | 8 | Nome do dependente |  | S | 60 |  | X | Completo sem abreviações
Data do óbito | 9 | Data óbito do dependente |  | N | 8 |  |  | Formato: AAAAMMDD
Nome Mãe | 10 | Nome da Mãe do Dependente |  | S | 60 |  | XX(*) | Completo sem abreviações
Estado Civil | 11 | Código do Estado Civil do dependente |  | N | 1 |  |  | Vide Tabela 4
Telefone | 12 | Telefone do dependente |  | S | 15 |  |  |
Email | 13 | E-mail do dependente |  | S | 60 |  |  |
Documentos Pessoais | 14 | Número da Carteira de Identidade |  | S | 15 |  |  | Pode conter separadores
 | 15 | Órgão/UF expedidor |  | S | 10 |  |  | Sigla órgão / UF
 | 16 | Data de Emissão |  | N | 8 |  |  | Formato: AAAAMMDD
Endereço do Dependente | 17 | Endereço |  | S | 60 |  |  |
 | 18 | Bairro |  | S | 20 |  |  |
 | 19 | Município |  | N | 6 |  |  | Código do Município no Sistema SIAFI
 | 20 | CEP |  | N | 8 |  |  | Formato: 00000000
Relação de Dependência com o servidor | 21 | Código do tipo de Dependência |  | N | 2 |  | X | Vide tabela 5
 | 22 | Data do início da relação de dependência |  | N | 8 |  |  | Formato: AAAAMMDD
 | 23 | Motivo de início da relação de dependência |  | N | 2 |  | X | Vide tabela 6
 | 24 | Data de fim da relação de dependência |  | N | 8 |  |  | Formato: AAAAMMDD
 | 25 | Motivo de fim da relação de dependência |  | N | 2 |  |  | Vide tabela 7
Capacidade | 26 | Tipo de capacidade |  | N | 1 |  |  | 1 – Válido 2 - Inválido
Informar os campos abaixo, obrigatoriamente, para todos os dependentes que sejam também pensionistas:
Chave única do pensionista | 27 |  | Matrícula do dependente /pensionsta no órgão | S | 12 | XX(**) |  |  | Pode conter separadores
 | 28 |  | Data registro do dependente /pensionista no órgão | N | 8 | XX(**) |  |  | Formato AAAAMMDD
 | 29 |  | Código do Vínculo com o órgão | N | 2 | XX(**) |  |  | Único valor assumido, nesse caso: 99 – SEM VÍNCULO

(*) O valor “XX” representa um campo não-obrigatório, porém essencial para a Gestão.

(**) Para os dependentes que sejam também pensionistas, estes campos são obrigatórios.

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: DPN.txt

ATENÇÃO: neste exemplo temos apenas um (1) registro no corpo do arquivo, ou seja, temos apenas os dados de um (1) Dependente.

CABEÇALHO

ßHßDPNß990000ß00ß20000101ß20000101ß120010ßN

CORPO

ßIß11111111111ß18000101ßNß11111111111ß18000101ßN

RODAPÉ

ßNOME DO DEPENDENTEßßNOME DA MAEß0ßTELEFONE ßEMAILßRGßORGAO/UFßDATA EMISSAOßENDERECO ßBAIRROßCODIGO MUNICIPIOßCEPß0ß18000101ß0ßßß1ßßß

ßTß1

DADOS PADRÕES DO ARQUIVO DE DEPENDENTES (DPN.txt)

ATENÇÃO:

Para o arquivo DPN a importação com os Dados Padrões só será permitida caso as inconsistências das informações encontradas, em seus arquivos precedentes (SR1 e SR2), já estejam corrigidas ou atualizadas no SIPREV. Desta forma, sugerimos que o Ente atualize o maior número de informações inconsistentes no SIPREV, para posteriormente preencher este arquivo com os Dados Padrões aqui definidos.

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Caso não tenha a informação ou o CPF seja inválido, deverá ser preenchido com “11111111111”

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Caso não tenha a informação deverá ser preenchido com “M” ou “F”

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com “0” (zero) que corresponde a “OUTROS”.

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com “0” (zero) que corresponde a “OUTROS”.

Não sofre Alteração

Não sofre Alteração

Não sofre Alteração

Caso não tenha a informação deverá ser preenchido com um intervalo de NI0000000000 a NI9999999999 (NI = Não informado)

Caso não tenha a informação deverá ser preenchido com um intervalo de 1800/01/01 a 1899/12/31

Deverá ser preenchido com “99” que corresponde a “SEM VÍNCULO”.

1.4.9 – ARQUIVO DE REMUNERAÇÕES E CONTRIBUIÇÕES (CPV.txt)

Arquivo para migração de dados relativos às REMUNERAÇÕES/PROVENTOS E CONTRIBUIÇÕES PREVIDENCIÁRIAS de servidores e pensionistas (CPV.txt):

Grupo | Nº | Nome Campo | Tipo | Tam. | Obrig | Descrição
Operação | 1 | Operação | S | 1 | X | Identifica a operação: I = Inclusão, A= Alteração
Órgão | 2 | Código do Órgão | S | 12 | X | Número exclusivo do Órgão no Sistema de Orçamento do Ente
Chave única de vinculação do Servidor/ Pensionista ao Ente | 3 | Matrícula do Servidor/Pensionista | S | 12 | X | Pode conter separadores
 | 4 | Data de Admissão/Início do Vínculo do Servidor/Pensionista com o Ente | N | 8 | X | Formato: AAAAMMDD
 | 5 | Código do Vínculo | N | 2 | X | Identifica o Vínculo do Servidor/Pensionista com o Ente (Vide Tabela 2)
Competência das Remunera-ções/Contri-buições | 6 | Competência | N | 6 | X | Ano e Mês a que se refere as Remunerações e Contribuições Previdenciárias. Formato AAAAMM
Folha de Pagamento | 7 | Número da Folha de Pagamento | N | 2 | X | Número seqüencial que identifica a folha de pagto efetuada no mês (*)
Moeda | 8 | Código Moeda | N | 1 | X | 1 – Real
Remunera-ções / Contribuições Previdenciá-rias | 9 | Valor da Remuneração/Provento/Pensão | N | 15** (13,2) | X | Remuneração/Provento/Pensão total do servidor/pensionista no mês de referência
 | 10 | Valor da Base de Cálculo da Contribuição da Pessoa | N | 15** (13,2) | X | Base de Contribuição da Pessoa
 | 11 | Valor da Base de Cálculo da Contribuição Patronal | N | 15** (13,2) | X | Base de Contribuição Patronal
 | 12 | Valor da Remuneração para fins de Benefícios | N | 15** (13,2) | X | Remuneração para fins de cálculo de benefícios previdenciários
 | 13 | Valor de Contribuição da Pessoa | N | 15** (13,2) | X | Valor da contribuição previdenciária descontada do servidor/pensionista no mês de referência
 | 14 | Valor de Contribuição Patronal | N | 15** (13,2) | X | Valor da contribuição previdenciária patronal, no mês de referência, em relação à remuneração/provento/pen-são do servidor/pensionista
 | 15 | Valor da Devolução da Contribuição | N | 15** (13,2) |  | Valor da devolução da contribuição previdenciária do servidor/pensionista no mês de referência
 | 16 | Valor da Diferença da Contribuição | N | 15** (13,2) |  | Valor da diferença da contribuição previdenciária do servidor/pensionista no mês de referência
Campos obrigatórios para servidor em gozo de benefício previdenciário:
Benefício em gozo pelo servidor / dependente | 17 | Código do Benefício | N | 2 |  | Vide tabela 8
 | 18 | Data de Concessão do Benefício | N | 8 |  | Formato: AAAAMMDD
 | 19 | Data de Cessação do Benefício | N | 8 |  | Formato: AAAAMMDD

(*) Utilizar o Número da Folha de Pagamento = 13 para a folha de pagamento do 13º salário.

(**) Total de 15 posições sendo: 13 posições p/ número inteiro e 2 últimas posições p/ os centavos.

Ex: R$ 1.508,25 = representar no arquivo 150825 (sem o ponto e a virgula).

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: CPV.txt

ATENÇÃO: neste exemplo temos apenas um (1) registro no corpo do arquivo, ou seja, temos apenas os dados referentes a proventos/contribuição de um (1) Servidor.

CORPO

RODAPÉ

CABEÇALHO

ßHßCPVß990000ß00ß20000101ß20000101ß120010ßN

ßIß15100ß12345ß20000101ß0ß200001ß1ß1ß200000ß200000ß200000ß200000ß20000ß20000ßßßßß

ßTß1

DADOS PADRÕES DO ARQUIVO DE REMUNERAÇÕES E CONTRIBUIÇÕES (CPV.txt)

Não se aplica.

1.4.10 – ARQUIVO DE TEMPOS DE RPPS E RGPS (TMP.txt)

Arquivo para migração dos dados relativos aos Tempos de Regime Próprio e Regime Geral de Previdência do Servidor (TMP.txt)

Objetivo: Informar os tempos de contribuição do servidor nos Regimes Próprio e Geral de Previdência, anteriores à vinculação ao Ente federativo atual.

Grupo | Nº | Nome Campo | Tipo | Tam. |  | Obrig | Descrição
Operação | 1 | Operação | S | 1 |  | X | Identifica a operação: I = Inclusão, A= Alteração
Chave única do Servidor no SIPREV | 2 | CPF do Servidor | N |  | 11 | X | Formato: 0000000000000
 | 3 | Data de Nascimento do Servidor | N |  | 8 | X | Formato: AAAAMMDD
 | 4 | Sexo do Servidor | N |  | 1 | X | M – Masculino e F - Feminino
Tempo RGPS | 5 | Número Protocolo Certidão | S | 20 |  |  | Número da Certidão de Tempo de Contribuição fornecida pelo INSS
 | 6 | CNPJ da Empresa | N | 14 |  |  | CNPJ da Empresa
 | 7 | Nome da Empresa | S | 60 |  |  | Nome da Empresa
 | 8 | Data Inicial | N | 8 |  |  | Formato: AAAAMMDD
 | 9 | Data Final | N | 8 |  |  | Formato: AAAAMMDD
 | 10 | Serviço Público | S | 1 |  |  | Identifica se o tempo de RGPS foi no serviço público: S – SIM e N - NÃO
Tempo RPPS | 11 | Ente empregador | N | 6 |  |  | Código SIAFI do Município ou Estado em que o servidor esteve vinculado a Regime Próprio de Previdência
 | 12 | Data Inicial do Vínculo | N | 8 |  |  | Data do início do vínculo ao RPPS. Formato: AAAAMMDD
 | 13 | Data Final do Vínculo | N | 8 |  |  | Data do fim do vínculo ao RPPS. Formato: AAAAMMDD
 | 14 | Tempo Líquido RPPS | N | 5 |  |  | Tempo líquido de vinculação do servidor ao Regime Próprio de Previdência.
Aposentadorias Adquiridas | 15 | Código do Benefício | N | 2 |  |  | Indica o código do benefício de aposentadoria já adquirida pelo servidor (vide tabela 8).

LEGENDAS:

Tipo - Tipo de Campo:

Ø N - Campo numérico

Ø S - Campo alfanumérico

Tamanho do Campo: Indica o tamanho máximo de caracteres do campo.

Campo Obrigatório: O preenchimento com a letra “X” indica que o campo é obrigatório e deve sempre ser informado para inclusões ou alterações de informações.

Exemplo: TMP.txt

ATENÇÃO: neste exemplo temos apenas um (1) registro no corpo do arquivo, ou seja, temos apenas os dados referentes aos tempos de um (1) Servidor.

CABEÇALHO

CORPO

ßHßTMPß990000ß00ß20000101ß20000101ß120010ßN

RODAPÉ

ßIß11111111111ß18000101ßNß1234ßCNPJßNOME DA EMPRESAßDATA INICIOßDATA FIMßSßßßßß

ßTß1

DADOS PADRÕES DO ARQUIVO DE TEMPOS DE RPPS E RGPS (TMP.txt)

Não se aplica.

1.4.11 – TABELAS PADRONIZADAS

Tabela 1

Situação Previdenciária
ID_MPAS | Descrição
1 | SERVIDOR ATIVO
2 | SERVIDOR INATIVO
3 | SERVIDOR INSTITUIDOR DE PENSÃO
4 | PENSIONISTA
5 | SERVIDOR FALECIDO S/PENSIONISTA
6 | EX-PENSIONISTA
99 | SEM VÍNCULO PREVIDENCIÁRIO

Tabela 2

Vínculos com o órgão
ID_MPAS | Descrição
0 | OUTROS
1 | SERVIDOR EM CARGO EFETIVO
2 | SERVIDOR EM CARGO TEMPORÁRIO
3 | SERVIDOR EM CARGO COMISSIONADO EXCLUSIVO
4 | MILITAR
5 | EMPREGADO PÚBLICO (CLT)
6 | EXERCENDO MANDATO ELETIVO
99 | SEM VÍNCULO

Tabela 3

Situação Funcional
ID_MPAS | Descrição
1 | EM EXERCÍCIO
2 | EXONERADO
3 | LICENCIADO COM REMUNERAÇÃO
4 | LICENCIADO SEM REMUNERAÇÃO
5 | CEDIDO COM ÔNUS
6 | CEDIDO SEM ÔNUS
7 | REQUISITADO COM ÔNUS
8 | REQUISITADO SEM ÔNUS
9 | DEMITIDO
10 | DISPONIBILIDADE
99 | SEM VÍNCULO

Tabela 4

Estados Civis
ID_MPAS | Descrição
0 | OUTROS
1 | SOLTEIRO
2 | CASADO
3 | VIUVO
4 | SEPARADO JUDICIALMENTE
5 | DIVORCIADO
6 | UNIÃO ESTÁVEL

Tabela 5

Tipos de Dependência
ID_MPAS | Descrição
0 | OUTROS
1 | CONJUGE
2 | COMPANHEIRO(A)
3 | FILHO(A) NÃO EMANCIPADO MENOR DE 21 ANOS
4 | FILHO(A) INVÁLIDO(A)
5 | PAI (MÃE) COM DEPENDÊNCIA ECONÔMICA
6 | IRMÃO NÃO EMANCIPADO MENOR DE 21 ANOS COM DEPENDÊNCIA ECONÔMICA
7 | IRMÃO INVÁLIDO COM DEPENDÊNCIA ECONÔMICA
8 | ENTEADO NÃO EMANCIPADO MENOR DE 21 ANOS COM DEPENDÊNCIA ECONÔMICA
9 | ENTEADO INVÁLIDO COM DEPENDÊNCIA ECONÔMICA
10 | MENOR TUTELADO NÃO EMANCIPADO MENOR DE 21 ANOS COM DEPENDÊNCIA ECONÔMICA
11 | MENOR TUTELADO INVÁLIDO COM DEPENDÊNCIA ECONÔMICA

Tabela 6

Motivos de INÍCIO de Dependência
ID_MPAS | Descrição
0 | OUTROS
1 | NASCIMENTO
2 | ADOÇÃO
3 | FILHO POSTUMO
4 | TUTELA DO MENOR
5 | DECISÃO JUDICIAL
6 | INVALIDEZ
7 | CASAMENTO
8 | UNIÃO ESTÁVEL
9 | DEPENDÊNCIA ECONÔMICA

Tabela 7

Motivos de FIM de dependência
ID_MPAS | Descrição
0 | OUTROS
1 | MAIORIDADE
2 | EMANCIPAÇÃO
3 | DECISÃO JUDICIAL
4 | ÓBITO
5 | SEPARAÇÃO JUDICIAL
6 | INDEPENDÊNCIA ECONÔMICA
7 | CESSAÇÃO DE INVALIDEZ

Tabela 8

Benefícios
ID_MPAS | Descrição
0 | OUTROS
1 | APOSENTADORIA POR INVALIDEZ
2 | APOSENTADORIA POR IDADE
3 | APOSENTADORIA POR TEMPO DE CONTRIBUIÇÃO
4 | APOSENTADORIA COMPULSÓRIA
5 | AUXÍLIO DOENÇA
6 | AUXÍLIO DOENÇA POR ACIDENTE DE TRABALHO
7 | AUXÍLIO ACIDENTE
8 | AUXÍLIO RECLUSÃO
9 | SALÁRIO FAMÍLIA
10 | SALÁRIO MATERNIDADE
11 | PENSÃO POR MORTE DE SEGURADO ATIVO
12 | PENSÃO POR MORTE DE APOSENTADO POR IDADE OU POR TEMPO DE CONTRIBUIÇÃO
13 | PENSÃO POR MORTE DE APOSENTADO POR INVALIDEZ


Integração Contábil - Exportar

Opção disponível no menu Mensais

Após prévia configuração dos eventos e unidades o SIP disponibiliza a tela de exportação dos dados a serem empenhados para o SCPI através do menu mensais conforme imagem abaixo.

No caso de integração contábil o usuário não deve utilizar o resumo normal da folha. A tela que será apresentada possui diversos relatórios que o usuário pode utilizar para comparar dados do SIP com dados pós-empenho do SCPI.

Além dos relatórios o SIP disponibiliza uma lista de unidades em que o usuário pode selecionar quais participarão do envio, nesse caso o usuário deseja criar lotes de exportação de dados a serem empenhados e o SIP não controla isso automaticamente, é o usuário quem deve anotar quais unidades já foram enviadas para empenho.

Quando o tipo de referência 7 - Rescisão estiver selecionado o SIP mostrará mais uma tabela que conterá os trabalhadores rescindidos no mês. Essa tabela também serve para criação de lotes de envio.


RAIS

RAIS - Relação Anual de Informações Sociais

Problema: Trabalhador não é enviado

Principais critérios para envio de trabalhador a RAIS:

Vínculo deve estar configurado para ser enviado a RAIS;

O trabalhador não pode ser configurado como pensionista (guia cálculo do trabalhador);

O trabalhador não pode ser configurado como aposentado inativo (guia situação do trabalhador);

O trabalhador deve estar ativo no exercício solicitado:

situação igual a 1 ou demissão maior que 31/12

admissão menor ou igual a 31/12

Problema: Trabalhador é enviado mas com valores errados:

Verificar incidência dos eventos para RAIS:


Ficha Financeira do Trabalhador

Opção disponível no menu Anuais

Instruções específicas para utilização da tela de emissão da ficha financeira do trabalhador do SIP 7

Com o intúito de facilitar o aprendizado o SIP 7 foi criado com padronização de telas de relatório, caso haja algum item de tela não mencionado neste tópico consulte o artigo sobre telas de relatório padronizadas .

A ficha financeira do trabalhador pode ser emitida para uma única pessoa ou um conjunto de trabalhadores com características em comum.

Para um único trabalhador o usuário pode escolher o exercício dentre os que existem calculados para o trabalhador selecionado ou pode escolher um período aquisitivo de férias. A escolha entre exercícios e períodos é opcional, trata-se apenas de um atalho intuitivo. Caso nenhuma das opções se encaixe na inteção do usuário ele pode informar o período que desejar através do campo "Período para Filtragem".

Para emitir a ficha financeira de vários trabalhadores o usuário deve selecionar a guia "Coletivo", em seguida o SIP apresentará o filtro de pesquisas para a escolha das características em comum. Ao selecionar esta opção o usuário terá a facilidade de escolher dentre os exercícios já calculados para a empresa selecioanda.

Além do período o usuário pode escolher quais bases serão emitidas na ficha financeira, observe a imagem abaixo para verificar as opções disponíveis.

Caso haja uma grande frequência no modo de visualização das bases escolhidas o usuário pode salvar na máquina local através do botão "Salvar Opções".

Existe ainda a opção de filtrar os eventos que incidem para a DIRF ou RAIS, de modo que o usuário possa conferir com a emissão desses dois arquivos os eventos que estão sendo enviados.


Backup

Utilitário de Backup

A principal função desse módulo é de realizar e restaurar backup (cópia de segurança) da base de dados do SIP 7. Porém existem outras funções adicionais úteis em outras situações.

O Gerenciador de Banco de Dados Firebird não realiza backup em ambiente de rede, do contrário seria possível um usuário mal intencionado solicitar um backup através de uma estação de trabalho e levá-lo consigo.

Portanto mesmo que o backup seja solicitado através de um terminal o Firebird salvará o arquivo dentro do servidor, nunca em uma pasta da rede ou no computador que solicitou o backup.

Instruções para utilização do Backup

Abra o SIP 7 e acesse o menu Backup, opção Utilitário de Backup.

O módulo de backup pode ser aberto através do menu Iniciar do Windows:

Inicar/Programas/Fiorilli SC Ltda/SIP7/SIP Backup.

Realizar Backup

Para realizar um backup manualmente selecione a primeira opção Realizar Backup e clique em Avançar.

(backup automático será abordado mais adiante)

Em seguida o assistente de backup solicitará a pasta ou diretório em que a cópia de segurança será salva.

O nome do arquivo de backup será gerado automaticamente pelo sistema no seguinte padrão:

1. Sigla “BKP” concatenada com

2. Ano da data do computador gerador do backup

3. Mês da data do computador gerador do backup

4. Dia da data do computador gerador do backup

5. Caractere “_” (underline)

6. Hora do computador gerador do backup

7. Minuto do computador gerador do backup

A extensão do arquivo de backup será .FBK de Fiorilli Backup. Um exemplo pode ser observado nas imagens seguintes.

Após armazenar a pasta de destino do backup o assistente solicitará as últimas opções antes de efetuar definitivamente o backup, são elas:

· Acompanhar andamento: mostrará um log detalhado de todas as operações internas (em inglês) ao banco de dados durante o processo de backup.

· Compactar (Zip): efetuará a compressão do arquivo de backup no formato Zip. O arquivo gerado terá o mesmo nome do arquivo de backup, porém com extensão .zip.

· Incluir outros arquivos: além do arquivo .FBK o gerador de backup copiará outros arquivos (para mais informações sobre backup de outros arquivos consulte tópico de mesmo título).

· Desligar o computador após o término do backup: se acionada esta opção desligará o computador gerador do backup. Outra opção será disponibilizada para que o gerador de backup aguarde um tempo, em minutos, antes de desligar o computador.

· Incluir arquivo de log: além do arquivo .FDB o gerador de backup fará a cópia do arquivo de log do sistema que contém todas as operações dos usuários, tais como incluir, alterar, excluir, imprimir, consultas SQL e respostas a perguntas do sistema.

· Enviar direto a Fiorilli (FTP): após o término da cópia de segurança o gerador de backup poderá enviar o arquivo direto a Fiorilli através da internet, bastando para isso que o usuário informe o nome de uma pasta. Essa pasta deverá respeitar o seguinte padrão:

· Nome da entidade seguido de

· Caractere “_” (underline) e

· Sigla do tipo da entidade

Exemplo: Balsamo_PM

A tela a seguir mostra o término do backup, nela pode ser observado o log de operações do gerador de backup, nele constam todas as opções selecionadas pelo usuário e as principais operações que o módulo realizou, com isso é possível que o suporte técnico analise a fonte de algum problema que possa vir a ocorrer.

Restaurar Backup

Para restaurar um backup, que consiste em substituir o arquivo SIP.FDB pelo conteúdo do arquivo de backup .FBK, basta selecionar a segunda opção Restaurar Backup e clicar em Avançar.

Em seguida o arquivo que contém o backup deverá ser informado, note que para restaurar o backup deve ser preenchido o caminho completo e o nome do arquivo.

Por fim o assistente de backup disponibiliza as últimas opções antes de restaurar definitivamente o backup, sobrepondo o arquivo SIP.FDB1 configurado no SIPCON2.

· Acompanhar andamento: mostrará um log detalhado de todas as operações internas (em inglês) ao banco de dados durante o processo de restauração do backup.

· Desligar o computador após o término do backup: se acionada esta opção desligará o computador gerador do backup. Outra opção será disponibilizada para que o gerador de backup aguarde um tempo, em minutos, antes de desligar o computador.

· Incluir arquivo de log: substituirá o arquivo de log do SIP pelo arquivo de log contido no backup.

1. Na verdade os arquivos SIP.FDB e de Log nunca são sobrepostos, o processo de restauração renomeia o arquivo original conforme um padrão e cria um novo arquivo SIP.FDB com o conteúdo do arquivo de backup.

2. A restauração permite, ainda, que o backup seja restaurado em outra pasta ou diretório diferente do configurado no SIPCON, para isso utilize o botão amarelo com um sinal verde de adição ao lado do campo que mostra o arquivo principal, conforme imagem acima. Através dele será possível indicar outra pasta local. Esse procedimento não altera o conteúdo do arquivo SIPCON.INI

Agendamento de Backup Automático

Para agendar o backup automático clique em Agendar Backup e em seguida em Avançar.

O agendamento de backup é composto por três fases:

Fase I - Configurar o tipo de inicialização: consiste em definir se o módulo será carregado na memória do computador no formato de aplicação ou serviço. Se for como aplicação um ícone será mantido ao lado do relógio do Windows, o usuário deverá indicar ainda se será iniciado somente para o usuário atual ou para todos os usuários. Se for como serviço, isso não será necessário pela sua própria natureza, que é de estar operacional antes mesmo de algum usuário efetuar login no Windows.

Observações:

· Usuários do Windows Vista que utilizam UAC devem observar que será solicitado elevação de privilégios na barra de tarefas do Windows antes de aparecer a imagem abaixo.

· O agendamento de backup acessa o endereço "SOFTWARE\Microsoft\Windows\CurrentVersion\Run" no registro do Windows sob uma das chaves: HKEY_LOCAL_MACHINE ou HKEY_CURRENT_USER, apenas para inicialização automática do módulo, todos os outros parâmetros de agendamento são gravados no arquivo Bakcup.ini.

Fase II - Freqüência: a freqüência pode ser definida a cada meia hora durante as 24 horas do dia. Pode ainda ser configurada para alguns dias ou para todos os dias da semana.

Fase III - Pasta do backup automático: indicar a pasta em que os backups automáticos deverão ser salvos.

Ao concluir a configuração do agendamento clique em Salvar e Fechar. Todas as configurações do agendamento serão salvas no arquivo Backup.ini presente na pasta de instalação. Se esse arquivo for excluído o módulo não realizará backup automático.

Tópicos complementares, dicas e truques

Verificar Log:

Essa opção mostra o início, o término, o local e a situação de todos os backups automáticos.

Adicionar outros arquivos:

Possibilita incluir outros arquivos além dos dados do SIP ao ZIP do backup, tais como os documentos que fazem parte da rotina do departamento, ou seja, declarações, planilhas, certificados, entre outros.

A inclusão pode ser feita de duas maneiras. A primeira é informar o caminho completo contendo o nome do arquivo que se deseja incluir. A outra é informar o caminho da pasta adicionada de caracteres curinga e extensões, dessa forma uma pasta inteira pode ser incluída no backup, observe exemplos na imagem abaixo.

Backup/Restore

Essa funcionalidade deve ser utilizada somente mediante orientação do suporte técnico. Sua finalidade consiste, basicamente, em revitalizar a saúde o arquivo de dados SIP.FDB, para casos em que ele não esteja se comportando da maneira esperada.

Apenas Enviar para FTP

Opção muito útil, entre outras, para conexões de internet instáveis, pois o arquivo de backup pode ser separado em inúmeros outros arquivos através do padrão zip e todos podem ser incluídos nesta lista para que sejam enviados gradativamente possibilitando, assim, que em caso de queda da conexão o envio não precise ser reiniciado desde o começo.

Os vários arquivos podem ser adicionados de duas maneiras: a primeira é através do botão Adicionar, dentro do dialogo que surgirá, vários arquivos podem ser selecionados ao mesmo tempo. A segunda forma é através do arrastar-e-soltar, para isso basta manter o módulo de backup aberto ao lado de uma pasta do Windows, em seguida selecione os arquivos desejados e arraste para cima do módulo.

Após a inclusão dos arquivos ainda é necessário informar a pasta em que o backup será salvo na Fiorilli, para isso um padrão deverá ser seguido:

· Nome da entidade seguido de

· Caractere “_” (underline) e

· Sigla do tipo da entidade

Exemplo: Balsamo_PM

Assista ao vídeo de envio de backup ao FTP.

Dica para restaurar backup rapidamente

O módulo de backup suporta três formas de restauração, uma delas é a já detalhada no tópico de restauração, as outras são através do sistema operacional.

Uma da formas adicionais de indicar o arquivo a ser restaurado é através do arrastar-e-soltar, para isso basta arrastar o arquivo que contém o backup para cima do módulo que todas as etapas preliminares da restauração serão puladas e o módulo apenas solicitará as opções finais. Apenas arquivos com extensão .zip e .fbk serão aceitos.

A outra forma é através do comando “Abrir com” do menu de contexto do Explorer do Windows, para isso clique com o botão direito do mouse sobre o arquivo que contém o backup e selecione a opção “Abrir com” e escolha o módulo do SIP como programa que todas as etapas preliminares da restauração serão puladas e o módulo apenas solicitará as opções finais, apenas arquivos com extensão .zip e .fbk serão aceitos.


Backup Enviar FTP

Video passo-a-passo para envio de vários arquivos ao FTP da Fiorilli.

Útil para casos em que o arquivo de dados é muito grande e a internet é lenta. Nesse cenário o usuário deve comprimir o arquivo de backup em vários arquivos de tamanho fixo e enviá-los ao FTP da Fiorilli através da função que o video demonstra.

Clique aqui para mais informações sobre backup.


Consulta SQL

Utilitário Emergencial

Instruções para utilização da tela de consulta SQL

Este manual não abordará os conceitos da linguagem SQL, apenas revelará as funções da tela que auxiliam algumas tarefas do suporte técnico.

Usuários que possuem permissão de acesso a esta tela devem utilizá-la apenas sob orientação do suporte técnico.

A primeira função de auxilio é o navegador do histórico de comandos SQL, através dele o usuário pode voltar e executar comandos já digitados. O histórico é influenciado não só pela digitação mas também por arquivos texto carregados, ou seja, ao utilizar o recurso de carregar arquivos contendo comandos SQL o SIP também os armazena no histórico como um novo item, assim como pode salvar o comando atual em arquivo texto. Por fim um item de histórico pode ser excluído, por exemplo, caso esteja obsoleto ou incorreto.

Todo comando executado com sucesso é armazenado no LOG do SIP, independente do histórico, que pode ser excluído.

Comandos SQL que retornam dados podem ser impressos pelo relatório automático do SIP, basta clicar em "Visualizar". Caso o relatório precise de ajustes o usuário pode alterar o layout através do botão "Layout". Por enquanto não é possível salvar o relatório direto no Gerador de Relatórios , assim que identificarmos essa necessidade isso será implementado.

Ainda há a opção de imprimir o comando SQL junto com o relatório, para isto basta checar a opção "Imprimir SQL", observe a imagem abaixo.

O SIP apresenta novos botões quando são executados SQL que retornam dados, observe a imagem abaixo.

O SIP permite que o resultado seja manipulado através da lista de dados, para isso ele disponibiliza os mesmo botões de manutenção presentes nas telas de cadastro padronizadas .

O botão de funções oferece importação e exportação de arquivos XML.

A importação de XML é indicada exclusivamente pelo suporte técnico, mas a operação é muito simples. Imaginemos que o arquivo XML enviado pelo suporte é uma lista numerada do tribunal de contas que teve seu módulo recentemente criado, se esta tabela chamar LISTA_TRIBUNAL_UF, basta digitar o seguinte comando SQL:

Select * From LISTA_TRIBUNAL_UF

Em seguida o usuário deve executar o comando e acionar a opção de importação de XML, se o arquivo for exatamente igual ao resultado do comando o SIP importará seus conteúdo para o banco de dados.

Além de importar arquivos é possível exportar o resultado dos comandos SQL em arquivos XML.

Outra função interessante é a de gerar sequências para filtro, de forma que o usuário possa obter uma lista de registros de trabalhador, por exemplo, através de um SQL complexo para utilizar em telas de cadastro através do Filtro de Pesquisa , ou até mesmo para outro comando SQL de forma a simplificar a operação.

Portanto a opção "Gerar Sequência para Filtro SIP" correspode a condição de filtro "Sequência" do Filtro de Pesquisa ,, já a opção "Gerar Sequência para Filtro SQL" gera para outro SQL. Ou seja dependendo da coluna selecionada, nos resultados do SQL, o SIP irá gerar uma cadeia daquele dado separado por barra contrária para o Filtro de Pesquisa , ou por vírgula para ser utilizado em outro SQL.

Exemplo "Gerar Sequência para Filtro SIP": 000001\000002\000003\000059\000258\025896\000009

Exemplo "Gerar Sequência para Filtro SQL":'000001','000002','000003','000059','000258','025896','000009'

Ambos os resultados gerados por essas opções serão enviados à Área de Transferência do Windows, poranto para visualizá-los basta utilizar o comando "Colar: Control+V" em qualquer ambiente de texto, tal como a própria área de escrita de comandos SQL.


Painel de Opções

Painel de Opções do SIP 7.0
Acesse pelo menu Utilitários

O Painel de Opções deve ser utilizado sempre que o usuário não souber onde encontrar uma tela do sistema. Basta digitar uma palavra no filtro ao lado que serão listados as telas compatíveis.

A listagem pode ser classificada por Contexto, Tipo, Nome, Atalhos ou Recentes

· Contexto: cabe a essa lista os mesmos itens de menu presentes na tela principal, tais como Parâmetros, Manutenção, Cálculo, Mensais, Eventuais, Anuais, etc.

· Tipo: as telas do SIP são divididas em Manutenção, Relatórios e Cálculos, portanto independentemente de onde o relatório está ele será encontrado, por exemplo.

· Nome: com essa opção não é necessário saber o contexto ou o tipo da tela, todas as telas do sistema serão listadas.

· Atalhos: Lista os atalhos criados pelo usuário logado.

· Recentes: Essa classificação lista as últimas telas acessadas pelo usuário logado, classificada por número de acessos decrescentes.

Observe na imagem acima que a lista é agrupada por tipo de tela, isso facilita a organização visual do resultado, que é completo trazendo inclusive layouts de relatórios alterados dentro do SIP e layouts de relatórios criados no Gerador de Relatórios .

É possível ainda criar sua própria lista de atalhos, observe que na tela principal existe um item vazio chamado "Atalhos", caso você os preencha o SIP mostrará sempre seus atalhos primeiro.

Para manipular a lista de atalhos clique no botão "Opções" e selecione o primeiro item "Manutenção de Atalhos". Um quadro será exibido abaixo da lista de telas, arraste as telas desejadas para o quadro e clique em "Concluir".

Observe o video abaixo com instruções passo-a-passo de como criar atalhos personalizados.

Demonstração: passe o mouse

Além de armazenar as telas recentemente acessadas o Painel de Opções possibilita a manutenção desses itens recentes. Através da manutenção é possível excluir algum item ou limpar a lista toda. Para isso basta o usuário clicar no botão "Manutenção" que aparece logo abaixo da lista de classificações, conforme imagem abaixo.

Observe que não é necessário que o Painel de Opções esteja aberto para que o SIP guarde as telas recém acessadas, ou seja, o SIP sempre salva as telas acessadas.


Módulo em 800x600

Opção disponível no menu Utilitários

Esta opção é disponível quando o SIP identifica que a definição de vídeo do computador é superior a 800x600. Com isso o SIP satisfaz usuários que gostam de trabalhar visualizando o papel de parede.

Além disso o SIP salva naquela estação de trabalho o tamanho e a posição do módulo.

Interessante notar que o SIP se comporta de maneira diferente de a cordo a versão do Windows. Caso o SIP identifique que o sistema operacional é superior ao Windows XP ele não maximiza a tela, apenas ajusta seu tamanho a resolução do vídeo, considerando a barra do iniciar, é claro. Dessa forma o SIP mantém o visual agradável de versões como a do Vista, por exemplo, pois do contrário, se o SIP maximizasse o módulo nessas versões, a barra do iniciar ficaria totalmente preta, atrapalhando a vida de quem gosta de apreciar a arte e belo.


Atualizar Conexão

Opção disponível no menu Utilitários

São inúmeros os motivos que podem provocar a perda de conexão com o firebird ou com o SIP-Servidor, em 99,99% dos casos há algum problema na infraestrutura de informática, quando isso ocorre a tela abaixo é exibida.

A tela de falha na conexão disponibiliza três operações. A primeira é visualizar o erro técnico, que consiste em exibir uma caixa de diálogo contendo o erro técnico que deve ser enviado ao seu departamento de informática ou ao suporte técnico. A segunda é tentar novamente realizar a conexão, nesse caso o usuário deve saber que o serviço já foi restaurado e não precisa esperar terminar a contagem regressiva. A terceira opção é fechar o SIP.

A opção de fechar o SIP é por total conta e risco do usuário, pois todos os dados do cadastro ainda não salvos serão perdidos. O recomendável é deixar a contagem regressiva chegar a zero, pois nesse momento o SIP tentará realizar novamente a conexão, se ela ainda estiver inativa a contagem regressiva é reiniciada, esse processo é infinito e garante a gravação dos dados em andamento, ou até mesmo o cálculo assim que o serviço for reestabelecido. Relatórios em processo de geração não são restaurados automaticamente, nesses casos o usuário deve clicar no botão para tentar visualizar novamente.

O SIP administra duas conexões, uma com o SIP-Servidor e outra com o Firebird, como pode ser observado no diagrama de transição, dessa forma podem ocorrer dois tipos de erro técnico:

Erro técnico de falha com a conexão do SIP-Servidor

obs: o número entre parênteses 10061 pode ser outro.

Erro técnico de falha com a conexão do Firebird

obs: a palavra "localhost" da mensagem acima pode ser trocada pelo nome do servidor em que o SIP está instalado.

Por fim a opção "Atualizar Conexão" presente no menu "Utilitários" deve ser acionada quando o usuário não efetuou operações com o servidor e tomou conhecimento de alguma falha de conexão.


Calculadora de Data

Opção disponível no menu Utilitários

A calculadora de data do SIP possui duas funções, a primeira obtém a data final com base no incremento de dias, meses, ou anos. A imagem 1 ilustra o exemplo de cálculo em que há incremento de 90 dias na data inicial, dessa forma é possível encontrar a data do retorno de um possível afastamento sem ter que utilizar a tela de manutenção. A segunda função da calculadora de data é obter a diferença entre a data inicial e a data final, diferença esta dada em dias, meses e anos. A imagem 2 ilustra quantos dias, meses e anos existem entre 01/01/1992 e 02/09/2009, com isso é possível obter o mesmo resultado encontrado no relatório de contagem de tempo de serviço para previdência disponível no menu eventuais do módulo folha. O relatório e a calculadora implementam o mesmo cálculo do site da Previdência Nacional.

A imagem acima ilustra um típico uso da calculadora de dadas. A lista abaixo é o passo-a-passo para esse tipo de operação.

Passo-a-passo

Obter Data Final

1. com o cursor no campo Dt. Tempo Serviço pressione F12. Nesse momento o SIP copia a data para a calcualdora;

2. altere dias, meses ou anos para obter o resultado;

3. arraste a calculadora para o lado;

4. clique dentro do campo Dt. Ctrl. Ref. Sal. (sem fechar a calculadora);

5. feche a calculadora. Nesse momento o resultado será transferido para o Dt. Ctrl. Ref. Sal., pois ela está em branco.

A imagem acima demonstra a obtenção do mesmo resultado calculado pelo relatório de Certidão de Contagem de Tempo de Serviço. Para isto o usuário deve digitar na calculadora a data inicial e a data final do período que consta no relatório, o resultado é obtido imediatamente após o término da digitação da data final.


Atalhos Horizontais

Opção disponível no menu Utilitários

A tela de atalhos horizonais é útil para o usuário visualizar todos os atalhos num só lugar, ao contrário da barra lateral de atalhos que mostra por contexto.


Eventos Circulares

Relação de Eventos Circulares

Opção disponível no menu Utilitários

A relação de eventos circulares demonstra os eventos que compõem base de cálculo cruzada, ou seja, o evento A incide para o evento B ao mesmo tempo que o evento B incide para o evento A.

O problema dos eventos circulares é que eles tornam o cálculo matematicamente impossível, uma vez que o próximo evento é indeterminado com base nos parâmetros informados.

Quando o cálculo do SIP 7 foi projetado existiam dois pré-requisitos fundamentais, o primeiro era que o usuário não poderia informar a ordem dos eventos a serem calculados, a segunda era que o cálculo só poderia ser realizado uma vez por trabalhador. O custo disso foi aceitar o fantasma dos eventos circulares, que na verdade não é tão difícil de resolver. A vantagem disso é a alta performance do cálculo do SIP 7.

A imagem abaixo demonstra o caso forçado para demonstração da emissão do relatório, em que a hora extra incide para afastamento, ou seja, ela está na base de cálculo do evento de afastamento, e o afastamento está na base de cálculo da hora extra.

O efeito dos eventos circulares é a parada imediata do cálculo dos eventos do trabalhador que satisfaz o cenário do relatório. Por exemplo, o trabalhador que começou seu afastamento no mesmo mês que fez hora extra terá apenas o evento de salário base calculado, já que os próximos eventos a serem calculados seriam a hora extra ou o afastastamento, mas como não é possível determinar qual dos dois seria o próximo então o cálculo do trabalhador é abortado. Nenhum erro é emitido e o cálculo pula da fase de cálculo de eventos para a faze final de totalização. Portanto o evento de previdência, que seria calculado por último, também não é calculado.

O cenário acima é chamado de nível 1, mas nem sempre é tão simples, existem os casos chamados de evento circular de nível 2, nível 3 ou até nível N, e infelizmente o relatório ainda não os identifica. Para soluciná-los é muito importante ter em mente o conceito do efeito dos eventos circulares no cálculo.

Portanto quando o efeito dos eventos circulares for identificado e o relatório estiver em branco é grande a chance de se tratar de um caso de eventos circulares de nível 2, nível 3 ou até nível N. Resolver o problema vai depender da sagacidade de quem tiver que solucioná-lo, pois será um trabalho de mineração das configurações dos itens presentes nos eventos fixos, eventuais, afastamento, férias, licença-prêmio, 13º salário, entre outros.


Mensagens Ignoradas

Opção disponível no menu Utilitários

A manutenção de mensagens ignoradas, presente no menu utilitários, permite ao usuário excluir do controle as mensagens que ele uma vez marcou para não serem emitidas novamente.

Observe a imagem abaixo, para marcar uma mensagem a ser ignorada selecione a opção "Não mostrar essa mensagem novamente", em seguida selecione a resposta que deseja que fique gravada.

Quando a mensagem é ignorada o SIP armazena a resposta fornecida pelo usuário e a aplica quando da oportunidade que ela seria novamente emitida.

Portanto, por exemplo, quando o usuário marca para a mensagem da imagem acima ser ignorada e clica no botão "Sim", o SIP sempre salvará as alterações no cadastro de trabalhadores caso o usuário o feche sem salvar ou cancelar a operação de inclusão ou alteração.

Para que a mensagem volte a ser emitida basta o usuário acessar a tela de mensagens ignoradas presente no menu utilitários e excluir a mensagem desejada.


Bloquear Módulo

Opção disponível no menu Utilitários

A opção de bloquear o módulo é útil para empresas que implementam normas de segurança da informação tal como a ISO/IEC 27002. Geralmente a política de mesa limpa e tela limpa está contida nessas normas.

POLÍTICA DE MESA LIMPA E TELA LIMPA

A política de mesa limpa deve ser considerada para os departamentos e utilizada pelos funcionários, de modo que papéis e mídias removíveis não fiquem expostos a acessos não autorizados. A política de tela limpa deve considerar que, se o usuário não estiver utilizando a informação, ela não deve ficar exposta, reduzindo o risco de acesso não autorizado e evitando perda e danos à informação.

Para auxiliar os departamentos de recursos humanos o SIP disponibiliza a opção de bloquear o módulo, ficando assim em conformidade com a política de tela limpa, pois o SIP encobre toda a tela do módulo com uma tela preta e sobre esta disponibiliza a tela de login.

A tela de login que o SIP disponibiliza aceita apenas a senha de confirmação do usuário logado, portanto não é possível trocar de usuário através dessa tela.

Caso a senha seja incorreta ou a tela seja cancelada o SIP é fechado imediatamente, se haviam telas de cadastro não salvas os dados serão perdidos. Por fim um log contendo a invalidade do acesso será gravado.


Configurações

Opção disponível no menu Utilitários

Nesta página:

· Multi-tarefa

· Fundo Preto-Transparente

· Próximo Registro Vago

· Integração Contábil

· Simulação do Cálculo

· Rede

· Referência

· Fonética

Multi-Tarefa

Exibir mais de uma tela ao mesmo tempo

Controla as janelas internas do SIP assim como o Windows controla as aplicações na barra do iniciar. Esta opção é recomendada apenas para estações de trabalho configuradas para utilizar resolução de vídeo superior a 800x600. A imagem abaixo ilustra como o SIP controla várias telas abertas ao mesmo tempo, observe que a tela que o usuário vê no momento é a de visualização do relatório de trabalhadores por evento.

Checagem de cálculo avançada

Além de controlar a abertura de várias telas ao mesmo tempo o SIP também permite que telas de acesso exclusivo abertas a partir do cálculo se transformem em telas de acesso compartilhado. Com isso o usuário pode acessar o movimento de férias a partir da tela do cálculo, e com ela aberta ainda pode manipular a tela do cálculo que ficou por baixo.

Telas de acesso exclusivo são aquelas que o usuário não consegue acessar o restante do módulo sem antes interagir definitivamente com ela.

Fundo Preto-transparente

Auxilia o uso de telas de acesso exclusivo mostrando um fundo preto-transparente entre ela e o módulo, impedindo que o usuário se esqueça de terminar o trabalho da tela aberta.

O fundo preto-transparente pode ter sua intensidade configurada numa escala de 0 a 255, em que 0 representa nenhuma intensidade da cor preta e 255 representa a total intensidade.

Esta função é desconsiderada quando a opção de Checagem de cálculo avançada está ativada.

Próximo registro vago

Na inclusão de novos cadastros o SIP irá indicar o próximo número de código vago e não mais apenas o último número acrescido do número um.

Tome a tabela abaixo como exemplo do cadastro completo de cargos de uma entidade:

Código do Cargo | Nome do Cargo
0001 | Cargo I
0002 | Cargo II
0004 | Cargo III
0005 | Cargo IV

Ao incluir novo cadastro o SIP preenche o código do cargo como sendo o próximo da lista, ou seja, seria o número 0006, porém com esta opção acionada o SIP preencheria com o número 0003, pois é o próximo registro vago.

Integração Contábil - Conexão ao SCPI

O SIP é capaz de ler dados do SCPI que auxiliam a integração contábil. Para isto o SIP tenta localizar a instalação do SCPI no computador, caso ele encontre esta configuração não é necessária. Porém, se o SCPI estiver instalado em outro computador é necessário indicar o arquivo de configurações do SCPI para o SIP através desta configuração.

Portanto basta clicar no botão ao lado e indicar o arquivo scpi.ini de alguma estação que já se conecta ao SCPI.

Permitir Simulação do Cálculo

Opção para exibir botão de simulação na tela do cálculo.

Compartilhamento de Rede (SIP_ARQ)

Informe o caminho do compartilhamento para atualizar os módulos da estação. Ex: \\Servidor\SIP_ARQ

Retornar para a referência MENSAL ao fechar as telas

Opção para o SIP sempre voltar para a referência "Mensal" ao sair das telas.

Habilitar Pesquisa Fonética

Opção para exibir filtro pelo nome de pessoas em telas de manutenção.

A pesquisa fonética é um modelo de pesquisa por troca de caracteres pelo som da letra, dessa forma o nome "Luiz" seria encontrado digitando "Luis" com "s", pois "z" teve som de "s". Já os nomes Camila e Carlos seriam encontrados com a letra "k" no começo.

Ao ativar essa opção o SIP precisa criar a nova fonte de pesquisa para todos os cadastros de pessoas, portanto isso pode demorar dependendo da quantidade.


LOG

Consulta LOG

Opção disponível no menu Utilitários

A função deste módulo é disponibilizar consultas ao LOG do sistema através do Filtro de Pesquisa . O módulo é dividido em duas partes, a primeira é onde o filtro de pesquisa é manipulado, a segunda é onde os resultados do filtro são mostrados.

A tela de resultados também é dividida em duas partes, do lado esquerdo há a lista dos registros de log, do lado direito há o conteúdo do registro de log selecionado.

O comportamento da lista de registros de log é influenciado pelo filtro de pesquisa, de modo que ela ocultará campos mencionados no filtro com a condição "Igual". O único campo que não sofre influência do filtro é a data pois nela está contida a hora.

Quando uma pesquisa é realizada o texto descritivo do filtro é mencionado acima da lista de registros de log.

Por fim o módulo disponibiliza a opção de impressão dos resultados da pesquisa. A impressão é baseada no Gerador de Relatórios e posibilita todas as suas formas de exportação e visualização. Na impressão também é mencionado o texto descritivo do filtro.

O LOG, as vezes, pode ser utilizado como documento legal, para isso o SIP disponibiliza a opções de impressão que auxiliam quando o relatório for anexado a um processo, uma das opções disponíveis é a renumeração de páginas, que consiste na possibilidade de o usuário definir o número da página inicial do relatório do LOG, dessa forma o digitador do processo administrativo pode mencionar o relatório do LOG anexo na página correspondente. Outra opção que auxilia processos legais é a exibição da numeração das linhas do LOG, essa opção é útil para o digitador do processo poder mencionar a linha do conteúdo do LOG que prova a operação.


Corrigir Cidade RAIS

Corrigir Código da Cidade para RAIS

Opção disponível no menu Utilitários

A função dessa tela é possibilitar ao usuário corrigir o código da cidade para RAIS indicado no cadastro da empresa, este que é automaticamente identificado pelo SIP ao incluir, porém existem casos em que a conversão ou o usuário não preenchem corretamente.

A inicialização do SIP tenta identificar alguma divergência entre o nome da cidade fornecido no endereço da empresa e o nome da cidade indicada na RAIS, caso exista alguma divergência o SIP apresenta esta tela para que o código seja corrigido. Essa checagem é realizada apenas entre os meses de janeiro e março.


Listar Módulos

Opção disponível no menu Utilitários

O módulo principal do SIP controla todos os módulos abertos por ele, através desta opção o usuário pode obter uma lista dos módulos abertos.

Caso o usuário tente fechar o módulo principal sem antes fechar os outros módulos o SIP emite um aviso contendo a lista de módulos abertos, através desse aviso o usuário tem a opção de terminar todos os módulos.

O usuário deve ter cuidado quando a estação de trabalho está lenta, pois ao fechar o módulo principal pode ser que algum outro módulo ainda esteja sendo encerrado, nesse caso SIP emitirá o aviso de que ele ainda está em execução, portanto convém que o usuário espere mais alguns segundos, no entanto se isso já tiver sido feito e a mensagem persistir, o usuário pode confirmar a mensagem de encerramento. Se houver freqüência desse cenário o usuário deve entrar em contato com o suporte técnico.


Diferença de Cálculo do SIP 6

Diferença de Cálculo entre o SIP 6 e o SIP 7

Utilitário de Funções pós conversão

Este relatório tem por objetivo encontrar diferenças entre o cálculo do SIP 7 e o SIP 6 logo após a conversão.

Portanto esta função deve ser utilizada imediatamente após a conversão do SIP 6 para o SIP 7, para isto calcule o próximo mês no SIP 6 e no SIP 7 e execute esse utilitário.

O primeiro passo é executar o relatório com as opções padrão, ou seja, conforme a imagem acima. Desta forma o SIP irá apresentar o relatório contendo a lista de eventos que estão diferentes.

Caso as diferenças sejam apenas provenientes de dízimas é possível configurar o relatório para ser emitido com diferenças superiores a um valor informado.

O segundo passo é alterar a opção padrão para "Listar Trabalhadores", desta forma o SIP irá apresentar um campo para especificar o evento, informe nesse campo algum código presente no relatório anterior.

Após o segundo passo o SIP irá listar os trabalhadores que possuem diferença no evento indicado.

Dessa forma é possível rastrear o evento e os trabalhadores que estão com a diferença. Basta agora verificar os motivos que podem ser vários, corrigí-los e abandonar o SIP 6, que nos foi muito útil até então.


Recalcular Abatimentos em Tempo de Serviço

Utilitário de Funções pós conversão

Este utilitário deve ser utilizado para as conversões do SIP 6 que possuem alguma diferença de abatimento no adicional de tempo de serviço, abatimentos esses provenientes de afastamento.

Realize um backup antes de prosseguir.

O SIP irá solicitar a confirmação do usuário. Se positiva o progresso do recálculo poderá ser acompanhado mês a mês. Ao término o SIP solicitará outra confirmação, agora para gravar os dados calculados.


Recalcular Patronal

Utilitário de Funções pós conversão

Este utilitário deve ser utilizado quando o mês convertido foi calculado no SIP 6 e será pago pelo SIP 7 e houve problema na SEFIP referente a patronal.

A tela apresentada contém a lista de vinculos com as alíquotas que compõem a patronal. Altere as taxas se necessário, as porcentagens alteradas não serão gravadas, serão apenas utilizadas para este processo e descartadas. Para alterar definitivamente acesse o cadastro de vinculos.

Ao término o SIP solicitará a confirmação do usuário para gravar definitivamente os dados recalculados no arquivo de movimento. Neste processo o SIP gera LOG de todos os registros de movimento alterados sob responsabilidade do usuário que acionou o utilitário.


Revisar Causas de Desligamento

Utilitário de Funções pós conversão

Este utilitário tem como objetivo criar registros de desligamento que por algum motivo não foram convertidos do SIP 6.

Registro de desligamento são as informações de causa, motivo, data do desligamento entre outros.


Recalcular Dias

Utilitário de Funções pós conversão

Este utilitário deve ser utilizado quando a conversão não detectou corretamente os dias para contagem de avos.

O SIP apresenta uma lista com todas as referências dos tipos (1,6,7) da empresa selecionada, que são os tipos de referência que influenciam na contagem de avos.

O usuário deve selecionar a referência que deseja que o SIP comece a recalcular, visto que o processo é feito seguindo a lista de cima para baixo sempre até o fim. No exemplo da imagem acima o SIP recalculará os meses de novembro, dezembro e janeiro, este último por estar no fim da lista.


Freqüência Faltas

Freqüência de Faltas

Um exemplo da utilização dessa configuração da empresa acontece quando o RH determina aos departamentos ou secretarias que somente aceitará a lista de freqüência até dia 20, fazendo com que os apontadores tenham uma folga para digitar e processar todos esses dados.

Para configurar o sistema conforme o exemplo acima basta indicar no campo "Dia Inicial" o número 20 e no campo "Dia Final" o número 21.

Portanto se uma falta for lançada com data do dia 01/01/2008 ela será descontada no mes de janeiro, já se ela for lançada com data do dia 25/01/2008 ela será descontada no mês de fevereiro, pois qualquer data entre o dia 21 e o fim do mês será processada no mês seguinte.

Mas atenção, caso a empresa não tenha esse tipo de controle não informe o número 1 no campo "Dia inicial" e o número 30 no campo "Dia final" pois essa configuração fará com que um lançamento no dia 01/01/2008 seja processado em fevereiro. Esses são casos em que a empresa processa com um mês de folga, pois a quantidade de lançamentos a serem processados é muito grande ou maior que a capacidade do departamento.

Para que um lançamento em 01/01/2008 seja processado em janeiro basta deixar os dois campos em branco.


Progressão Salarial Automática

Existem duas maneiras de um trabalhador receber aumentos automáticos no SIP com base numa quantidade de tempo em anos: Através da progressão salarial ou através de fórmula de cálculo de tempo de serviço.

Para que o SIP atualize a referência salarial atual do cadastro do trabalhador com sucesso as seguintes configurações devem ser realizadas:

Cadastro da empresa:

no cadastro da empresa, na guia "cálculos" o usuário deve habilitar a opção "Mudar Referência de Salário Automaticamente" e informar o tempo em anos para cada progressão.

Cadastro do vínculo:

no cadastro do vínculo basta que o usuário habilite a opção "Mudar Ref. Salarial Automático".

Cadastro de cargos:

no cadastro do cargo o usuário deve configurar os cargos que possuem progressão salarial e informar dentro deles por quais referências salariais ele é composto e na ordem crescente de salto.

Além de relacionar as referências salariais de cada cargo o usuário deve, também, habilitar a opção "Mudar Ref. Salarial Automaticamente" conforme ilustra a imagem abaixo:

o campo "Tempo em Anos" presente no cadastro de cargos deverá ser preenchido somente se a quantidade for diferente da já informada na empresa.

O relatório da progressão salarial pode ser encontrado no menu mensais.


Média Rescisão para Cálculo Proporcional

Essa opção deve ser utilizada para adequar o cálculo da rescisão de 13º Salário Proporcional e Férias Proporcional.

Para o seguinte cenário (fictício):

Admissão: 02/04/2008

Desligamento: 12/06/2008

Base para média: 500,00

Divisor: Meses Trabalhados

500,00 / 2 = 250,00

Apenas depois do cálculo da média é que será aplicado os avos:

(250,00 / 12) * 2 = 41,66

Divisor: 12

500,00 / 12 = 41,66

Apenas depois do cálculo da média é que será aplicado os avos:

(41,66 / 12) * 2 = 1,73


Casos de Demons. 13º Salário

Casos de Demonstração de 13º Salário

Tome como base o recibo mensal abaixo:

Descrição dos eventos relevantes
Evento | Base | Incide para 13º Salário | Incide para Média | Informa no 13º Salário
Salário Base | referência salarial | Sim | Não | Não
Adicional de Tempo de Serivço | 1% a.a. sobre a referência salarial | Sim | Sim | Não
Sexta Parte | 1/6 a cada 20 anos sobre 001+050 | Sim | Não | Não
Insalubridade 40% | 40% sobre a referência salarial | Sim | Sim | Não
O valor da média apurado no exercício é 211,19

Abaixo serão listados sete formas de demonstração de adiantamento de 13º Salário.

Para o fechamento do 13º Salário as demonstrações serão as mesmas, apenas o evento 912 será trocado pelo evento 911, e o evento 931 será trocado pelo evento 935.

1º Forma de Configuração

2º Forma de Configuração[1]

3º Forma de Configuração

4º Forma de Configuração

5º Forma de Configuração

6º Forma de Configuração

7º Forma de Configuração[1]

[1] Observe que se a empresa "não" estiver configurada para calcular média, os eventos que "estão" configurados para incidir para média "não" serão calculados, que são os casos demonstrados nas formas 2 e 7.


Licença Prêmio

Licença Prêmio, no SIP 7, não possui um tipo de folha/cálculo separado como há para as férias, pois Licença Prêmio tem conceitos de afastamento e férias juntos.

Para calcular uma LP basta calcular o mensal do trabalhador selecionado. Os parâmetros necessários estão na empresa, no vínculo, no trabalhador e na incidência dos eventos.

na empresa:

Informe se há média de eventos para ser calculada. Parece redundância mas essa opção aumenta a velocidade do cálculo evitando que ele busque por eventos que fazem média ao longo do período aquisitivo, o que seria muito dispendioso já que eles variam em torno de cinco anos.

Indique quais classificações de eventos de falta serão considerados para que o SIP apure o direito em dias de gozo. Para isso existe uma tabela escalonada por vínculo RAIS idêntica a das férias no menu parâmetros, opção Duração do Gozo conforme falta.

no vinculo:

Na página 4 indique se é permitido o cálculo de LP, a quantidade de anos que compete ao período aquisitivo, os dias de gozo e o máximo de pecúnia permitido.

no trabalhador:

clique no botão [image] para exibir e manipular os períodos aquisitivo e movimentação de pagamento de pecúnia e gozo.

o conceito para lançamento é quase o mesmo das férias, a diferença é que o período de pagamento só deve ser informado para quando a pecúnia deve ser paga, já o período de gozo é que determina o pagamento da licença propriamente dita.

para geração de recibo de adiantamento basta indicar a opção de mesmo nome no grupo da pecúnia da tela de lançamento, calcule a folha mensal e em seguida acesse o recibo pelo menu Mensais opção Recibo Pecuniário Licença Prêmio.


Rateio

Instruções específicas para cálculo do rateio no SIP 7

Rateio é um cálculo automático realizado quando a opção "Informar Custeio Alternativo" da empresa está acionada. A imagem abaixo ilustra o cadastro da empresa.

Ao acionar esta opção o usuário obterá um novo campo no cadastro de eventos, trata-se da configuração de rateio do evento, através dela é possível indicar se o evento é base de cálculo para rateios, é rateado ou não participa de rateios. A imagem abaixo ilustra a nova opção do evento. Qualquer evento, até mesmo os eventos automáticos, podem ter esta opção configurada.

Outro campo que será exibido apenas se a empresa estiver configurada é o campo "Ratear" do trabalhador, através desta nova opção o usuário informa se o cálculo irá ratear os eventos do trabalhador. A imagem abaixo ilustra a opção disponível na ficha "Cálculo" dos dados cadastrais.

Ao lançar eventos configurados como base de cálculo de rateio o usuário deverá informar a unidade de custeio daquele lançamento. A imagem abaixo ilustra o lançamento de eventos fixos.

Portanto para eventos configurados para ratear ou para eventos configurados para nenhum rateio a informação da unidade é desnecessária.

Finalmente após as configurações e lançamentos o SIP irá calcular o rateio dos eventos durante o próprio cálculo normal de qualquer referência. Portanto nenhuma tela especial é necessária para o cálculo do rateio.

A imagem abaixo ilustra o cadastro de eventos fixos dos exemplos que virão a seguir.

Observe que trata-se de um professor que ministra aulas de matemática em três cursos diferentes, a unidade de custeio principal, ou seja, aquela indicada no cadastro do trabalhador foi escolhida para ser a matemática de forma arbritrária pois não há relação com o fato do evento 001 ser o salário da matemática.

Este professor ministra aulas de matemática nos cursos de graduação de matemática, computação e engenharia, trabalhando 90, 100 e 30 horas em cada curso respectivamente. Os três salários base deste professor estão configurados para serem base de cálculo para rateio, por isso que suas unidades de custeio estão informadas no cadastro de eventos fixos, já o evento de insalubridade está configurado para ratear, portanto a unidade de custeio é desnecessária.

Ao calcular este registro o SIP produzirá o rateio da insalubridade nas unidades indicadas, mas observe que não há relação direta com o cadastro de eventos fixos, não importa onde o evento está lançado, o que importa é como ele está configurado. Portanto se houvece algum outro evento lançado nos eventuais diversos como base de cálculo de rateio na unidade "Manutenção", a insalubridade também seria rateada para esta unidade.

A tela de cálculo disponibiliza um extrato específico para trabalhadores que participam de rateio, através dele o usuário poderá realizar os cálculos necessários para a checagem dos resultados do SIP. Para mais informações sobre o extrato do rateio consulte o tópico aqui .

Por fim o resumo contábil permitirá a emissão do agrupamento de unidades de custeio rateadas. A opção da imagem abaixo será exibida se a empresa estiver configurada e estará disponível apenas para o agrupamento de unidades de custeio.


Folha Complementar Mensal

Folha complementar é um tipo de cálculo especial que pode e deve ser pago e empenhado imediatamente. É utilizado quando, por exemplo, houve um erro na apuração do cartão de ponto e os trabalhadores ficaram sem receber horas-extras, ou então quando houve um aumento retroativo do salário base.

Nesse caso o usuário deve utilizar o cálculo da folha complementar para pagar imediatamente o valor devido, este tipo de cálculo possui seu próprio crédito bancário e seu próprio resumo contábil, podendo ser realizado não por mês mas por data.

Nenhum encargo será calculado na folha complementar pois eles serão apurados apenas no cálculo mensal posterior, e para isso é necessário uma configuração de eventos.

Existem dois tipos de demonstração, o primeiro exibe no cálculo mensal posterior evento por evento, o outro exibe apenas um evento que agrupa todos os diferenças/valores pagos.

Existem, também, dois tipos de cálculo, aquele que o usuário indica ao sistema qual evento deve ser pago e aquele que o usuário quer que o sistema pague a diferença de qualquer evento.

Indicando Evento ao Sistema:

Primeiro é necessário configurar a empresa, para isso acesse o cadastro da empresa, vá até a guia "Folha Complementar" e altere o campo "Tipo Folha Complementar" para a opção "1 - Somente Eventuais" conforme imagem abaixo:

Em seguida acesse a manutenção "Eventuais de Folha Complementar", trata-se de uma tela de lançamento simples porém o usuário deve prestar muita atenção na data que será colocada no campo "Data Pagto.", pois ela deve ser exatamente igual a data do pagamento indicada na tela do cálculo.

Pronto, basta calcular que apenas o evento indicado será pago, neste exemplo criei o evento com 150% sobre os eventos fixos.

Para emissão do recibo desse tipo de pagamento recomendamos utilizar o modelo administrativo, mas como em todos os outros relatórios dos sistema o usuário pode criar ou alterar conforme sua necessidade.

Observe que é muito importante preencher o parâmetro da data de pagamento do recibo exatamente igual a do lançamento e do cálculo, não somente deste relatório mas em qualquer outra funcionalidade oriunda dessa operação, tais como a folha analítica, o crédito bancário, resumo contábil, etc.

Calculando a diferença de qualquer evento:

Para esse exemplo temos o seguinte cenário: uma nova vantagem foi adicionada aos trabalhadores de determinada categoria porém houve uma falha ao não indicar que esse novo evento faria parte da base de cálculo das horas-extras, ou seja, todos que receberam horas-extras receberam a menor.

Para pagar a diferença basta corrigir a base de cálculo das horas-extras e calcular a folha complementar, ou seja, não é necessário indicar qual evento deverá ser pago pois alguns receberam hora-extra 50% outros 40% e assim por diante.

Antes de calcular altere na empresa para o tipo de folha complementar dois ou três.

Demonstrando folha complementar:

A demonstração da folha complementar é feita geralmente no mês posterior ao seu cálculo, porém é possível indicar outro, essa configuração é feita na tela do cálculo conforme imagem abaixo:

Além de configurar o mês que será demonstrado é necessário configurar na empresa se haverá de fato demonstração, para isso acesse o cadastro da empresa na guia "Folha complementar" e marque a opção "Discriminar Eventos da Folha Complementar na Folha Posterior". Essa opção é necessária para pagamentos que judicialmente ou legalmente não sofrem incidência de encargos não sendo, portanto, necessário a demonstração no mês posterior.

Esse procedimento é necessário para que a folha processe os encargos, mas antes é necessário configurar os eventos de demonstração, conforme botão de mesmo nome na imagem acima.

Antes de continuar vamos definir como os três tipos de folha complementar influenciam na demonstração. O primeiro utilizará a demonstração evento a evento, ou seja, para cada evento pago em folha complementar é necessário indicar um que o representará na folha mensal indicada como provento e outro como desconto conforme imagem abaixo:

Para esse exemplo as incidências do evento 038 devem ser iguais as do evento 005, já o evento 168 deve ter nenhuma incidência.

Concluindo o exemplo o cálculo mensal ficaria conforme a imagem abaixo:

O resultado acima será proveniente da configuração dos tipos de folha complementar 1 e 2, já o 3 não leva em consideração cada evento pago na folha complementar, ele agrupa todos os eventos em uma única demonstração de provento e outra de desconto. O único problema de se demonstrar dessa maneira são as incidências.

A imagem abaixo mostra a tela de configuração dos eventos que irão agrupar a demonstração:

Comparando eventos específicos:

Outra funcionalidade é a indicação de quais eventos específicos devem ser monitorados/comparados pelo cálculo da folha complementar, ela permanece oculta até que a opção "3 - Geral um evento" seja acionada. Essa configuração também é feita na tela do cálculo conforme imagem abaixo:

Ao acionar o botão indicado a tela abaixo será exibida, basta listar os eventos que devem ser comparados no cálculo da folha complementar.

Caso nenhum evento seja informado o SIP irá comparar todos.


Folha Complementar de Rescisão

Folha complementar de Rescisão é um tipo de cálculo especial que pode e deve ser pago e empenhado imediatamente. É utilizado quando, por exemplo, houve um erro na apuração do cartão de ponto e os trabalhadores ficaram sem receber horas-extras.

Nesse caso o usuário deve utilizar o cálculo da folha complementar para pagar imediatamente o valor devido em atraso, este tipo de cálculo possui seu próprio crédito bancário e seu próprio resumo contábil, podendo ser realizado não por mês mas por data.

Diferentemente da Folha Complementar Mensal os encargos serão calculados na folha complementar de rescisão, pois não há configuração de demonstração posterior.

Existem, dois tipos de cálculo, aquele que o usuário indica ao sistema qual evento deve ser pago e aquele que o usuário quer que o sistema pague a diferença de qualquer evento (para mais detalhes sobre a configuração e utilização dessas opções clique aqui ).

Caso o parâmetro da empresa esteja indicando que o cálculo é feito por evento digitado (imagem abaixo), basta proceder a digitação dos eventos desejados na manutenção de "Eventuais - Folha Complementar".

Para esse modelo de cálculo é obrigatório que o usuário "posicione" a tela de cálculo no mês/ano que será pago a diferença, ou seja, para um caso de rescisão no mês de junho que será pago no mês de julho o cálculo deve ser feito em julho.

Caso o parâmetro da empresa esteja indicando que o cálculo é feito por comparação é obrigatório que o usuário "posicione" a tela de cálculo no mês/ano da data de rescisão. Porém o cálculo será gravado no mês/ano da data de pagamento indicada na tela do cálculo.


Margem Consignável - Configuração

Margem Consignável

Instruções específicas para configuração da margem consignável no SIP 7

Trata-se da emissão de uma declaração que atesta que o trabalhador possui capacidade financeira disponível no seu holerite. Esta declaração é destinada a entidades financeiras ou do comércio que desejam garantias do trabalhador para abertura de crédito ou concessão de empréstimo.

Para determinar a capacidade financeira do trabalhador o usuário do SIP 7 deve criar um evento classificado como base de cálculo e montar a fórmula necessária, geralmente é 30% das vantagens fixas. Após incluir o evento o usuário deve informar o número desse evento dentro do cadastro da empresa no campo "Evento Teto para desconto de convênios" disponível na guia "Outros".

Em seguida o usuário pode incluir o evento no cadastro de eventos fixos dos trabalhadores, calcular o mês, para então finalmente emitir a declaração da margem consignável disponível no menu eventuais. Toda declaração que for emitida com autenticação pode ser verificada no controle de margem consignável presente no menu manutenção.

Somente eventos classificados como convênio/consignação serão somados para verificar a margem consignável.


Margem Consignável - Relatório

Margem Consignável

Instruções específicas para emissão da declaração de margem consignável no SIP 7

O relatório da margem consignável pode ser emitido na forma de listagem ou na forma de declaração, esta última pode ser impressa com o código de controle de autenticidade, que é um número gerado pelo sistema para atestar futuramente o conteúdo da declaração.

O número de autenticação é gerado para cada emissão da declaração, mesmo que a declaração seja idêntica.

A listagem contém todos os dados financeiros da declaração com totalização ao final, o que pode ser utilizado pela empresa para negociações com entidades financeiras.

O SIP disponibiliza um modelo de declaração genérico mas pode ser alterado, assim como qualquer relatório do sistema através da criação de novos layouts .

O cálculo do valor disponível é dado pela seguinte fórmula: (margem consignável bruta - total consignado), no qual a margem consignável bruta é o valor calculado pelo evento indicado no cadastro da empresa, e o total consignado é a soma dos eventos classificados como convênio no cadastro de eventos.

Para instruções sobre configuração da margem consignável clique aqui .

Para instruções sobre verificação de autenticidade da declaração clique aqui .


Margem Consignável - Verifica Autenticação

Margem Consignável

Instruções específicas para verificação da autenticiade da declaração de margem consignável no SIP 7

Para verificar a autenticidade da declaração o usuário deve acessar a tela "Margem Consignável - Verifica Autenticidade" disponível no menu "Manutenção" do módulo folha.

Através dessa tela o usuário pode informar o código do controle de autenticidade e verificar o conteúdo da declaração, bem como a data, a hora e o usuário que a emitiu. Alternativamente ao parâmetro do código o usuário pode informar diversos outros através do filtro de pesquisas que contém desde o nome do usuário até o mês, ano e data de emissão, entre outros.

A tela de verificação de autenticidade é, visualmente, uma tela de manutenção comum, porém nela é permitido apenas a exclusão de uma autenticação, embora os botões de inclusão e alteração estejam disponíveis.


TCE-MT

TCE-MT - Sigla Orgão

Esta opção é utilizada para entidades que enviam o SAGRES com o mesmo número do CNPJ em bancos de dados separados.

Ao preencher esta esta opção, o sistema irá enviar a "Sigla" mais o código de identificação da "Matrícula ou Inscrição Previdenciária", "Código de Identificação do Cargo, Função ou Emprego" e "Código de Identificação da Lotação", conforme solicitado no layout dos arquivos a serem importados no SAGRES.

OBS. Esta opção foi criada para evitar as duplicidades nos registros.


FAQ - TI

Dúvidas sobre instalação/atualização/configuração

Calculo:

· Internal gds software consistency check (can't continue after bugcheck)

· base de dados com problemas - realizar backup/restore.

· instalação do firebird errada - reinstalar Firebird 1.5.3.4870 PT-BR disponível no site.


FAQ - Folha

Dúvidas sobre Falhas nas Operações

Gerar Períodos Aquisitivos:

· Violação de Chave

· Ordem do campo Aquisitivo Inicial está diferente do campo Item

Adiantamento de 13º Salário não calcula no Mensal:

· Verificar incidência dos eventos

· Verificar campos de configuração no cadastro do trabalhador

· se está configurado para calcular no mês do aniversário

· se está configurado para calcular após um ano de admissão

· Verificar Vinculo

· Verificar Categoria SEFIP

· Veriricar Empresa

Duração do gozo das férias conforme faltas não funciona:

· Verificar o campo Vinculo-RAIS do cadastro de vinculos pois pode estar diferente do indicado na tabela escalonada, pois essa última está relacionada ao campo Vinculo-RAIS e não ao código do vinculo.


Dicas e Truques

Dicas e Truques do SIP

Atalhos, Menus de Contexto e Teclas Escondidas

que facilitam a operação